LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   How to update BIND ./etc/bind/db.coaxcables (https://www.linuxquestions.org/questions/debian-26/how-to-update-bind-etc-bind-db-coaxcables-421252/)

AndeAnderson 03-03-2006 09:35 AM

How to update BIND ./etc/bind/db.coaxcables
 
I just finished rebuilding a M$ Small Business Server 2003 because of User corrupted files.

I have a Debian Web Server for hosting our website internally.

The SBS name was changed from coaxserver1.coaxcables.com to coaxserver1.coaxcables.local due to conflicts and email problems.

What do I need to do to change/correct the BIND9 configuration for this server name change and to have the coaxcables.com point to 192.168.2.3 internally. I have a firewall and it is already reconfigured.

The original db file is named db.coaxcables. Here is the file as it exists:
________________________________________________

login as: root
Using keyboard-interactive authentication.
Password:
Last login: Fri Mar 3 08:47:23 2006 from coax99.coaxcables.local
coaxwww:~# mc
File: db.coaxcables Col 0 2056 bytes 0%
$ORIGIN .
$TTL 3600 ; 1 hour
coaxcables.com IN SOA coaxserver1.coaxcables.com. hostmaster. (
855 ; serial
900 ; refresh (15 minutes)
600 ; retry (10 minutes)
86400 ; expire (1 day)
3600 ; minimum (1 hour)
)
NS coaxserver1.coaxcables.com.
$TTL 600 ; 10 minutes
A 4.2.2.1
A 192.168.2.254
$TTL 3600 ; 1 hour
MX 10 mail.coaxcables.com.
$ORIGIN coaxcables.com.
_msdcs NS coaxserver1
$ORIGIN _tcp.Default-First-Site-Name._sites.coaxcables.com.
$TTL 600 ; 10 minutes
_gc SRV 0 100 3268 coaxserver1.coaxcables.com.
_kerberos SRV 0 100 88 coaxserver1.coaxcables.com.
_ldap SRV 0 100 389 coaxserver1.coaxcables.com.
$ORIGIN _tcp.coaxcables.com.
_gc SRV 0 100 3268 coaxserver1.coaxcables.com.
_kerberos SRV 0 100 88 coaxserver1.coaxcables.com.
_kpasswd SRV 0 100 464 coaxserver1.coaxcables.com.
_ldap SRV 0 100 389 coaxserver1.coaxcables.com.
$ORIGIN _udp.coaxcables.com.
_kerberos SRV 0 100 88 coaxserver1.coaxcables.com.
_kpasswd SRV 0 100 464 coaxserver1.coaxcables.com.
$ORIGIN coaxcables.com.
$TTL 1200 ; 20 minutes
coax12 A 192.168.2.55
coax15 A 192.168.2.67
coax20 A 192.168.2.68
coax22 A 192.168.2.65
coax24 A 192.168.2.24
coax31 A 192.168.2.50
coax4 A 192.168.2.63
coax5 A 192.168.2.60
coax6 A 192.168.2.61
coax7 A 192.168.2.57
Coax8 A 192.168.2.52
coax9 A 192.168.2.53
coax99 A 192.168.2.56
$TTL 3600 ; 1 hour
COAXSERVER1 A 192.168.2.254
companyweb CNAME coaxserver1
$TTL 600 ; 10 minutes
DomainDnsZones A 4.2.2.1
A 192.168.2.254
$ORIGIN DomainDnsZones.coaxcables.com.
_ldap._tcp.Default-First-Site-Name._sites SRV 0 100 389 coaxserver1.coaxcables.com.
_ldap._tcp SRV 0 100 389 coaxserver1.coaxcables.com.
$ORIGIN coaxcables.com.
ForestDnsZones A 4.2.2.1
1Help 2UnWrap 3Quit 4Hex 5Line 6RxSrch 7Search 8Raw 9Unform 10Quit
login as: root
Using keyboard-interactive authentication.
Password:
Last login: Fri Mar 3 08:47:23 2006 from coax99.coaxcables.local
coaxwww:~# mc
File: db.coaxcables Col 0 2056 bytes 0%
$ORIGIN .
$TTL 3600 ; 1 hour
coaxcables.com IN SOA coaxserver1.coaxcables.com. hostmaster. (
855 ; serial
900 ; refresh (15 minutes)
600 ; retry (10 minutes)
86400 ; expire (1 day)
3600 ; minimum (1 hour)
)
NS coaxserver1.coaxcables.com.
$TTL 600 ; 10 minutes
A 4.2.2.1
A 192.168.2.254
$TTL 3600 ; 1 hour
MX 10 mail.coaxcables.com.
$ORIGIN coaxcables.com.
_msdcs NS coaxserver1
$ORIGIN _tcp.Default-First-Site-Name._sites.coaxcables.com.
$TTL 600 ; 10 minutes
_gc SRV 0 100 3268 coaxserver1.coaxcables.com.
_kerberos SRV 0 100 88 coaxserver1.coaxcables.com.
_ldap SRV 0 100 389 coaxserver1.coaxcables.com.
$ORIGIN _tcp.coaxcables.com.
_gc SRV 0 100 3268 coaxserver1.coaxcables.com.
_kerberos SRV 0 100 88 coaxserver1.coaxcables.com.
_kpasswd SRV 0 100 464 coaxserver1.coaxcables.com.
_ldap SRV 0 100 389 coaxserver1.coaxcables.com.
$ORIGIN _udp.coaxcables.com.
_kerberos SRV 0 100 88 coaxserver1.coaxcables.com.
_kpasswd SRV 0 100 464 coaxserver1.coaxcables.com.
$ORIGIN coaxcables.com.
$TTL 1200 ; 20 minutes
coax12 A 192.168.2.55
coax15 A 192.168.2.67
coax20 A 192.168.2.68
coax22 A 192.168.2.65
coax24 A 192.168.2.24
coax31 A 192.168.2.50
coax4 A 192.168.2.63
coax5 A 192.168.2.60
coax6 A 192.168.2.61
coax7 A 192.168.2.57
Coax8 A 192.168.2.52
coax9 A 192.168.2.53
coax99 A 192.168.2.56
$TTL 3600 ; 1 hour
COAXSERVER1 A 192.168.2.254
companyweb CNAME coaxserver1
$TTL 600 ; 10 minutes
DomainDnsZones A 4.2.2.1
A 192.168.2.254
$ORIGIN DomainDnsZones.coaxcables.com.
_ldap._tcp.Default-First-Site-Name._sites SRV 0 100 389 coaxserver1.coaxcables.com.
_ldap._tcp SRV 0 100 389 coaxserver1.coaxcables.com.
$ORIGIN coaxcables.com.
ForestDnsZones A 4.2.2.1
____________________________________________________

As you can see this db file points to a name that doesn't exist anymore and the work station IP's have changed also.

I forgot to add the named.conf file:
____________________________________________________
login as: root
Using keyboard-interactive authentication.
Password:
Last login: Fri Mar 3 08:47:23 2006 from coax99.coaxcables.local
coaxwww:~# mc
File: named.conf Col 0 1746 bytes 0%
// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";

// prime the server with knowledge of the root servers
zone "." {
type hint;
file "/etc/bind/db.root";
};

// be authoritative for the localhost forward and reverse zones, and for
// broadcast zones as per RFC 1912

zone "localhost" {
type master;
file "/etc/bind/db.local";
};

zone "coaxcables.com" {
type slave;
masters { 192.168.2.254; };
file "/etc/bind/db.coaxcables";
};

zone "127.in-addr.arpa" {
type master;
file "/etc/bind/db.127";
};

zone "0.in-addr.arpa" {
type master;
file "/etc/bind/db.0";
};

zone "255.in-addr.arpa" {
type master;
file "/etc/bind/db.255";
};

zone "192.in-addr.arpa" (
);


// zone "com" { type delegation-only; };
// zone "net" { type delegation-only; };

// From the release notes:
// Because many of our users are uncomfortable receiving undelegated answers
// from root or top level domains, other than a few for whom that behaviour
// has been trusted and expected for quite some length of time, we have now
_____________________________________________________________

Thanks for any assistance you can provide.


All times are GMT -5. The time now is 11:18 AM.