LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-13-2004, 05:44 PM   #1
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Rep: Reputation: 30
How to set FQDN in debian?


http://www.debian.org/doc/manuals/re...ateway.en.html

10.3.1 Hostname

A Debian system sometimes needs to identify itself by name. For this purpose a hostname is maintained by the kernel.

The initscript /etc/init.d/hostname.sh sets the hostname at boot time (using the hostname command) to the name stored in /etc/hostname. This file should contain only the hostname, not a fully qualified domain name.

To print out the current hostname run hostname without an argument.

As stated in the Debian reference, /etc/hostname only contain hostname. How should I go about configuring a FQDN?

Thanks
 
Old 04-13-2004, 08:30 PM   #2
llamakc
Member
 
Registered: Nov 2003
Distribution: Debian & Ubuntu
Posts: 402

Rep: Reputation: 31
/etc/hosts is your place. But I must ask what are you setting it for? Your mailserver will have its own config file (/etc/exim/exim.conf for default) as will apache (/etc/apache/httpd.conf) with unique syntax. Here's my /etc/hosts

Code:
[ken:ken](09:26 PM)$ cat /etc/hosts
127.0.0.1       llamakc localhost
xxx.xxx.xxx.xxx llamakc llamakc.org
192.168.0.103   uma
192.168.0.101   polly
128.186.86.136  skoolio
# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
I used xxx.xxx.xxx.xxx b/c I'm on a dynamic IP and it friggin' rotates all the time. I don't actually have that entry in my /etc/hosts though. I included it as an example.

Unless you run your own dns servers you won't need to config it, your FQDN needs to be on your name servers, and your services set up to respond properly.

Do you have a more specific question?
 
Old 04-14-2004, 05:36 AM   #3
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Original Poster
Rep: Reputation: 30
It is because of the following error I get when starting squid:

david:/var/log# squid
FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.5.STABLE5): Terminated abnormally.
CPU Usage: 0.010 seconds = 0.000 user + 0.010 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 260
Aborted

Any advice? Thanks

Quote:
Originally posted by llamakc
/etc/hosts is your place. But I must ask what are you setting it for? Your mailserver will have its own config file (/etc/exim/exim.conf for default) as will apache (/etc/apache/httpd.conf) with unique syntax. Here's my /etc/hosts

Code:
[ken:ken](09:26 PM)$ cat /etc/hosts
127.0.0.1       llamakc localhost
xxx.xxx.xxx.xxx llamakc llamakc.org
192.168.0.103   uma
192.168.0.101   polly
128.186.86.136  skoolio
# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
I used xxx.xxx.xxx.xxx b/c I'm on a dynamic IP and it friggin' rotates all the time. I don't actually have that entry in my /etc/hosts though. I included it as an example.

Unless you run your own dns servers you won't need to config it, your FQDN needs to be on your name servers, and your services set up to respond properly.

Do you have a more specific question?
 
Old 04-14-2004, 05:47 AM   #4
llamakc
Member
 
Registered: Nov 2003
Distribution: Debian & Ubuntu
Posts: 402

Rep: Reputation: 31
Edit squid's configuration files and specifically the variable it spits out in the logs. Look in /etc.
 
Old 04-14-2004, 06:37 AM   #5
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Original Poster
Rep: Reputation: 30
Thank you

Last edited by davidas; 04-14-2004 at 09:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
iptables+FQDN roopunix Linux - Networking 5 07-12-2005 08:10 AM
ip as my fqdn? sortia Linux - Networking 6 04-27-2005 09:46 AM
Fqdn ziox Linux - Networking 0 10-06-2004 05:46 PM
FQDN - not darb Linux - General 1 10-04-2004 03:57 PM
what should i set a local FQDN to? vrillusions Linux - Newbie 1 02-09-2003 03:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration