LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 12-10-2016, 12:55 AM   #1
hack3rcon
Senior Member
 
Registered: Jan 2015
Posts: 1,432

Rep: Reputation: 10
Post How to install "libssl0.9.8" ?


Hello.
I use Debian 8.6 amd64 and I like to install "libssl0.9.8" but this package not found!!!
Code:
$ sudo apt-get install libssl0.9.8
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libssl0.9.8 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libssl0.9.8' has no installation candidate
Thank you.
 
Old 12-10-2016, 01:22 AM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,517

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
do not add the version
i use " su -" and not sudo
Code:
su -

apt-get update 
apt-get upgrade
apt-get install libssl
 
Old 12-10-2016, 05:27 AM   #3
hack3rcon
Senior Member
 
Registered: Jan 2015
Posts: 1,432

Original Poster
Rep: Reputation: 10
Quote:
Originally Posted by John VV View Post
do not add the version
i use " su -" and not sudo
Code:
su -

apt-get update 
apt-get upgrade
apt-get install libssl
Thank you a lot and result is:
Code:
$ sudo apt-get install libssl
[sudo] password for jason: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libssl
My sources.list is:
Code:
# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 DVD Binary-1 20160917-14:25]/ jessie contrib main 

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official amd64 DVD Binary-1 20160917-14:25]/ jessie main contrib 

deb http://security.debian.org/ jessie/updates main contrib 
deb-src http://security.debian.org/ jessie/updates main contrib 

# jessie-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.

deb http://ftp.debian.org/debian/ jessie-updates contrib main 
deb-src http://ftp.debian.org/debian/ jessie-updates contrib main 

##############################

# deb http://httpredir.debian.org/debian/ jessie main 
# deb-src http://httpredir.debian.org/debian/ jessie main 

# deb http://httpredir.debian.org/debian/ jessie-updates main 
# deb-src http://httpredir.debian.org/debian/ jessie-updates main 


################################

deb http://httpredir.debian.org/debian/ jessie main contrib non-free 
deb-src http://httpredir.debian.org/debian/ jessie main contrib non-free 

deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free 
deb-src http://httpredir.debian.org/debian/ jessie-updates main contrib non-free 

##################################
deb http://ftp.debian.org/debian jessie-backports main
 
Old 12-10-2016, 04:10 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,517

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
then do a normal everyday search for the name , i might be slightly different
-- and it is
Code:
apt search libssl 

libssl1.0.0/stable,now 1.0.1t-1+deb8u5 amd64 [installed]
  Secure Sockets Layer toolkit - shared libraries
so run
Code:
apt-get install libssl1.0.0
 
Old 12-11-2016, 07:00 AM   #5
hack3rcon
Senior Member
 
Registered: Jan 2015
Posts: 1,432

Original Poster
Rep: Reputation: 10
Quote:
Originally Posted by John VV View Post
then do a normal everyday search for the name , i might be slightly different
-- and it is
Code:
apt search libssl 

libssl1.0.0/stable,now 1.0.1t-1+deb8u5 amd64 [installed]
  Secure Sockets Layer toolkit - shared libraries
so run
Code:
apt-get install libssl1.0.0
I did:
Code:
$ apt search libssl 
Sorting... Done
Full Text Search... Done
cl-plus-ssl/stable 20140826-1 all
  Common Lisp interface to OpenSSL

dcmtk/stable 3.6.0-15+b1 amd64
  OFFIS DICOM toolkit command line utilities

dlang-openssl/stable 1.0.0e-1 all
  D version of the C headers for openssl

libdcmtk2/stable 3.6.0-15+b1 amd64
  OFFIS DICOM toolkit runtime libraries

libdcmtk2-dev/stable 3.6.0-15+b1 amd64
  OFFIS DICOM toolkit development libraries and headers

libssl-dev/stable 1.0.1t-1+deb8u5 amd64
  Secure Sockets Layer toolkit - development files

libssl-doc/stable 1.0.1t-1+deb8u5 all
  Secure Sockets Layer toolkit - development documentation

libssl-ocaml/stable 0.4.7-1 amd64
  OCaml bindings for OpenSSL (runtime)

libssl-ocaml-dev/stable 0.4.7-1 amd64
  OCaml bindings for OpenSSL

libssl1.0.0/stable,now 1.0.1t-1+deb8u5 amd64 [installed]
  Secure Sockets Layer toolkit - shared libraries

libssl1.0.0-dbg/stable 1.0.1t-1+deb8u5 amd64
  Secure Sockets Layer toolkit - debug information

r-cran-openssl/jessie-backports 0.9.2-1~bpo8+1 amd64
  GNU R toolkit for encryption, signatures and certificates based on OpenSSL
As you see, It is installed but I like to install "Comodo Antivirus" and it show me an error.
 
Old 10-14-2019, 10:45 AM   #6
VapinPagan
LQ Newbie
 
Registered: Oct 2019
Posts: 3

Rep: Reputation: Disabled
Post Comodo install issues...

I realize this post is about 6 months old but I was wondering did anyone ever find a fix for this? I am having the exact issue. When trying to install Comodo Anitvirus it specifically requires libssl0.9.8 which seems to be impossible to install.

Anyone who has any help to offer or suggestions it would be greatly appreciated.
 
Old 10-14-2019, 10:54 AM   #7
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,635

Rep: Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895
Quote:
Originally Posted by VapinPagan View Post
I realize this post is about 6 months old but I was wondering did anyone ever find a fix for this? I am having the exact issue. When trying to install Comodo Anitvirus it specifically requires libssl0.9.8 which seems to be impossible to install.

Anyone who has any help to offer or suggestions it would be greatly appreciated.
This thread is actually three YEARS old. You don't say what version/distro of Linux you're using, what version of Comodo, where you got it, or how you're doing the install, but for openSUSE it doesn't ask for that package. The SSL libraries have been updated a good bit in three years.
 
Old 10-14-2019, 10:56 AM   #8
VapinPagan
LQ Newbie
 
Registered: Oct 2019
Posts: 3

Rep: Reputation: Disabled
Thumbs up FIX FOUND for LINUX Mint and other debian versions...

After posting my question I finally found a way to fix this issue by locating and directly installing the library needed which can be found here:

https://pkgs.org/download/libssl0.9.8

I wanted to share so now this thread can be closed for good.
 
Old 10-14-2019, 11:01 AM   #9
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,635

Rep: Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895
Quote:
Originally Posted by VapinPagan View Post
After posting my question I finally found a way to fix this issue by locating and directly installing the library needed which can be found here:

https://pkgs.org/download/libssl0.9.8

I wanted to share so now this thread can be closed for good.
This is a **HORRIBLY BAD** idea...the package you installed is very old, and you have actually DOWNGRADED the security on your system a very good bit, ironically trying to install an anti-virus program to keep you more secure.

If you installed the latest version of Comodo, it would use the latest libraries.
 
Old 10-14-2019, 11:05 AM   #10
VapinPagan
LQ Newbie
 
Registered: Oct 2019
Posts: 3

Rep: Reputation: Disabled
Talking

Quote:
Originally Posted by TB0ne View Post
This thread is actually three YEARS old. You don't say what version/distro of Linux you're using, what version of Comodo, where you got it, or how you're doing the install, but for openSUSE it doesn't ask for that package. The SSL libraries have been updated a good bit in three years.
------------
1) You correct and I apologize, I was working with 5 different forums at the time trying to find the answer and had thought I included that information. LINUX Mint Tina, 64bit Intel system
2) Three years old: again, I was just trying to post to too many forums at once, that was supposed to read over 6 months old. It has always been my experience that any forum posts over 6 months old are normally considered dead, complete, finished...thus my remark. Was obviously trying to do too much at once. =)

However, I did find an answer for the issue that worked great for me, so I shared what I found right away for others.
 
Old 10-14-2019, 11:17 AM   #11
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,635

Rep: Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895Reputation: 6895
Quote:
Originally Posted by VapinPagan View Post
------------
1) You correct and I apologize, I was working with 5 different forums at the time trying to find the answer and had thought I included that information. LINUX Mint Tina, 64bit Intel system
2) Three years old: again, I was just trying to post to too many forums at once, that was supposed to read over 6 months old. It has always been my experience that any forum posts over 6 months old are normally considered dead, complete, finished...thus my remark. Was obviously trying to do too much at once. =)

However, I did find an answer for the issue that worked great for me, so I shared what I found right away for others.
Understand and that's great...but your solution has made your system *MORE* insecure. Asked what version of Comodo you were installing and where you got it too, since a new version of that package won't ask for a VERY old SSL implementation.
 
Old 10-23-2019, 09:41 AM   #12
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,439

Rep: Reputation: 275Reputation: 275Reputation: 275
Quote:
Originally Posted by VapinPagan View Post
After posting my question I finally found a way to fix this issue by locating and directly installing the library needed which can be found here:

https://pkgs.org/download/libssl0.9.8

I wanted to share so now this thread can be closed for good.
Auch
That package doesn't even include all its ancient security updates.

Remove it ASAP.

Quote:
so I shared what I found right away for others
Please DON'T.
Others can (and did) read your post.
It's terrible advice, just don't.

Last edited by jens; 10-23-2019 at 09:59 AM.
 
2 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Any way to manually install "backports-3.11-rc3-1.tar" or ".inf" file from usb ? FondOfLinux Linux - Software 1 08-18-2013 05:20 PM
CrunchBang 10 "Statler" r20110207 Install Hangs "Detecting Network Devices" jv2112 Linux - Newbie 2 05-04-2011 05:48 PM
FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? A6Quattro Fedora 6 07-20-2005 12:49 PM
Can't install "glibmm" library. "configure" script can't find "sigc++-2.0&q kornerr Linux - General 4 05-10-2005 02:32 PM
does failed using urpmi messed up my "Install Software" / "mandrake update" ??? sirpelidor Mandriva 1 11-02-2003 09:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 02:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration