LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-02-2016, 10:11 PM   #16
HaasonHeist
LQ Newbie
 
Registered: Apr 2016
Posts: 1

Rep: Reputation: Disabled
Question


Quote:
Originally Posted by AlucardZero View Post
This topic is the first Google result for "xterm black background", so sorry for the necro, but the question is IMO not clearly answered and contains several totally irrelevant replies.

If you want your XTerm color to be white font on black background, then create or edit a file named .Xdefaults in your home directory, and place the following in it:

Code:
XTerm*Background: black
XTerm*Foreground: white
Then restart xterm.

You can of course switch the colors if you want black on white.
So, I did try this and it did not work for me. I am running lubuntu and have only had it running for a day or so. I am a complete beginner on any type of unix/linux OS so perhaps I am getting a bit ahead of myself?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 04-04-2016, 09:52 AM   #17
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 561

Rep: Reputation: 129Reputation: 129
The default terminal on lxde (the desktop enviroment of lubuntu) is lxterminal, and it does have a gui for its options, so there is no need to start editing files here and there.
 
Old 04-30-2016, 04:46 AM   #18
gcurse
LQ Newbie
 
Registered: Apr 2016
Location: Germany
Distribution: Archlinux
Posts: 1

Rep: Reputation: Disabled
First of all: The file ~/.Xdefaults is deprecated. Please use ~/.Xresources instead.

If it does not exist issue the following command in a terminal:
Code:
touch ~/.Xresources
Then put the following in it:
Code:
xterm*Background: black
xterm*Foreground: white
"xterm" must be all lowercase.
Now in a terminal issue
Code:
xrdb -merge ~/.Xresources
and restart xterm.
 
1 members found this post helpful.
  


Reply

Tags
xterm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I change the background color of xterm permanently? vxc69 Linux - Software 9 01-22-2018 01:30 PM
Change font color xterm aeruzcar Linux - Software 3 01-04-2012 04:48 PM
Change background in solaris and Xterm background also EvilAngel Solaris / OpenSolaris 2 01-31-2005 11:25 AM
Change background color chingyenccy Linux - Newbie 6 01-23-2005 03:17 AM
Is there a way to change background color out of X? purpleburple Linux - General 1 01-23-2003 08:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration