LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Closed Thread
  Search this Thread
Old 11-28-2006, 02:00 PM   #1
meligon
LQ Newbie
 
Registered: Sep 2006
Posts: 22

Rep: Reputation: 15
How setup Apache to run CGI Script


Attempted to run a CGI script from HTTP. Called the scrip (i.e. http://www.mydomainname.com/cgi-bin/vqadmin.cgi) and received a browser error. onfigured Httpd.conf and .htaccess and successfuly logged in based on .htaccess configuration. However after loggin in I get the prompt "The file vqadmin.cgi" is of type application/octet-stream, and Mozilla does not know how to handle this file type ..." It appears my browse do not know what application to associate .cgi file with.


My .htaccess file looks like this:

AuthType Basic
AuthUserFile /home/lj/cgi-bin/.htpasswd
AuthName vQadmin
require valid-user
satisfy any


My Httpd.conf file looks like this:

....
LoadModule auth_module /usr/lib/apache/1.3/mod_auth.so
LoadModule alias_module /usr/lib/apache/1.3/mod_alias.so
LoadModule access_module /usr/lib/apache/1.3/mod_access.so

ScriptAlias /cgi-bin/ "/home/lj/cgi-bin/vqadmin/"

AddHandler cgi-script .cgi

<Directory "/home/lj/cgi-bin/vqadmin">
deny from all
Options ExecCGI
#AllowOverride AuthConfig
AllowOverride All
Order Deny,Allow
</Directory>

Can someone help me please. I have been working at this for a couple of days.

Michael
 
Old 11-29-2006, 07:26 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is closed because it is a duplicate of http://www.linuxquestions.org/questi....php?p=2512217.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
run cgi script as a user other than apache paul_mat Linux - Software 1 06-02-2006 02:01 PM
Allow user to run their own cgi script samwong Linux - Newbie 5 05-25-2004 10:22 PM
Help CGI won't run under Apache shuttleX Linux - Software 2 06-05-2003 02:37 PM
cgi script doesn't run just downloads SchoolITguy Programming 3 12-19-2002 03:08 PM
Auto Run A Cgi Script f117bomb Linux - General 1 11-25-2001 01:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration