LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-09-2004, 06:14 PM   #1
The Pentium Guy
Member
 
Registered: Oct 2004
Distribution: Debian Sid (Unstable)
Posts: 41

Rep: Reputation: 15
How do you use KDE?


Yo guys,
I installed KDE using Debian with kernel 2.4

I boot up my system, and log in as root, but still no KDE starts up

how do i "Run" KDE?

-The Pentium GUy
 
Old 10-09-2004, 06:22 PM   #2
RossB
Novell Adv. Tech. Training Engineer
 
Registered: Jul 2004
Distribution: Knoppix/Mint
Posts: 47

Rep: Reputation: 15
Heh, see if "startkde" is there, if so, type it...

Also, if there is an /etc/sysconfig/desktop file, put the string:

DESKTOP="KDE"

in the file and save it. If it doesn't exist, you can create it and populate it.

See if those will do it.

RossB
 
Old 10-09-2004, 07:01 PM   #3
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
If you've installed kde using "apt-get install kde", you should have kdm (it's a gui login screen for kde) starting automatically. But it appears that this is not the case. So I suggest that you install rcconf ("apt-get install rcconf"), run it as root (first "su", then "rcconf") and enable kdm. Then reboot.

If rcconf doesn't show you kdm, then you might want to consider reinstalling kde ("apt-get --reinstall install kde"). Hope this helps.
 
Old 10-09-2004, 07:02 PM   #4
The Pentium Guy
Member
 
Registered: Oct 2004
Distribution: Debian Sid (Unstable)
Posts: 41

Original Poster
Rep: Reputation: 15
Awesome, I'll try that tonight

however uhh, since this is my first venture into linux.. and since im using a freaking console thingy - how do i open that file . heh - sorry

edit: I was talking about the 2nd reply .
Dead Parrot - thanks, if the other thing fails, I'll try this

-pent

Last edited by The Pentium Guy; 10-09-2004 at 07:04 PM.
 
Old 10-09-2004, 07:56 PM   #5
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
Read this:
Sections 9,10, and 11.
The Very Verbose Debian Installation
http://osnews.com/story.php?news_id=2016

it will show you the use of apt-get (among other things), why not to cruise the internet, or enter X as ROOT.

After you're thru, with it, if you still don't get KDM, the login dialog box from KDE that allows you to sign as user and enter your user password, come back, we'll tell you how to edit your files, so KDE starts automatically, with something like Nano, etc. Of course you can also try as root:

apt-get install kdm

You say you installed Debian, which one? did you use the sarge net-installer?

APT-HOWTO
debian.org > Documentation > Manuals > APT-HOWTO
this will give you the basics plus a lot of other stuff.

Last edited by macondo; 10-09-2004 at 08:00 PM.
 
Old 10-09-2004, 10:41 PM   #6
The Pentium Guy
Member
 
Registered: Oct 2004
Distribution: Debian Sid (Unstable)
Posts: 41

Original Poster
Rep: Reputation: 15
Yo guys,

I tried everything you said.. starting with the first reply:

Quote:
"Heh, see if "startkde" is there, if so, type it..."
I tried that, it says could not connect to X Server manager, and somethign about $DISPLAY is not set.

Quote:
If you've installed kde using "apt-get install kde", you should have kdm (it's a gui login screen for kde) starting automatically. But it appears that this is not the case. So I suggest that you install rcconf ("apt-get install rcconf"), run it as root (first "su", then "rcconf") and enable kdm. Then reboot.
I tried that also . When I run rcconf - KDM is enabled (there's a star next to it). I rebooted, nothing happened, same thing. Next I tried unchecking xdm and gdm and rebooting, nothing happened either.

Quote:
Step 2 (Managing Xwrapper.config)
Once all of the packages have been downloaded, you are presented with a screen that looks like the installation screens. This new screen should be titled "Configuring Xserver-common". This screen is asking whether you want to control who has access to the X server or if you want debconf (Debian's configuration tool) to do it for you. I suggest you choose "Yes" and press the Enter key to continue; unless you know what you're doing.
The above quote was from the website that macondo linked me to. After I download and install it - I don't get a screen at all. So I couldn't complete the rest of the instructions.

Quote:
apt-get install kdm
After doing that, it said I had the latest version. I even added the --reinstall flag.

Quote:
You say you installed Debian, which one? did you use the sarge net-installer?
I installed it from a cd, under the "Official CD images of the 'stable' releases" section, using version 3.0 rev2 and kernel 2.4.
I beleive it's woody.

Please help me out, and thank you guys for your help,
-The Pentium Guy
 
Old 10-09-2004, 11:13 PM   #7
Robhogg
Member
 
Registered: Sep 2004
Location: Old York, North Yorks.
Distribution: Debian 7 (mainly)
Posts: 653

Rep: Reputation: 97
$DISPLAY is an environment variable that tells your PC which display to use. When I typed echo $DISPLAY in the console on my PC it returned :0.0, which apparently just means that it's displaying on its own screen. There's an explanation here.

On my box (running SuSE with KDE) the "desktop" file in /etc/sysconfig is called displaymanager. It contains the line DISPLAYMANAGER="kdm". In case you haven't found out yet, you can open this file for editing with the command vi displaymanager. The vi command launches the VIM text editor. It takes a little getting used to, but: hitting "i" puts you in insert mode (for typing) and the ESC key puts you back in "last line command" mode from which:

:q! <RETURN> exits without saving,
:x <RETURN> saves and exits, and
:w "filename" <RETURN> saves the file.

Hope this is helpful.

Rob

Last edited by Robhogg; 10-09-2004 at 11:32 PM.
 
Old 10-09-2004, 11:16 PM   #8
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
Doesn't sound like to me you have all of X installed. Where you ever given the choice to configure it? If not, it is not installed.

apt-get install x-window-system
 
Old 10-10-2004, 07:32 PM   #9
The Pentium Guy
Member
 
Registered: Oct 2004
Distribution: Debian Sid (Unstable)
Posts: 41

Original Poster
Rep: Reputation: 15
"$DISPLAY is an environment variable that tells your PC which display to use. When I typed echo $DISPLAY in the console on my PC it returned :0.0, which apparently just means that it's displaying on its own screen. There's an explanation here. "

When I type in echo $DISPLAY it doesn't say anything.. meaning the string $DISPLAY doesn't exist. When i set $DISPLAY:
$DISPLAY=:0.0

It says cannot find command =:0.0

I created the display manager file in /etc/sysconfig/
(I had to create the /sysconfig/ directory with mkdir)

In the "vi" thing, i typed in DISPLAYMANAGER="kdm" and saved and rebooted.. still nothing.

-The Pentium Guy
 
Old 10-10-2004, 08:45 PM   #10
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
If you are sure that you have installed the "x-window-system" package, run (as root) "dpkg-reconfigure -plow xserver-xfree86" and give the correct videocard driver and monitor refresh values when asked. Then run "dpkg-reconfigure kdm", and reboot.

If KDE still fails to start, do "more /var/log/XFree86.0.log" and see if there is some explanation in the last lines of this log file. Also keep an eye on lines that begin with (WW) or (EE).
 
Old 10-10-2004, 08:46 PM   #11
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
From the link in Post #7 http://www.saao.ac.za/unix/node74.html
"The environment variable DISPLAY is of particular importance in X windows"

Now look at my Post #8

Did you install the X Window System? If you did it asked you to configure it at installation. Just because you installed KDE doesn't mean you have X installed.
 
Old 10-10-2004, 10:21 PM   #12
The Pentium Guy
Member
 
Registered: Oct 2004
Distribution: Debian Sid (Unstable)
Posts: 41

Original Poster
Rep: Reputation: 15
Thanks all, what Dead Parrot said got it to work . Thanks for your patience with a noob lol.

-The Pentium Guy
 
Old 10-11-2004, 09:57 AM   #13
The Pentium Guy
Member
 
Registered: Oct 2004
Distribution: Debian Sid (Unstable)
Posts: 41

Original Poster
Rep: Reputation: 15
Oh crap! When I made my previous post I tested out Gnome (I started it from the graphical login screen). I tried tiw and saw (?) - they both work.

But when I start (Default) and kde2... right when it gets to initializing peripherals (step2 I beleive), the screen flashes twice.. on the 2nd time I see a buncha gray stuff...

So I looked in the log file "more /var/log/XFree86.0.log". It said somethign along the lines of (WW) APM failed to start or something.

I went to the end of the file, it said error with my mouse... Its a simple PS2 mouse and I simply used "Generic Mouse". I know for a fact that my mouse works becuase in the graphical login screen, I can move my mouse....etc

Anyone got any tips on what to do...

btw darthux: When I installed x window system, there was no screen asking me to configure it. But yes, I did configure it at installation. It never prompted me what $Display was - I just had to type in my monitor name, and it was some old compaq CRT so I used Generic Monitor... Also for my graphics card driver, I used the first one (versa or something or vesa), since its a generic/integrated driver.

Also, when I log back into console mode, when I type in startkde, it STILL gives the errors: Cannot find $DISPLAY '' (the '' indicates that display is empty), and it says cannot find the Connect() command.. something along those lines and it says Cannot connect to X Server


Thanks for hearing me out guys, I really appreciate it.. I would have almsot given up on linux if I hadn't come to this forum.

-The Pentium Guy
 
Old 10-11-2004, 11:27 AM   #14
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
"The above quote was from the website that macondo linked me to. After I download and install it - I don't get a screen at all. So I couldn't complete the rest of the instructions."

at the bottom of the screen, you have to type 'Y' and then the dialog box will come out, so you can choose 'Debconf' as your manager, you probably missed. it. You have a bad installation, that's why you are having so many problems. You have 2 choices:

Reinstall, and this time do it slowly and carefully, following the instructions to the letter. Type 'bf24' at the prompt so you get the 2.4 kernel, you will end up with Woody though. Might as well install Sarge, which you will have to upgrade to, in a few weeks anyhow.

OR

install the sarge net-installer, this site is full of info about it, type 'linux' and take the defaults, skip the the 'install packages' and at the end, install x-window-system, an easy window manager like icewm, and later on, once you're in, install kde. Afterwards, check the Debian Configuration sticky at the top of this page.
 
Old 10-11-2004, 12:41 PM   #15
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Installing Sarge http://www.debian.org/devel/debian-installer/ would indeed save you from a lot of trouble. Sarge comes with a hardware autodetection program called "discover", which can probably automatically pick the correct graphics card driver for you. After installing Sarge, you can also install "read-edid" and "mdetect" packages. "read-edid" tries to automatically detect the refresh values (horizontal & vertical) for your monitor, although it doesn't always succeed. Mdetect tries to autodetect your mouse type (and it often succeeds). With "discover", "read-edid", and "mdetect" installed you should be able to configure X Window System by using the "dpkg-reconfigure -plow xserver-xfree86" command.

If you've got Windows installed, you can also try to check the graphics card driver, mouse type, and monitor refresh values (horizontal & vertical) from the Windows Control Center, System properties. Monitor refresh values are sometimes difficult to track down, but you can also do a google search for "<your monitor name & model> horizontal vertical refresh".

During Debian installation, you are asked to configure Debconf. Choose "Dialog" for Debconf frontend and choose "normal" or "low" for Debconf priority level. These choices should ensure that Debconf gives you the chance to configure programs when they are installed for the first time. You can later change these choices with "dpkg-reconfigure debconf".

Installing and configuring Linux can be difficult and Debian is not the easiest possible distro for a beginner. But once you've got it installed and configured to your liking (yes, it IS possible!), Debian is one of the very best Linux distros out there -- definitely worth the trouble.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! Installed kde 3392 rpms keyboard dead inside kde, working in shell hansschmucker SUSE / openSUSE 1 02-13-2005 09:01 PM
Why wont my KDE 3.2 FC2 setup run make commands w/KDE 1.x packages? rusty_slacker Linux - Newbie 1 09-19-2004 06:40 PM
dpi font | gdm | kde DE | xinitrc.kde | Slackware 10 acummings Slackware 2 07-28-2004 11:28 PM
couple of qs, gnome ftp, removing kde or improving speed of kde, startup modprobe darkleaf Linux - Software 2 07-20-2004 10:54 AM
[REDHAT KDE] Disable KDE boot? Apache down after 10min losing monitor signal bjwesselink Linux - Software 2 08-11-2003 02:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration