LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-15-2012, 05:09 AM   #196
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163

Caravel:

Be back in a few minutes with the outputs of those commands.
 
Old 08-15-2012, 05:50 AM   #197
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Caravel Wednesday Morning:

Code:
root@mock:/home/ztcoracat# iwconfig 
lo        no wireless extensions. 

eth0      no wireless extensions. 

wlan0     Ralink STA  ESSID:""  Nickname:"RT2870STA" 
          Mode:Auto  Frequency=2.422 GHz  Access Point: Not-Associated   
          Bit Rate:1 Mb/s   
          RTS thr:off   Fragment thr:off 
          Encryption key:off 
          Link Quality=76/100  Signal level:-63 dBm  Noise level:-115 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0 
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0 

pan0      no wireless extensions.
Next Command
[CODE]root@mock:/home/ztcoracat# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
address 192.168.1.5
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 192.168.1.1
root@mock:/home/ztcoracat#

Next Command
[CODE]root@mock:/home/ztcoracat# cat /etc/resolv.conf
# Generated by NetworkManager
root@mock:/home/ztcoracat#

And....
Code:
root@mock:/home/ztcoracat# cat /etc/resolv.conf 
# Generated by NetworkManager 
root@mock:/home/ztcoracat# cat /etc/NetworkManager/NetworkManager.conf 
[main] 
plugins=ifupdown,keyfile 

[ifupdown] 
managed=false 
root@mock:/home/ztcoracat#

Last edited by Ztcoracat; 08-15-2012 at 05:53 AM.
 
Old 08-15-2012, 05:54 AM   #198
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163


I did not run this in a terminal because I am only suspicious (because of the thread I read) of ipv6 being an issue. I do not have concrete confirmation so I figured that it was not wise for me to do so w/o being told to do so.

# echo net.ipv6.conf.all.disable_ipv6=1 > /etc/sysctl.d/disableipv6.conf
 
Old 08-15-2012, 06:17 AM   #199
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,417

Rep: Reputation: Disabled
No, disable IPv6 now as in my previous post and reboot before doing anything else.

Ok, you said the wifi connected and showed you four green bars, but that is clearly not the case here?
Quote:
Originally Posted by Ztcoracat View Post
Code:
wlan0     Ralink STA  ESSID:""  Nickname:"RT2870STA" 
          Mode:Auto  Frequency=2.422 GHz  Access Point: Not-Associated   
          Bit Rate:1 Mb/s   
          RTS thr:off   Fragment thr:off 
          Encryption key:off 
          Link Quality=76/100  Signal level:-63 dBm  Noise level:-115 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0 
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Connect the wifi as you did before to get the 4 green bars and then issue the iwconfig command again.

Quote:
Originally Posted by Ztcoracat View Post
Code:
# This file describes the network interfaces available on your system 
# and how to activate them. For more information, see interfaces(5). 

# The loopback network interface 
auto lo 
iface lo inet loopback 

# The primary network interface 
allow-hotplug eth0 
iface eth0 inet static 
	address 192.168.1.5 
	netmask 255.255.255.0 
	network 192.168.1.0 
	broadcast 192.168.1.255 
	gateway 192.168.1.1 
	# dns-* options are implemented by the resolvconf package, if installed 
	dns-nameservers 192.168.1.1
You've set up a static address for the wired connection? Is this connection available to use? If not, let's comment it out (disable it) just in case - change the file exactly as follows (edit it as root):
Code:
# This file describes the network interfaces available on your system 
# and how to activate them. For more information, see interfaces(5). 

# The loopback network interface 
auto lo 
iface lo inet loopback 

# The primary network interface 
#allow-hotplug eth0 
#iface eth0 inet static 
#	address 192.168.1.5 
#	netmask 255.255.255.0 
#	network 192.168.1.0 
#	broadcast 192.168.1.255 
#	gateway 192.168.1.1 
	# dns-* options are implemented by the resolvconf package, if installed 
#	dns-nameservers 192.168.1.1
Quote:
Originally Posted by Ztcoracat View Post
Code:
# Generated by NetworkManager
This shows that the network manager daemon is not establishing a connection as there should be a "nameserver" line below the networkmanager comment.

Quote:
Originally Posted by Ztcoracat View Post
Code:
[main] 
plugins=ifupdown,keyfile 

[ifupdown] 
managed=false
Leave that one as it is for now, as we don't really need to tell networkmanager to manage the wired connection if we've already deconfigured it in the interfaces file.
 
Old 08-15-2012, 05:41 PM   #200
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
I had trouble with that file. Here's the output first.

Code:
ztcoracat@mock:~$ su 
Password: 
root@mock:/home/ztcoracat# echo net.ipv6.conf.all.disable_ipv6=1 > /etc/sysctl.d/disableipv6.conf 
root@mock:/home/ztcoracat#
And the next:
Code:
Next Command to post lo        no wireless extensions. 

eth0      no wireless extensions. 

wlan0     Ralink STA  ESSID:"Mock"  Nickname:"RT2870STA" 
          Mode:Managed  Frequency=2.422 GHz  Access Point: 22:02:71:1E:25:14   
          Bit Rate=54 Mb/s   
          RTS thr:off   Fragment thr:off 
          Encryption key:3434-3337-3732-3033-3034-3434-33 
          Link Quality=100/100  Signal level:-61 dBm  Noise level:-83 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Code:
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0 

pan0      no wireless extensions. 
Having trouble with copy/paste
Code:
root@mock:/home/ztcoracat# iwconfig 

root@mock:/home/ztcoracat#
I edited the interfaces file exactly the way you did with the # in front of the entries.
Upon closing that file Debian asked me: Save Changes? I saved as and got:
“The file etc/network/interfaces is a read only”
Do you want to replace it? I clicked Replace. Than Debian gave me a warning in red.
“Could not save the file etc/network/interfaces” You do not have permissions necessary to save the file”
In truth Caravel; when I was prompted; I typed in my root password before I started to edit that file- I tried to put in the ( # ) and it worked; it just wouldn't let me replace it with the changes I performed.
So, I do not get what I've done incorrectly.
 
Old 08-15-2012, 06:09 PM   #201
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
I do understand how to get to that file(etc/network/interfaces) but once I got the interfaces file open and tried to make the changes, it would not let me save the changes.

I did enter my root password (prior to attempting to change the file) to do so.

I don't understand why I could not change the file as I thought entering my root password should have allowed me to accomplish just that.

I'm starting to think there may be a problem with my permissions or my password or the way in which I'm applying them.
 
Old 08-15-2012, 10:57 PM   #202
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by Ztcoracat View Post
I do understand how to get to that file(etc/network/interfaces) but once I got the interfaces file open and tried to make the changes, it would not let me save the changes.

I did enter my root password (prior to attempting to change the file) to do so.

I don't understand why I could not change the file as I thought entering my root password should have allowed me to accomplish just that.

I'm starting to think there may be a problem with my permissions or my password or the way in which I'm applying them.
Anyway I'm going to Google on how to edit this file in Debian. And look for an example of how others in Debian have done this. I have to learn how to use Nano or Geany. Think I have gedit-
I now know that I have to open a terminal to do this but I need more knowledge.Don't understand how to open the network interfaces file in the terminal.
Trying to help myself here. Hope to solve " editing this file" before morning.
 
Old 08-16-2012, 03:04 AM   #203
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,417

Rep: Reputation: Disabled
Post #200 now shows that your wireless is connected to "Mock" and associated correctly. Once again ensure that the wifi is actually connected (verify this with iwconfig) and post the outputs of:
Code:
$ cat /etc/resolv.conf
Code:
# route -n
How are you editing the interfaces file? What editor?
 
Old 08-16-2012, 03:31 AM   #204
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Great news Caravel!

Iceweasel is up and running!

Code:
I am online now and my wireless is working successfully!
As soon as I figured out how to use the terminal to edit my etc/network/interfaces file and edited it successfully
shut down and rebooted about 1/2 hour ago the internet connection has been up and running.

ztcoracat@mock:~$ su
Password:
root@mock:/home/ztcoracat# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0
root@mock:/home/ztcoracat#


You have helped me for 2 weeks straight. Your very good at what you do Caravel and dedicated too; Thank You

Last edited by Ztcoracat; 08-16-2012 at 03:49 AM. Reason: Additional Terminal output
 
Old 08-16-2012, 03:35 AM   #205
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by caravel View Post
Post #200 now shows that your wireless is connected to "Mock" and associated correctly. Once again ensure that the wifi is actually connected (verify this with iwconfig) and post the outputs of:
Code:
$ cat /etc/resolv.conf
Code:
# route -n
How are you editing the interfaces file? What editor?
Caravel:

I used Nano 2.2.4 and it worked.

Code:
ztcoracat@mock:~$  cat /etc/resolv.conf
# Generated by NetworkManager
domain Home
search Home
nameserver 192.168.1.1
ztcoracat@mock:~$
It's great to be online!
 
Old 08-16-2012, 04:09 AM   #206
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,417

Rep: Reputation: Disabled
Well done, you stuck at it and got it working.

Please start a new thread for any other issues you may have.

 
Old 08-16-2012, 07:46 PM   #207
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Caravel:

Thanks again and have a great weekend!

Sincerely,
Coracat
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to add Debian Squeeze to your Debian Lenny FAI install server LXer Syndicated Linux News 0 09-08-2011 07:21 PM
LXer: How To Install A (Canon) Printer On Debian And Debian-Like Systems LXer Syndicated Linux News 0 05-20-2011 11:01 AM
how can i install debian 5.06 in my pc i have downloaded debian-update-5.0.6-i386-DVD siddtanu Debian 2 10-21-2010 02:56 PM
Debian Etch install from dvd, not authenticated by Debian jiobo Linux - Security 3 01-11-2009 07:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration