LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-19-2011, 07:47 PM   #1
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Jessie, Bunsenlabs
Posts: 586

Rep: Reputation: 38
How do I switch to Nvidia driver?


Using Debian Squeeze

I installed the Nvidia installer: NVIDIA-Linux-x8~.86.14-pkg1.run
I configured the xorg.conf file and changed the driver from nv to nvidia.
I also removed "load dri"

When I use startx I get this error and it won't give me a desktop:
(EE) Failed to load /usr/lib/xorg/modules/drivers/nvidia_drv.so
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available

This is all I remember doing with Lenny. Apparently there is something else I need to do with Squeeze?

Thanks
 
Old 03-19-2011, 08:58 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,425

Rep: Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590
you might want to post the xorg.conf

there is a section for adding the PATH to the driver

also informing us as to your nvidia card will help

also "NVIDIA-Linux-x86_64-260.19.36.run" is the current for a new card on 64 bit platform

"86.14-pkg1.run"????????
IF AND A VERY BIG IF my guess is right this 86.14 is for a very very old LEGACY agp gforce5 card
NVIDIA-Linux-x86-71.86.14-pkg1.run

that very old nvidia card WILL need the xorg.conf wrote by hand
PLEASE read the readme for that driver the FULL instructions on the "xorg.conf" options and settings is in there
ftp://download.nvidia.com/XFree86/Li....86.14/README/
 
Old 03-20-2011, 03:24 AM   #3
sgrayban
Member
 
Registered: Nov 2004
Location: Spokane, WA
Distribution: Debian 6.0
Posts: 369

Rep: Reputation: 30
I assume you are using squeeze now....

The newest version is NVIDIA-Linux-x86-260.19.36.run

There is one last step that sets up xorg.conf -- did you go through that ?
 
Old 03-20-2011, 07:55 PM   #4
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Jessie, Bunsenlabs
Posts: 586

Original Poster
Rep: Reputation: 38
Quote:
you might want to post the xorg.conf

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "glx"
#Load "dri"
Load "dbe"
Load "record"
Load "dri2"
Load "extmod"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "VideoKey" # <i>
Identifier "Card0"
Driver "nv"
VendorName "nVidia Corporation"
BoardName "NV6 [Vanta/Vanta LT]"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
The above file is the one I generated with Xorg -configure, and have tried the instructions in the article you posted that follows. It worked with the nv and the nouveau drivers.
Quote:
If you already have an X config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist.
Quote:
there is a section for adding the PATH to the driver
I checked the path in the xorg.conf file: /usr/lib/xorg/modules/drivers
The drivers for nvidia are in there: nouveau_drv.so, nv_drv.so, nvidia_drv.so
The only difference is that nvidia_drv.so is executable.

Quote:
also informing us as to your nvidia card will help
01:00.0 VGA compatible controller: nVidia Corporation NV6 [Vanta/Vanta LT] (rev 15)

I know this is an old card. I don't need the 3D. I thought the nvidia driver would work better than the nv. What else would I need to do to get Squeeze to choose the nvidia driver?

Thanks
 
Old 03-20-2011, 09:18 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,425

Rep: Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590
the " nv " driver is theold 2d ONLY
the "nouveau" driver is the Open source 3d driver
and the Nvidia.run is the "binary blob" from nvidia.

Vanta
http://www.nvidia.com/page/vanta.html
that thing is old
a press release from 1999
http://www.nvidia.com/object/IO_20020109_4288.html
the "71.86.13 " is the driver

-------------
try this
rename the current xorg.conf to xorg.conf-old
then reboot and let the system remake the file
if it dose not auto make a new one then from text boot run
"nvidia-xconfig"
PS. you will need to be root to run that

and if that dose not do it i see one problem
this
/usr/lib/xorg/modules/drivers/nvidia_drv.so --- notice the "/drivers" folder
then the path in the conf "/usr/lib/xorg/modules" NO "/drivers" folder
add a second listing for "/usr/lib/xorg/modules/drivers"


Code:
Section "Files"
ModulePath "/usr/lib/xorg/modules"
ModulePath "/usr/lib/xorg/modules/drivers"
FontPath "/usr/share/fonts/X11/misc"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to switch from Nvidia driver to free driver? miros84 Linux - Hardware 3 12-28-2009 07:52 AM
Switch to nVidia? Agizor Linux - Hardware 9 12-16-2004 05:16 PM
Switch from ATI to NVidia El Basto SUSE / openSUSE 2 11-14-2004 10:46 PM
nvidia fx5600 loads vesa driver instead of nvidia driver saburo62 Linux - Hardware 3 05-04-2004 03:59 PM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 05:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration