LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-21-2017, 05:07 PM   #1
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,444

Rep: Reputation: 182Reputation: 182
How do I activate the proper locale on my Debian system? (en-CA)


Hello. I'm using Debian stable (9.0 -- aka Stretch). I used to use Vector Linux a while back, and I enabled the locale of en-CA via editing the file /etc/profile.d/lang.sh replacing "en-US" with "en-CA". After, programs had Canadian spellings rather than American (IE, "colour" or "centre" rather than "color" or "center").

But there is no such file on Debian. I have messed around with stuff from the Debian wiki (https://wiki.debian.org/Locale) on locales, but to no avail. It currently looks like this:

Code:
mark@debian:~$ locale
LANG=en_CA.utf8
LANGUAGE=en_CA:en
LC_CTYPE="en_CA.utf8"
LC_NUMERIC="en_CA.utf8"
LC_TIME="en_CA.utf8"
LC_COLLATE="en_CA.utf8"
LC_MONETARY="en_CA.utf8"
LC_MESSAGES="en_CA.utf8"
LC_PAPER="en_CA.utf8"
LC_NAME="en_CA.utf8"
LC_ADDRESS="en_CA.utf8"
LC_TELEPHONE="en_CA.utf8"
LC_MEASUREMENT="en_CA.utf8"
LC_IDENTIFICATION="en_CA.utf8"
LC_ALL=
However, spellings within programs are all en-US.
 
Old 07-21-2017, 07:46 PM   #2
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 18/ TC64
Posts: 5,301

Rep: Reputation: Disabled
Hi

locale looks good

what is Desktop environment or window manager

provide a short list of the main programs you find US spelling pls

2) you can also get specific lang packs for some web browsers

you can get some lang packs for large office suites too

3) as a quick and dirty work a round, if all else fails try GB ....aussie spell the same as brits

Last edited by aus9; 07-21-2017 at 07:57 PM.
 
1 members found this post helpful.
Old 07-21-2017, 10:25 PM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,622

Rep: Reputation: 105Reputation: 105
Try installing the Canadian dictionary package.

Code:
apt-cache  show wcanadian
Package: wcanadian
Source: scowl
Version: 7.1-1
Installed-Size: 990
Maintainer: Don Armstrong <don@debian.org>
Architecture: all
Provides: wordlist
Depends: dictionaries-common (>= 0.20), debconf (>= 0.5) | debconf-2.0
Description-en: Canadian English dictionary words for /usr/share/dict
 This package provides the file /usr/share/dict/canadian-english
 containing a list of English words with Canadian spellings.
 This list can be used by spelling checkers, and by programs such
 as look(1).
 .
 There are also -small, -large and -huge versions of this word list,
 and there are wbritish* and wamerican* packages as well.
Description-md5: fda6495f146f251df0601393fe5b6c65
Homepage: http://wordlist.sourceforge.net/
Tag: culture::TODO, made-of::dictionary, role::app-data, use::checking
Section: text
Priority: optional
Filename: pool/main/s/scowl/wcanadian_7.1-1_all.deb
Size: 272090
MD5sum: 98617111cf8eeb4e1a1eccdeef80deb0
SHA1: ecad69aa879807d7cf3999b52dd27008c0f8cb71
SHA256: e25c244a29c2c09233070b32ee6db977fa76fcace64ba810c5cceedbd4fbf75e
 
1 members found this post helpful.
Old 07-21-2017, 11:44 PM   #4
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 557

Rep: Reputation: 127Reputation: 127
For the locale part.
Recently, I decided to change my system to the greek locale. I ran
Code:
dpkg-reconfigure locales
and selected only these ones on the first question
Code:
el_GR ISO-8859-7
el_GR.UTF-8 UTF-8

en_US.ISO-8859-15 ISO-8859-15
en_US.UTF-8 UTF-8
and on the second one, about the system locale, I selected el_GR ISO-8859-7. This is pretty much what the wiki explains in the "manually" section, with the dpkg-reconfigure ease of use. After a reboot, everything (desktop enviroment, apps etc) was switched to the greek locale.

No idea about the spelling part
 
1 members found this post helpful.
Old 07-22-2017, 11:08 AM   #5
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,444

Original Poster
Rep: Reputation: 182Reputation: 182
Quote:
Originally Posted by aus9
what is Desktop environment or window manager

provide a short list of the main programs you find US spelling pls
I use XFCE. Anyway, as far as which programs, it is all of them. It's not actually a big deal, given that it's usually only seen in menu choices (and most often in "preferences"). Generally it's words like "center" and "color" that appear most.

For the bigger programs, I realize (realise?) that special language versions of them (if available) would need to be installed*, and would only be available in en-gb and not the small-fry en-ca. Though, from what I can tell, regarding smaller programs, it seems none of them acknowledge the en-ca locale (which was not my experience some years ago when I used Vector Linux). Included in the programs with US spellings is Synaptic. I figure if any program should have settings for all the locales, it's this one, since it's Debian's main GUI package management tool. I figure there must be something I've neglected to do to enable the locale setting to work, but I'm not sure what it is.
_____
* I did do this with Thunderbird recently, and haven't had any luck here either (I do have a separate thread on that though).

Last edited by mark_alfred; 07-22-2017 at 11:12 AM.
 
Old 07-22-2017, 03:50 PM   #6
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,444

Original Poster
Rep: Reputation: 182Reputation: 182
I think I was getting overly particular. Seems that some spellings actually were changed when I enacted the en-ca localization. But, some of the more apparent things, like menu items, remain fixed in their original state (that being US English). I just took a look at two programs, those being Geany (a text editor) and Gimp (a photo editor) and they each feature some Canadian spellings. I've included two attachments. The first shows Geany's "Color Chooser", which, below in the window, says, "Colour name: #FFFFFF". The second one is Gimp's Colour Balance tool. The main window of Gimp gives the menu option of "Colors", but when a picture is opened and the Colour Balance tool is enacted, it gives the Canadian spelling of "colour". So, it's kinda half-assed, but it's something. So, solved.
Attached Thumbnails
Click image for larger version

Name:	GeanyGB.png
Views:	3
Size:	34.8 KB
ID:	25541   Click image for larger version

Name:	gimpGB.png
Views:	5
Size:	40.5 KB
ID:	25542  

Last edited by mark_alfred; 07-22-2017 at 08:56 PM.
 
  


Reply

Tags
debian, en-ca, en-us, locale


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
system locale sanjay2k4 Linux - Software 3 06-14-2006 11:47 AM
C locale and system locale johnnydangerous Fedora 4 04-11-2005 03:37 PM
Debian Locale's boardinglaxplr Linux - Newbie 4 05-17-2004 02:35 PM
Proper method to upgrade debian system? xanas3712 Debian 11 05-14-2004 06:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration