LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-18-2015, 02:38 PM   #1
hack3rcon
Senior Member
 
Registered: Jan 2015
Posts: 1,432

Rep: Reputation: 10
Thumbs down How can I solve Proxychains error "LD_PRELOAD cannot be preloaded" ?


Hello.
I use Debian Jessie x64.
I installed proxychains v4 but I get "ERROR: ld.so: object '/usr/lib/libproxychains.so.3' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored." error, How can I solve it?
I used below link too but I have problem :

http://www.blackmoreops.com/2014/12/...oaded-ignored/

Thank you.
 
Old 08-19-2015, 04:10 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591
Quote:
Originally Posted by hack3rcon View Post
How can I solve it?
Does the file exist?
Is it the right architecture?
What have you actually tried yourself?
 
Old 08-20-2015, 02:11 AM   #3
hack3rcon
Senior Member
 
Registered: Jan 2015
Posts: 1,432

Original Poster
Rep: Reputation: 10
$ ls libproxy*
libproxychains.so

File exist and I installed it via "Synaptic" in debian.
I created a link from this file but problem not solved
 
Old 08-20-2015, 04:23 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591Reputation: 3591
A plain 'ls' doesn't say much so either learn to use 'stat /path/to/file*' or a long listing 'ls'. Did you recompile the application as suggested?
 
Old 08-21-2015, 12:14 AM   #5
hack3rcon
Senior Member
 
Registered: Jan 2015
Posts: 1,432

Original Poster
Rep: Reputation: 10
Problem solved with create another link.
I created a link with the name "libproxychains.so.3" and problem solved
 
Old 04-21-2020, 06:19 AM   #6
farab
LQ Newbie
 
Registered: Aug 2011
Posts: 18

Rep: Reputation: 22
In my case,

Code:
    export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libproxychains.so.3
did not work. I also added this line to my `.bashrc` and refreshed it by `source ~/.bashrc`

Solution:
You need to add/edit it to `proxychains` by:

Code:
    sudo gedit /usr/bin/proxychains
if on 32bit Ubuntu and derivatives, replace `x86_64-linux-gnu` with `i386-linux-gnu`
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to solve fortran95 compilation error "Unexpected array reference at (1)" tom0395 Programming 8 12-12-2014 04:11 AM
[SOLVED] How can I solve "E: Error, pkgProblemResolver::Resolve generated breaks, this may be" jokar.mohsen Debian 2 11-29-2014 04:40 AM
sudo to solve this error "tar: Error exit delayed from previous errors" ? xombboxer Linux - Newbie 7 03-13-2012 02:26 AM
ERROR: ld.so: LD_PRELOAD cannot be preloaded xombboxer Linux - Newbie 2 05-12-2011 11:16 AM
ffmpeg, "error opening filters" - how to solve this problem? falmdavis Linux - Software 1 07-31-2010 08:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration