-   Debian (
-   -   High Cpu usage (

untak 09-29-2005 11:23 PM

High Cpu usage
I've tried everything I can think of I don't think its "debian" that is my problem however that is the distro I'm using and I dunno where to post this...

I'm using the latest version of Xorg ..Kernel 2.6.8-2 ..I load up after a fresh install Xfce (doesn't matter what GUI I use I've tried them all including flux) ..Check cpu usage in Top everything looks ok untill I open a program or start doing something then it spikes to 99% lets say I'm viewing a web page or browsing the internet the cpu usage goes very high and doesn't come down ..I've been struggling so much with this and I have no idea what to do any help I would appricate :)

linux-rulz 09-30-2005 12:30 AM

Are you able to post your system specs?

Also, does it only happen in XFCE or in all WM/DEs?

untak 09-30-2005 11:04 AM

all gnome,kde,Xfce,fluxbox

AMD AthlonXP 3000+
Asus AV7400A
512 DDR400
80Gig HDD

it happens with Xfree86 but mostly Xorg since its the one I use (latest version)

Kernel 2.6.8-2

my GFX is onboad S3 UniChrome (not installed just using via that comes with basic setting up xorg)

yanik 09-30-2005 11:42 AM

open a term and type top

you'll see what's eating all your CPU cycles.

linux-rulz 09-30-2005 08:32 PM

If you need a gui program instead of top, you can use ksysguard or gnome-system-monitor

untak 10-02-2005 02:44 PM

Sorry was afk for a while ...Like I said in my first post its xorg thats taking up my cpu hence the gui say I scroll in a browser window while looking at a website xorg goes up

linux-rulz 10-02-2005 03:59 PM

Hmmm, thats odd. Debian's packages come from Ubuntu, and Ubuntu doesn't have those problems.

Which video card are you using?

untak 10-02-2005 06:25 PM

its intergrated S3 Unichrome on my ASUS baord

linux-rulz 10-02-2005 06:27 PM

Please post the output of lspci :)

untak 10-03-2005 08:51 AM

0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
0000:01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video (rev 01)

linux-rulz 10-03-2005 06:17 PM

I'm thinking this may be a problem with the driver for your video card. Do you happen to have Debian running on another computer? Also, which version of are you running?

untak 10-03-2005 07:03 PM

I have a feeling you are correct, I've searched around alot and I have a feeling thats it as well, I'm using the latest version of Xorg I have also tried Xfree86 and noticed it had the same problem though, when ever I did something the CPU usage would go up, prehabs I should try a different distro? (even though I tested it on Ubuntu and debian) and I don't see how that would make much differnce however I did find a thread once about high CPU usage with S3 UniChrome GFX card, however it was beyond me on how to install that patch or driver they gave no information on how to do it or what to do they just mentioned it.

linux-rulz 10-03-2005 09:37 PM

Hmmmm.....How did you try XFree86? Did you try an older distro or did you compile it yourself? Anyways, you could always try something like a SUSE live CD or Knoppix or Mandriva Move or something. In that other thread with the same card as yours, was the person using Debian or a derivative?

untak 10-03-2005 10:06 PM

I just used apt-get to install Xfree86, was when I first used debian ...Ill try using FeatherLinux rite now and see how that goes ill pop in the cd and check :)

untak 10-03-2005 10:20 PM

hmm same results with Featherlinux although Xorg wasnt on the live cd so it was Xvesa and it wasn't AS bad but still I noticed when I opened firefox XVesa and firefox took up all my CPU doesn't seem normal I've used linux on the machine im on right now for a long time and never had problems like this... btw what post were u speaking of?

All times are GMT -5. The time now is 03:06 AM.