LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-13-2005, 09:23 AM   #1
hrr
LQ Newbie
 
Registered: Feb 2003
Location: Sweeden
Distribution: Debian
Posts: 6

Rep: Reputation: 0
HELP! Unable to lower MTU on pppoe connection


Hi

Getting a little desperate here....

I have an adsl connection on a firewall running Debian Sarge that uses PPPoE.

Since this firewall is also a VPN gateway (and I have trouble with PMTU, DF etc.) I need to lower the MTU to 1412 for the pppoe connection.

According to all I have read this must be done via the /etc/ppp/peers/dsl-provider file, but any changes to the mtu setting in this is ignored.

I get an mtu of 1492 no matter what I try.

I have also tried setting the mtu option in /etc/ppp/options (and even the mru same place).

I have tried setting "mtu 1412" for the physical interface (eth2) in /etc/network/interfaces.

No matter what I do I get an mtu of 1492 on the ppp0 interface when viewed with "ifconfig -a".

I had the same setup privously running on a Slackware box, where lowering the mtu wasn't a problem. But the configuration files for pppd is a little different in Debian.

What am I doing wrong?

Here is the (slightly modified) output from /var/log/debug from when the connection is set up (I have enabled "debug" in /etc/ppp/options):

Oct 13 13:53:21 mail kernel: eth2: Identified 8139 chip type 'RTL-8100B/8139D'
Oct 13 13:53:22 mail pppd[364]: rcvd [LCP ConfReq id=0x2 <mru 1492> <auth pap> <magic 0xe63da026>]
Oct 13 13:53:22 mail pppd[364]: sent [LCP ConfAck id=0x2 <mru 1492> <auth pap> <magic 0xe63da026>]
Oct 13 13:53:22 mail pppd[364]: sent [LCP EchoReq id=0x0 magic=0x794b9ff8]
Oct 13 13:53:22 mail pppd[364]: sent [PAP AuthReq id=0x1 user="hidden" password=<hidden>]
Oct 13 13:53:22 mail pppd[364]: rcvd [LCP EchoRep id=0x0 magic=0xe63da026]
Oct 13 13:53:22 mail pppd[364]: rcvd [PAP AuthAck id=0x1 ""]
Oct 13 13:53:22 mail pppd[364]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Oct 13 13:53:22 mail pppd[364]: rcvd [IPCP ConfReq id=0x1 <addr 213.173.x.x>]
Oct 13 13:53:22 mail pppd[364]: sent [IPCP ConfAck id=0x1 <addr 213.173.x.x>]
Oct 13 13:53:22 mail pppd[364]: rcvd [IPCP ConfNak id=0x1 <addr 213.173.x.x> <ms-dns1 195.184.96.2> <ms-dns3 195.184.96.3>]
Oct 13 13:53:22 mail pppd[364]: sent [IPCP ConfReq id=0x2 <addr 213.173.x.x> <ms-dns1 195.184.96.2> <ms-dns3 195.184.96.3>]
Oct 13 13:53:22 mail pppd[364]: rcvd [IPCP ConfAck id=0x2 <addr 213.173.x.x> <ms-dns1 195.184.96.2> <ms-dns3 195.184.96.3>]
Oct 13 13:53:22 mail pppd[364]: Script /etc/ppp/ip-up started (pid 657)
Oct 13 13:53:22 mail pppd[364]: Script /etc/ppp/ip-up finished (pid 657), status = 0x0

Thanks,
Henning
 
Old 10-16-2005, 06:56 PM   #2
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
You can configure the mtu on the interface which pppoe uses, e.g. eth0:

auto eth0
iface eth0 inet dhcp
mtu 1452

I have the same problem with pppoe, but setting the mtu on the hardware interface solves it for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pppoe MTU fedora core2 sonik.bhoom Linux - Networking 1 03-21-2005 11:29 PM
set mtu above 1500 of firewire connection edman007 Linux - Networking 1 09-20-2004 04:08 PM
Max MTU with PPPoE... murphaph Linux - Networking 0 04-03-2004 07:32 AM
PPPoE connection setup Tarts Linux - Networking 1 12-31-2003 08:46 PM
pppoe adsl connection tonyh Linux - Networking 0 05-22-2002 09:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration