LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-26-2009, 07:44 PM   #16
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Stretch Amd64
Posts: 1,477

Rep: Reputation: Disabled

Quote:
Originally Posted by wheeliee View Post
I did so, and it seems to have made no difference (resolution is still not right). For what it's worth - I don't see the nvidia logo before X starting, it should, shouldn't it?
You haven't tried to install the driver from Nvidia's website first by any chance?
Or do you have any old Nvidia packages installed on the system?

Yes,you should see the Nvidia logo before X starts.
In the meantime change the driver entry to nv,then restart X again.
This uses the 2d driver.
See if the resolution is improved.

Then i'd say go back and read through the guide again.

The main points are:

1, Compile and build the kernel module.

2, Install the glx libraries.

3, Configure X to use the 'Nvidia' driver.

You should then see the Nvidia logo before X starts.
You can check you have graphics acceleration by installing the mesa-utils package.Then run the command glxinfo.
You should see something like this: direct rendering: Yes
 
Old 07-26-2009, 07:48 PM   #17
wheeliee
Member
 
Registered: Aug 2008
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by the trooper View Post
You haven't tried to install the driver from Nvidia's website first by any chance?
Or do you have any old Nvidia packages installed on the system?
No, on both. I'm actually on a completely fresh install (only a few hours old, in fact).
Quote:
Originally Posted by the trooper View Post
Yes,you should see the Nvidia logo before X starts.
In the meantime change the driver entry to nv,then restart X again.
This uses the 2d driver.
See if the resolution is improved.
Yes, it indeed helps (resolution is back to a normal and proper size).

Quote:
Originally Posted by the trooper View Post
Then i'd say go back and read through the guide again.

The main points are:

1, Compile and build the kernel module.

2, Install the glx libraries.

3, Configure X to use the 'Nvidia' driver.

You should then see the Nvidia logo before X starts.
You can check you have graphics acceleration by installing the mesa-utils package.Then run the command glxinfo.
You should see something like this: direct rendering: Yes
I'll try it out.

Thanks for your time.
 
Old 07-26-2009, 07:54 PM   #18
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Stretch Amd64
Posts: 1,477

Rep: Reputation: Disabled
Quote:
Yes, it indeed helps (resolution is back to a normal and proper size).
Well it looks like the problem is with the Nvidia driver.
As i say,go through each step again carefully and see if you have missed anything.

Post back if i can help further.
 
Old 07-26-2009, 07:58 PM   #19
wheeliee
Member
 
Registered: Aug 2008
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by the trooper View Post
Well it looks like the problem is with the Nvidia driver.
As i say,go through each step again carefully and see if you have missed anything.

Post back if i can help further.
Alright, thanks.

I'll have to try tomorrow though - I'm very sleepy and tired right now.

Thanks again for spending what seems to be easily 2 hours on me.
 
Old 07-27-2009, 12:19 AM   #20
wheeliee
Member
 
Registered: Aug 2008
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by the trooper View Post
Well it looks like the problem is with the Nvidia driver.
As i say,go through each step again carefully and see if you have missed anything.

Post back if i can help further.
Well, I tried again.. reading over the procedure and redoing it as carefully as I could. I'm on it right now (the nvidia drivers), but with the low resolution, as I had mentioned (1024x768, as I'm being told by 'Screen Resolution' - it gives no higher options, by the way). 3d acceleration seems to be working as well.. I seem to be getting a fancy 2500 fps with glxgears.

Oh, and I thought I might as well give the non-Debian way a try -- trying nVidia's things, but they seemed to have no prebuilt version -- and so I tried going with source, it then complained that gcc was not up to date, and errors may occur - I tried to do it anyway - alas, it didn't work. (One more note: it is possible.. I had them working before back about 4 months ago when I initially tried Debian for the first time - I recall someone on IRC helped me. (some things broke, and I had to reinstall.. and here I am :-\))

I'll keep on looking though.
Wish me luck.

Last edited by wheeliee; 07-27-2009 at 12:24 AM.
 
Old 07-27-2009, 02:14 AM   #21
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
Try using xrandr to get the resolution you want.

Just running xrandr will give you the ones available, like:
$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 2048 x 2048
VGA connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
1280x1024 60.0*+ 75.0 60.0*
1152x864 75.0
1024x768 75.0 60.0
800x600 75.0 60.3
640x480 75.0 59.9
720x400 70.1

xrandr --output VGA-0 --mode 1024x768 --rate 75 & will give you 1024x768 etc.
http://www.x.org/wiki/Projects/XRandR

Also you might want to try using smxi to install your nvidia drivers.
 
Old 07-27-2009, 02:31 AM   #22
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
whoops - I didn't see the 2nd page. Ignore this.
jdk

Last edited by jdkaye; 07-27-2009 at 02:32 AM.
 
Old 07-27-2009, 02:34 AM   #23
wheeliee
Member
 
Registered: Aug 2008
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by craigevil View Post
Try using xrandr to get the resolution you want.

Just running xrandr will give you the ones available, like:
$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 2048 x 2048
VGA connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
1280x1024 60.0*+ 75.0 60.0*
1152x864 75.0
1024x768 75.0 60.0
800x600 75.0 60.3
640x480 75.0 59.9
720x400 70.1

xrandr --output VGA-0 --mode 1024x768 --rate 75 & will give you 1024x768 etc.
http://www.x.org/wiki/Projects/XRandR

Also you might want to try using smxi to install your nvidia drivers.
Hi, thanks for taking the time to help.

I did try that -- but the maximum res. it offers me is still very small:
Code:
kh@slimdeb:~$ xrandr
Screen 0: minimum 320 x 175, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       50.0*    51.0     52.0     53.0     54.0     55.0  
   960x720        56.0  
   960x600        57.0     58.0  
   928x696        59.0  
   896x672        60.0     61.0  
   840x525        62.0  
   832x624        63.0  
   800x600        64.0     65.0     66.0     67.0     68.0     69.0     70.0     71.0     72.0     73.0  
   800x512        74.0  
   720x450        75.0  
   720x400        76.0  
   640x512        77.0     78.0     79.0  
   640x480        80.0     81.0     82.0     83.0     84.0     85.0  
   640x400        86.0     87.0  
   640x384        88.0  
   640x350        89.0  
   576x432        90.0     91.0  
   576x384        92.0  
   512x384        93.0     94.0     95.0     96.0     97.0  
   416x312        98.0  
   400x300        99.0    100.0    101.0    102.0    103.0  
   360x200       104.0  
   320x240       105.0    106.0    107.0    108.0  
   320x200       109.0  
   320x175       110.0
With vesa, it defaults to a very nice and proper 1600x1200 (my monitor is 20" I think).

Furthermore, I'm beginning to think now that I'm not at fault, there may be a bug around here somewhere. The reason being, I found the IRC logs when someone helped me through getting the drivers last time (about a month ago -- with 5.0.1, however (now I'm trying it with 5.0.2) - I followed every command to the letter -- they did not work for me this time.
 
Old 07-27-2009, 02:48 AM   #24
wheeliee
Member
 
Registered: Aug 2008
Posts: 47

Original Poster
Rep: Reputation: 15
It works!

It works now.

You know what I had to do? Try another monitor -- my 22" LCD monitor. I have absolutely no clue why it chooses to work perfectly with the LCD but not the CRT.. but it does.

Here's the xrandr now:
Code:
kh@slimdeb:~$ xrandr
Screen 0: minimum 320 x 175, current 1680 x 1050, maximum 1680 x 1050
default connected 1680x1050+0+0 0mm x 0mm
   1680x1050      50.0*    51.0  
   1600x1024      52.0  
   1440x900       53.0  
   1400x1050      54.0     55.0     56.0  
   1280x1024      57.0     58.0     59.0  
   1280x960       60.0     61.0  
   1280x800       62.0  
   1280x768       63.0  
   1280x720       64.0  
   1152x864       65.0     66.0  
   1152x768       67.0  
   1024x768       68.0     69.0     70.0     71.0  
   960x720        72.0  
   960x600        73.0     74.0  
   928x696        75.0  
   896x672        76.0  
   840x525        77.0  
   832x624        78.0  
   800x600        79.0     80.0     81.0     82.0     83.0     84.0     85.0     86.0     87.0     88.0  
   800x512        89.0  
   720x450        90.0  
   720x400        91.0  
   640x512        92.0     93.0     94.0  
   640x480        95.0     96.0     97.0     98.0     99.0    100.0  
   640x400       101.0    102.0  
   640x384       103.0  
   640x350       104.0  
   576x432       105.0    106.0  
   576x384       107.0  
   512x384       108.0    109.0    110.0    111.0  
   416x312       112.0  
   400x300       113.0    114.0    115.0    116.0    117.0  
   360x200       118.0  
   320x240       119.0    120.0    121.0    122.0  
   320x200       123.0  
   320x175       124.0
Everything looks sharp and crisp (in 1680 x 1050 res). glxgears operates at a comfortable 2000 fps, and all is well.

Thank you again the trooper, for taking the time to help. I really do appreciate it. and thank you as well, craigevil
(and, also, I'm sorry that I was being very dull - not reading docs as closely as I should had -- but reading with that res. was not a forgiving task for my eyes, and I get dizzy really quickly anyway)

Last edited by wheeliee; 07-27-2009 at 03:05 AM.
 
Old 07-27-2009, 02:48 AM   #25
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Rep: Reputation: 57
from teh console alt ctrl f1, i run this usually:
Code:
     echo "Installing Nvidia"
        apt-get update 
        /etc/init.d/gdm stop
        apt-get -f -y --allow-unauthenticated install gcc
        apt-get -f -y --allow-unauthenticated install build-essential
        apt-get -f -y --allow-unauthenticated install nvidia-kernel-$(uname -r)
        apt-get -f -y --allow-unauthenticated install 
        aptitude install module assistant build-essential
        m-a update
        m-a prepare
        m-a auto-install nvidia -f
        modprobe nvidia
        cd /tmp
 
Old 07-27-2009, 05:14 AM   #26
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Stretch Amd64
Posts: 1,477

Rep: Reputation: Disabled
Great to hear you got things sorted.
Thanks for taking the time to post back the solution also.
 
Old 07-27-2009, 05:21 AM   #27
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
is there a hardware drivers tool like in ubuntu and deratives cos thats good for nvidea drivers
(i have a geforce 8300gs)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing nvidia 5200 fx drivers on debian NightLeech Linux - Newbie 6 03-21-2009 01:32 PM
Problem installing Nvidia Legacy drivers on Debian sureshot324 Linux - Software 3 06-03-2007 12:22 AM
confused about installing nvidia drivers on debian Michael_aust Debian 22 05-01-2006 09:00 AM
HOWTO: Installing nVidia Graphics Drivers on Debian Etch MrKrrtft Debian 1 12-27-2005 03:04 AM
nVidia drivers not installing with debian x86_64 Wolvenmoon Linux - Newbie 1 08-16-2005 07:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration