LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-29-2004, 11:28 PM   #1
jeffthespasm
LQ Newbie
 
Registered: Jul 2004
Distribution: Debian
Posts: 4

Rep: Reputation: 0
Help me please!!!


I'm new to Linux, I just installed the latest build of Debian on a second hard drive.

I am using a Radeon 9200 graphics card. I don't know if knowing that will help answer the question or not.

I got linux installed, and accidentally chose 1280x960 for my resolution, which will not normally work. Then, when Debian booted up, the screen was HUGE. All I could see was "Sessions", which took up the entire screen. With the help of a friend, I managed to log in, and get to the desktop. After exiting out of the windows, the desktop was normal resolution. But, when I opened a window, or even hovered and got tool tips, the text was also HUGE. I mean, one word takes up the entire screen huge. I'm not sure if this is a problem with just text size or with resolution. I can't even see what I'm doing in the configuration windows, so I can't really do anything about it.

Does anyone know of any way to fix this, such as changing text/resolution size with the keyboard? I tried Ctrl+Alt+ - or +, but it did not work to change it. Can anyone help, or do I have to completely reinstall?

Thanks very much in advance.
 
Old 07-29-2004, 11:46 PM   #2
Ankheg
Member
 
Registered: Jul 2004
Location: Woodland Hills, CA
Distribution: Debian/Mandrake
Posts: 37

Rep: Reputation: 15
When I was first starting out, I used to run into this all of the time...usually because I would try to push my puny graphics card to it's limits... It was very soon I became familiar with a few things, the most notable being XF86Config.

If you log into the console (if you come to the graphical login by default [sounds like you do], you'll probably want to do ctrl+alt+f1 to get to a console).

Log in as root, or su to root.

Run xf86config (usually, you can simply type this at the prompt).

It will put you through a series of questions to reconfigure X, with a fairly large portion of it being the display.

Once you're done:

Log out of the root account, and log into your user, and type startx.
OR
Log out of the root account, and use ctrl+alt+f7 to get back to your graphical login, and use ctrl+alt+backspace to restart X from there, and login as you would normally.


Depending on what distro you're using (when I went through all of this before, I was using Mandrake), you might just setup just enough to make sure you know it will work (like 640x480x16 or something), then once I got into X, I would use Xconfigurator to configure it further, so I could see results much faster of what did/didn't work. Though, this can be dangerous too, because I remember doing that several times and switching to something that simply wouldn't work, and not being able to navigate blindly well enough to change it back, resulting in going right back to step 1...hehe... Though, that's now been years since I've done that, and the tools may have progressed quite a bit since I did anything along these lines.

Hope this helps!
 
Old 07-30-2004, 01:28 PM   #3
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 52
as root:

dpkg-reconfigure xserver-xfree86

and this time do it right, follow the instructions from sections 9 amd 10: Installing XFree86 Parts I and II, from the article by Clinton De Young:

The Very Verbose Debian Installation Walkthrough
http://osnews.com/story.php?news_id=2016
 
Old 07-31-2004, 01:52 PM   #4
Clark Bent
Member
 
Registered: Jul 2004
Distribution: Debian, FreeBSD, Slamd64
Posts: 201

Rep: Reputation: 30
Another optition is to open up your XF86Config file with your favorite editor (be it nano, vi, emacs...whatever you like best) and just edit out the resolutions you don't want. Thats what I always do. So open up the file and scroll on down until you see:


# ***************************************************
*******************
# Screen sections
# ***************************************************
*******************

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600"
"640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600"
"640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768"
ViewPort 0 0
EndSubsection


Ok...you have your 8 bit, 16 bit, and 24 bit options. One of which, you run as your default depending on what you selected when configured X the first time. But regardless, you can alter all there. You see the modes line? It's listed by preference in order. For example, I want to run 1280x1024 as my first choice. 1024x768 as my second choice, and 800x600 as my third. If you have something in there that you don't want, just remove that resolution. Make sure you keep quotes around those that you do leave.

To change your resolution on the fly, just hit CRL+ALT+ the minus or plus key to increase or decrease your resolution.
 
Old 08-01-2004, 12:39 AM   #5
jeffthespasm
LQ Newbie
 
Registered: Jul 2004
Distribution: Debian
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for all the responses! I've finally got it running decently.

Now I've got to get good with Linux so I can help out around the forums.

Thanks again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration