LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-18-2005, 05:32 AM   #1
floppywhopper
Member
 
Registered: Aug 2004
Location: Western Australia
Distribution: Mageia , Centos
Posts: 643
Blog Entries: 2

Rep: Reputation: 136Reputation: 136
Graphical boot


I have installed Debian 3.1 on a Pentium 200, 64 M Ram, 2 m vid card

apart from a few issues I am confident of fixing,
X wont start at boot up.
I changed inittab to rl 5
is there something else I need to do

I have read the manuals but cant find the answer
currently after the text login I type startx
but I want KDE to start automatically

floppy
 
Old 09-18-2005, 05:51 AM   #2
dinolinux
Member
 
Registered: Jun 2005
Location: Oslo, Norway
Distribution: Slackware 11, Solaris 10, Solaris 9, Sourcemage 0.9.6
Posts: 322

Rep: Reputation: 31
X should start automatically if you configure it right. If you want KDE to start when you type startx, edit the /etc/X11/xinit/xinitrc and change this:
Code:
else
	# start some nice programs
	twm &
	xclock -geometry 50x50-1+1 &
	xterm -geometry 80x50+494+51 &
	xterm -geometry 80x20+494-0 &
	exec xterm -geometry 80x66+0+0 -name login
fi
to this:
Code:
else
        # start kde
        startkde &
fi
 
Old 09-18-2005, 06:19 AM   #3
lpd
Member
 
Registered: Nov 2004
Distribution: Debian Unstable
Posts: 77

Rep: Reputation: 15
To get a graphical login you need to install a Display Manager, like kdm, xdm, wdm or gdm.
 
Old 09-18-2005, 06:40 AM   #4
floppywhopper
Member
 
Registered: Aug 2004
Location: Western Australia
Distribution: Mageia , Centos
Posts: 643

Original Poster
Blog Entries: 2

Rep: Reputation: 136Reputation: 136
I can start KDE by typing startx
but it doesn't go straight to a graphical login at boot
sorry if I didn't make myself clear

I was hoping by changing innitab to rl 5
it would go straight to KDE
but it doesn't

so to clarify
it goes to a text login
and then I startx
it goes to KDE
I logout of KDE
it drops back to a text screen only
I logout or shutdown from there
no option in KDE to shutdown

hope this clears things up
thanks for the help so far

floppy
 
Old 09-18-2005, 06:47 AM   #5
McCloud
Member
 
Registered: Sep 2004
Distribution: Debian Etch
Posts: 179

Rep: Reputation: 30
Have you installed KDM, GDM or XDM ??? If you use KDE I would try installing KDM.
Code:
aptitude install kdm
or if you use apt-get to install packages
Code:
apt-get install kdm
Good luck.
 
Old 09-20-2005, 03:24 AM   #6
floppywhopper
Member
 
Registered: Aug 2004
Location: Western Australia
Distribution: Mageia , Centos
Posts: 643

Original Poster
Blog Entries: 2

Rep: Reputation: 136Reputation: 136
YES !!!
apt-get didn't work
but aptitude did

thank-you for your help
now boots straight to KDE

floppy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphical boot thomasfingram Linux - Newbie 2 06-27-2005 04:30 AM
switching graphical boot up to text boot up? chunlee Linux - Newbie 4 12-03-2004 03:55 AM
Graphical Boot Jose Muņiz Mandriva 4 03-12-2004 06:25 PM
2.6.1 and the graphical boot-up benjithegreat98 Fedora 7 02-03-2004 10:52 PM
graphical boot Phantom Rayne Slackware 6 04-07-2003 11:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration