LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-26-2008, 12:43 AM   #1
zero7
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Rep: Reputation: 0
Gnome system sounds not playing


Hi All,

My sound is working well in debian testing (brand new install) except for system sounds. I'm running gnome 2.22.1 with the new 2.6.24-1-686 kernel. Has anyone else run into this problem?

Thanks,

zero7
 
Old 04-26-2008, 04:24 AM   #2
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 675
Blog Entries: 11

Rep: Reputation: 36
Do you have the system sounds enabled? I know it's a dumb question. The way to enable it is to go to Sound Preferences. From the System menu at the top of the screen follow the route "System=>Preferences=>Sound Preferences". You should see a dialog with three tabs. Go to the tab marked "System Beep" and make sure that the "Enable System Beep" checkbox is checked. You've probably already done this, so if you have disregard this post.
 
Old 04-26-2008, 04:13 PM   #3
zero7
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks. I never take offense in someone pointing out the obvious in debian; I've slapped my forehead many times :-).

I have the following enabled:

-Sounds/enable software sound mixing, and play system sounds

-System Beep/enable system beep

To be fair, the same thing is happening on gnome 2.22.1 with freebsd. My cd and dvd audio play fine and ALSA shows as activated at startup.

Clueless,

zero7
 
Old 04-26-2008, 05:13 PM   #4
zero7
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Ok, I've resolved this issue. This is how I did it:

aptitude install pulseaudio-esound-compat

checked /usr/bin/esd to make sure it was symlinked to esdcompat- it was.

Rebooted and voila! All system sounds now play.

Cheers,

zero7
 
Old 11-20-2008, 09:28 PM   #5
Wenches_Master
LQ Newbie
 
Registered: Oct 2008
Location: Kentucky U.S.A
Distribution: Linux Mint/Gnome Desktop
Posts: 2

Rep: Reputation: 0
Lightbulb

Quote:
Originally Posted by zero7 View Post
Ok, I've resolved this issue. This is how I did it:

aptitude install pulseaudio-esound-compat

checked /usr/bin/esd to make sure it was symlinked to esdcompat- it was.

Rebooted and voila! All system sounds now play.

Cheers,

zero7
I'm running Linux Mint 6rc1 and am having the same problem.
I'll give this a shot and let you know if it worked for me to....
Keeping fingers crossed....

Nope didn't work but here's the readout from my usr/bin/esd File maybe you can tell me what's wrong?


VERSION_STRING="pulseaudio esd wrapper 0.9.10"

fail() {
echo "ERROR: $1"
exit 1
}

ARGS=" --log-target=syslog"

while [ "$#" -gt "0" ]; do

case "$1" in
"")
;;

-v|--version)
echo "$VERSION_STRING"
exit 0
;;

-h|--help)
cat <<EOF
$VERSION_STRING

Usage: $0 [options]

-v --version print version information
-h --help show this help

Ignored directives:

-tcp use tcp/ip sockets in addition to unix domain
-promiscuous don't require authentication
-d DEVICE force esd to use sound device DEVICE
-b run server in 8 bit sound mode
-r RATE run server at sample rate of RATE
-as SECS free audio device after SECS of inactivity
-unix use unix domain sockets instead of tcp/ip
-public make tcp/ip access public (other than localhost)
-terminate terminate esd daemone after last client exits
-nobeeps disable startup beeps
-trust start esd even if use of /tmp/.esd can be insecure
-port PORT listen for connections at PORT (only for tcp/ip)
-bind ADDRESS binds to ADDRESS (only for tcp/ip)
EOF
exit 0
;;

-spawnpid)
shift
ARGS="$ARGS '-Lmodule-esound-compat-spawnpid pid=$1'"
;;

-spawnfd)
shift
ARGS="$ARGS '-Lmodule-esound-compat-spawnfd fd=$1'"
;;

-unix|-b|-public|-terminate|-nobeeps|-trust|-tcp|-promiscuous)
# Ignore these commands
;;

-d|-r|-as|-port|-bind)
# Ignore these commands and their arguments
shift

;;

*)
fail "Unknown command: $1"
;;
esac

shift
done

eval "exec '/usr/bin/pulseaudio'$ARGS"


Also here are my lspci readouts if they help?

rickity@rickity-laptop ~ $ lspci
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 83)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]
06:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
06:02.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
06:04.0 CardBus bridge: ENE Technology Inc CB-712/4 Cardbus Controller (rev 10)
06:04.1 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller (rev 01)
06:04.2 SD Host controller: ENE Technology Inc ENE PCI Secure Digital Card Reader Controller (rev 01)
06:04.3 FLASH memory: ENE Technology Inc FLASH memory: ENE Technology Inc: (rev 01)
06:04.4 FLASH memory: ENE Technology Inc SD/MMC Card Reader Controller (rev 01)
rickity@rickity-laptop ~ $

Thanks in Advance.

Last edited by Wenches_Master; 11-20-2008 at 10:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
System sounds don't work as well as sounds through a browser Bagmeijer Linux - Newbie 1 03-03-2008 11:53 AM
system sounds have statick gnome 2.10 Abe_the_Man Linux - Software 1 06-27-2005 02:07 PM
wrong sample rate for Gnome system sounds sharkzf6 Linux - Hardware 0 03-10-2005 10:10 AM
artsd crashing when playing system sounds Metalbarthug SUSE / openSUSE 6 11-13-2004 02:59 AM
Playing sounds dark_light Linux - General 1 09-06-2002 03:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 03:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration