-   Debian (
-   -   GNOME settings daemon error (

radiodee1 07-28-2009 10:58 AM

GNOME settings daemon error
I get this error after squeeze updates from 7/27. I see this error dialog box when I log into gnome. It doesn't keep me from using the session, as I can dismiss the dialog and everything seems to work after that. I googled the text, and some people point to my /etc/network/interfaces file and the /etc/hosts file, while some people point to .gconf, .gconfd, .gnome, .gnome2 and .gnome2_private . The text from the error message is below


There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

GNOME will still try to restart the Settings Daemon next time you log in.
I don't think my networking is responsible, as my files are all pretty straight forward. My question is has anyone else had this problem, have they any advice, and if I go the route of deleting the gnome configuration files from my home directory, what will I loose in the way of configuration? -- What am I going to achieve and what am I going to loose?

radiodee1 07-28-2009 04:02 PM

I created a new user and the problem persisted when I logged on with that user too. As I said above it doesn't keep me from using gnome, but I would like to know what the problem is. I guess erasing my folders named .gconf, .gconfd, .gnome, .gnome2_private and .gnome2 won't do anything.

radiodee1 07-29-2009 05:39 AM

I purged kdebase-workspace and all that went with it, and ended up getting rid of the GNOME error along with 40 packages or so. I had installed kdebase-runtime on another occasion, so that wasn't removed, so I can still use my favorite kde4 apps. I'm really a gnome user, not a kde user, so this is no big deal to me. :)

jim_p 08-05-2009 04:06 AM


I am facing the same exact problem on my brother's laptop for the last 4-5 days.
Debian testing, fully updated, not a single kde (3 or 4) package installed except the ones required by k3b (unique k-app in here).

I also have a desktop pc that has 98% the same packages as the laptop, but nothing happened there! Both have openbox installed as a "fallback" when gnome starts to act weird.

As a workaround i switched from autologin to delayed autologin (10 seconds), because it seems something was not ready for use upon login. Error is gone, but I still can't run nautilus as root.

If you have any idea on how to solve this, please post.

Thank you.

(I can post some errors that nautilus does due to prove the above)

radiodee1 08-05-2009 05:11 AM

Yeah, this error has returned for me too. I guess it doesn't have anything to do with removing 'kdebase-workspace'. I just marked the thread 'UNSOLVED'. I also found this bug report. It doesn't suggest a solution.

jim_p 08-06-2009 03:44 AM

I continue troubleshooting and I need some help.

How can i temporarily disable gnome-panel from starting upon login?
Please note that it is NOT listed inside System > Preferences > Sessions and it can restart itself even when you kill it with killall.

Nautilus and metacity will follow the same route as gnome-panel, so this has to be found somehow.

jim_p 08-08-2009 03:02 AM

After today's update on some other pc running testing (the owner can't update his system by himself), I remembered that the day this begun to happen, there was an update on hal or dbus or something and I can recall it stopped nautilus (killall).

On my pc I totally ignored the "kill", since i had to shutdown and leave home at once.
On the laptop I started nautilus again (alt+f2) and that's where it begun I guess...

bgoodr 08-08-2009 08:13 PM

I am seeing this dialog box, too. And, only on my Debian Linux laptop, and not on my Debian Linux desktop PC. I, too, can close the dialog box and continue without any problems, but it is getting annoying to have that dialog box popup each time. In my thinking, that dialog box is not helpful at all, as it doesn't give much hint as to what could cause the settings daemon to fail like this.


radiodee1 08-09-2009 06:29 AM

Yesterday I updated 'libdbus-glib-1-2' as part of my regular updates. Today I have booted up twice without the dreaded error box. Though this problem has been intermittent for me from the start, maybe this has fixed it.

EDIT: now that I think about it, I'm not sure what package is actually responsible for the change.

jim_p 08-10-2009 12:55 AM

What is apt's logs file so as to check if I have it updates as well?

radiodee1 08-10-2009 06:24 AM

jim_p, I use aptitude, so the logs for aptitude would be stored in '/var/log/aptitude'. I don't know about the logs for apt-get, BUT I was wrong about the package 'libdbus-glib-1-2' solving the Gnome Settings Daemon problem, because my startup this morning produced the same error again. I'm sorry if I got anyone's hopes up. The problem is intermittent on my computer, so yesterday it just didn't happen.

Looking in the directory '/var/log/' I think you can get some idea of the recent operations of apt-get by issuing the command 'cat /var/log/dpkg.log | grep install' or 'cat /var/log/dpkg.log | grep libdbus-glib' . There is also info in a file called '/var/log/apt/term.log' but you must be root to view it. I don't know if that's apt-get or aptitude.

jim_p 08-10-2009 10:00 AM


As the log informs me, my libdbus-glib-1-2 was updated too.

# cat /var/log/dpkg.log | grep libdbus | tail
2009-08-08 10:52:13 status half-configured libdbus-glib-1-2 0.80-4
2009-08-08 10:52:13 status unpacked libdbus-glib-1-2 0.80-4
2009-08-08 10:52:13 status half-installed libdbus-glib-1-2 0.80-4
2009-08-08 10:52:14 status half-installed libdbus-glib-1-2 0.80-4
2009-08-08 10:52:14 status unpacked libdbus-glib-1-2 0.82-1
2009-08-08 10:52:14 status unpacked libdbus-glib-1-2 0.82-1
2009-08-08 10:52:29 configure libdbus-glib-1-2 0.82-1 0.82-1
2009-08-08 10:52:29 status unpacked libdbus-glib-1-2 0.82-1
2009-08-08 10:52:29 status half-configured libdbus-glib-1-2 0.82-1
2009-08-08 10:52:29 status installed libdbus-glib-1-2 0.82-1

But the problem insists! Can I start telling about ubuntu's influence on gnome now? :@

radiodee1 08-13-2009 06:57 AM

I went ahead and installed gnome-settings-daemon from unstable. It seems to work. My experience with this error has been that it has been intermittent on my machine, so I cannot tell you if it will work tomorrow, but for three or four reboots today there has been no error message.

I am posting this message to another thread too:

EDIT: this solution continues to work for me several days after the initial upgrade to 2.26.1-2 so I'm marking the thread SOLVED (again).

All times are GMT -5. The time now is 10:35 AM.