LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-23-2004, 06:51 PM   #1
robbow52
Member
 
Registered: Oct 2003
Location: Kentucky, USA
Distribution: Debian "SID"
Posts: 110

Rep: Reputation: 15
Unhappy Gnome/Mozilla problems after upgrade...


I'm running Sid and did a dist-upgrade this afternoon. It installed a number of packages including a Mozilla upgrade from 1.7.2 to 1.7.3... I noticed during the configuring of Mozilla that it was creating a symlink... When I logged into Gnome, the first thing I did was to launch Mozilla Mail and I received an error... No such file or directory.

To make a long story short, all of my Mozilla launchers in Gnome are "Mozilla-1.7.2 -Something"... The link that Mozilla created during the install was:

/usr/bin/mozilla -> /etc/alternatives/mozilla

which in turn links to /usr/bin/Mozilla-1.7.3. Certainly it makes sense to just have "mozilla" run everything, but the links above did nothing for my launchers all pointing to Mozilla-1.7.2. The first thing that I tried to do was to edit the properties of the launchers in the Gnome menus (changed "Mozilla-1.7.2" for the browser to "Mozilla" and so on) which worked but did not stay! I logged off and then back on and they had reverted! To fix the problem I just added another symlink:

/usr/bin/mozilla-1.7.2 -> /etc/alternatives/mozilla

which "fixes" things so they will start now, but what is up with the Gnome/Mozilla menu items? How do I edit a these launchers so that the changes are saved? (I added a test launcher to a menu, logged off and back on and it stayed fine!)

Thanks in advance for your help!
 
Old 09-23-2004, 07:00 PM   #2
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
in the properties, change it to mozilla 1.7.3, that should do it.
 
Old 09-23-2004, 08:01 PM   #3
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
i guess when u run sid, u have to accept that things break every now and then. when it happens, you should submit a bug report so that the developers know that they broke something.

http://www.debian.org/Bugs/

Last edited by zero79; 09-23-2004 at 08:03 PM.
 
Old 09-23-2004, 09:17 PM   #4
robbow52
Member
 
Registered: Oct 2003
Location: Kentucky, USA
Distribution: Debian "SID"
Posts: 110

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by macondo
in the properties, change it to mozilla 1.7.3, that should do it.
That's the problem, I edited the properties of the launchers (changed them from "Mozilla-1.7.2 -Whatever" to just "Mozilla -Whatever) which worked fine for that session, but when I logged out and then logged back on, they had reverted! I even created a launcher in one of the menus to test to see if it was me... Logged out and then back on and my test launcher was still there and working, but the "changes" to the Mozilla launchers had reverted!

Thoughts???
 
Old 09-24-2004, 10:56 AM   #5
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
after you change the mozilla version, SAVE the session.

i don't use gnome, but iirc, it comes out of Main Menu > Advanced > sessions, all i remember is, that it was the last item on the long drop-down menu, which included fonts, among other things.

BTW, it also hapenned to me in IceWM, so i changed the version with iceme, you don't have to save the session. I love that icewm!

Last edited by macondo; 09-24-2004 at 11:03 AM.
 
Old 09-24-2004, 01:38 PM   #6
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
Ok, i just got back from my neighbor's house, he wanted to install Gnome. We installed gnome-core (less weight) and icewm, he uses Debian/Sid.

#apt-get install gnome-core icewm

Once installed, we made icewm the windowmanager within gnome by editing the ~/.gnomerc file to show icewm as the window manager instead of metacity, this makes it faster.

#vim /home/raul/.gnomerc

the end result is:

# set the default GNOME window manager
export WINDOW_MANAGER=/usr/bin/icewm

you can do this with fluxbox or windowmaker if you desire, just make sure you got them installed.


We eliminated the gnome splash screen, because it doesn't do didly, just hog resources, thru:

Applications > Desktop Preferences > Advanced > Sessions

and unmarking the "Show splash screen on login", we marked the box for "Saving the session automatically".

We also changed the name and command of the terminal icon in the toolbar at the top, by right-clicking on the icon, choosing properties, and changing it to

xterm

It launches faster.

We created an icon for Mozilla, went to Properties, changed to 'Mozilla 1.7.3' in the command section, did a Ctrl+Alt+Backspace to logout, logged in, and it was perfect.

Last edited by macondo; 09-24-2004 at 02:02 PM.
 
Old 09-24-2004, 04:47 PM   #7
robbow52
Member
 
Registered: Oct 2003
Location: Kentucky, USA
Distribution: Debian "SID"
Posts: 110

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by macondo
after you change the mozilla version, SAVE the session.

i don't use gnome, but iirc, it comes out of Main Menu > Advanced > sessions, all i remember is, that it was the last item on the long drop-down menu, which included fonts, among other things.

BTW, it also hapenned to me in IceWM, so i changed the version with iceme, you don't have to save the session. I love that icewm!
I did save the session after the changes. The launchers still revert after logging back on.

I filed a bug report and the maintainer e-mailed me that the bug has been fixed in the next version.

Thanks!
 
Old 09-24-2004, 05:17 PM   #8
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
"I did save the session after the changes. The launchers still revert after logging back on."

It hapenned to my friend too, he unchecked the box for saving the sessinon and deleted the 'default' session in the dialog box, logout/login and now it works fine.
 
Old 09-24-2004, 05:34 PM   #9
robbow52
Member
 
Registered: Oct 2003
Location: Kentucky, USA
Distribution: Debian "SID"
Posts: 110

Original Poster
Rep: Reputation: 15
Wink Update...

Just as an update, I managed to get my session locked up pretty well (don't ask!) and I could ctrl+alt+backspace out of Gnome, but when I logged back in, I was still faced with the same problem, it locked up right after it started. I could have logged in with a safe session, but I decided to just reboot... (and I hate to do that : -(...)

After the reboot everything seemed fine, so I decided to edit the launchers again for Mozilla just to see... Now they will save!!! I suppose something either in my session or an event during the upgrade.

Thanks for the help and ideas!
 
Old 09-24-2004, 06:35 PM   #10
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
it's like i've said before, KDE and GNOME are too big and complex, too much crap to maintain.

if you look around the forums, problems with these two are the norm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome 2.10 upgrade problems mkoljack Fedora 1 04-12-2005 02:08 AM
Mozilla and Gnome problems s1l3ntbob Debian 4 01-23-2005 02:42 PM
Cannot Change GNOME Menu Items to add/change Item for Mozilla 1.2 After Upgrade metoome General 0 03-27-2004 01:19 AM
Cannot Change GNOME Menu Items to add/change Item for Mozilla 1.3 After Upgrade SForsgren Linux - General 4 03-27-2004 12:43 AM
Problems with Mozilla after upgrade to RH 9.0 and_deva Linux - Software 4 07-02-2003 09:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration