LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-15-2011, 03:43 PM   #1
Hangaber
Member
 
Registered: Sep 2004
Location: USA
Distribution: Slackware
Posts: 154

Rep: Reputation: 47
Gnome, better gnome-volume-control, setting default playback channel


The 'mute' button on my keyboard will only mute the "Front" channel, and the volume up/down keys also only control this channel.

When I go in to the gnome-volume-control, I can mute the whole system and all speakers from the 'PCM' slider.

I installed a few other sound apps (sound recognition, etc) a few days ago but have since reverted to the previous state. During that time, something changed somewhere and the volume control applet was MUCH better, allowing me to set a default channel for mute/etc, set my setup to 5.1, set the correct default recording channel (mic 1 instead of line-in)

I'd like to set PCM as my default channel for mute/etc... but I can't figure out how to bring that 'advanced' gnome volume control applet up, or even get to those settings.

Any advice would be appreciated!


Debian squeeze, (2.6.32-5-amd64)
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: VT1828S Analog [VT1828S Analog]
Subdevices: 1/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
 
Old 03-15-2011, 04:33 PM   #2
Hangaber
Member
 
Registered: Sep 2004
Location: USA
Distribution: Slackware
Posts: 154

Original Poster
Rep: Reputation: 47
I installed pulseaudio, did an 'alsa unload', made sure 'pulseaudio' was running.
Then the gnome-volume-control.pulse opened up, but I don't see any "default mixer/channel" option.

(I then removed pulseaudio and restarted alsa.)

Somehow this fixed my "mute" button, it now mutes everything (rather than only just the front channel), but the volumeLower and volumeRaise still only apply to the front channel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa: how to set gnome-volume-control-applet to master channel? Kropotkin Linux - Hardware 1 11-07-2010 03:01 AM
gnome keyboard shortcuts: volume mute other channel psychobyte Linux - Software 3 04-20-2007 12:15 PM
Wave Surround setting missing in Gnome volume control buldir Mandriva 2 10-17-2005 10:05 AM
Volume Control in Gnome dudeman41465 Linux - Software 3 10-09-2005 02:15 PM
Volume Control in Gnome dudeman41465 Mandriva 2 10-09-2005 05:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration