LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-27-2005, 06:12 AM   #1
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Rep: Reputation: 15
gnome and gdm problems


I've posted these problems in anotherthread but now I'm following redazz advice and starting my own thread .

Issues are these:
1) the most serious - I can't reboot or shutdown from Gnome. SOLVED - I was getting packages and upgrades from sid then I edited my sources.list to point out to unstable versions of Debian, marked all upgradable packages in Synaptic, apllied changes and actually making the upgrades. Somehow the problem was solved

2) I can't use Alt and Alt Gr keys and I need them to insert special characters of portuguese language, for the "euro" symbol and "at" symbol. Please, I'm not entirely new to this: I already went to keyboard layouts, portuguese is chosen as default; my XF86Config-4 file has the xrules and the xkbdlayout set to the right values
Code:
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "keyboard"	
	Option      "CoreKeyboard"
	Option "XkbRules" "xfree86"
	Option "XkbModel" "pc105"
	Option "XkbLayout" "pt"
EndSection
I also have tried dpkg-reconfigure locales but nothing seems to worked. In KDE and using kdm everything was ok. Should I return to KDE even if I prefer using Gnome? I'd like to think that this can be fixed and one can enjoy the freedom of choice made possible by linx

3) finally, in Gnome Control Center I use power management and I set standby to 10 min, suspend to 60 min and poweroff to 90 min but it doesn't work. I spent far more than 10 min away from my PC and when I got back I realize it didn't use the power management feature...

Thanks in advance... any helpful advice is hihgly appreciate
 
Old 03-27-2005, 06:45 AM   #2
zvonSully
Member
 
Registered: Nov 2004
Location: Romania
Distribution: Debian maniak(apt-get upgrade)
Posts: 85

Rep: Reputation: 15
Return to KDE :{)
 
Old 03-27-2005, 07:02 AM   #3
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I would have thought that "dpkg-reconfigure locales" fixed your locale problem on gnome. Did you uncheck all the other locales when you chose your current locale?

You can change the keyboard layout for console with "dpkg-reconfigure console-data" but I don't think this should affect gnome -- still, no harm in trying it. You might also want to check /etc/environment to see if it looks OK.
 
Old 03-28-2005, 07:11 AM   #4
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Original Poster
Rep: Reputation: 15
Return to KDE?!?

Hi and thanks!
DeadParrot I've tried dpkg-reconfigure locales in many ways: I marked only one option (pt_PT) I've marked all of my interest (pt_PT, pt_PT@Euro, pt_PT ISO-8859-1...) none worked.

I've followed zvonSully suggestion and returned to KDE (in fact I'm posting this within it that's why I could use the @ symbol and the € symbol)

But I'm very disapointed because I couldn't never imagine that the different desktop environments would use so badly what I consider to be a system config. I mean, if I set keyboard and other stuff (as monitor type and resolution, mouse and so on) globally, as system configuration, why don't KDE and Gnome act the same way, since I've understood they are «layers» between the system and the user ?

I believe this is a major bug in Gnome I'm thinking in trying XFCE as I've read it's light yet powerful!
 
Old 03-28-2005, 08:14 AM   #5
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
If you tried the "dpkg-reconfigure console-data" thing I suggested, you should notice that the changes won't take effect until you reboot, because the keymap is loaded during boot-time.
 
Old 03-30-2005, 09:42 AM   #6
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Original Poster
Rep: Reputation: 15
Problem Solved

This is just to say that the problem was solved. I installed once again KDE as I've told you, kdm and what I believe were all the necessary libraries!
Than, I check for the keyboard configuration using KDE and, as usual, it worked correctly!
After that, and because I don't want to use KDE (sorry, it's only a matter of taste ) I removed it but, here is the difference, I picked one by one the packages to remove: kdebase, kdebase-data, kate, kwrite, kpalm... all the ones I tought I didn't need.
The first time I had removed KDE I used
Code:
# apt-get remove libarts2
which removed entirely KDE desktop environment with one single command !!!
This time I left kdm and some other libraries and somehow I think that could had sometihing to do with my keyboard misconfiguration.
The first time I logout and loged back in with gdm all my configuration where kept intact and correctly working!
So here it is my thanks for everyone who helped me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
freerock gnome gdm problems xrado Slackware 3 08-09-2005 03:32 PM
gdm autologin to gnome vampire Janus Fedora 5 10-27-2004 11:13 PM
Gnome Gdm PricessDaisy Linux - General 2 07-27-2004 07:21 AM
no fonts in gnome or gdm Jrmdidit Fedora 23 04-13-2004 01:00 PM
gnome won't start, but gdm does progster Linux - General 5 07-09-2002 03:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration