-   Debian (
-   -   gift, Gnutella....why don't P2P programs ever work for me? (

R00ts 10-31-2004 10:37 PM

gift, Gnutella....why don't P2P programs ever work for me?
Ok, ever since I installed Debian (sarge) in June I've never once been able to get P2P software working (granted I didn't try very hard, until tonight). I worked my ass off trying to get gift (using giftui) working tonight and it just. won't. work! After reading thru their homepage I tried restarting the giftd daemon manually and this was the result:


tyler@localhost:~/.giFT/Gnutella$ killall -TERM giftd
tyler@localhost:~/.giFT/Gnutella$ ps axu | grep gift
tyler    16655  0.0  0.0  3624  572 pts/10  S+  20:40  0:00 grep gift
tyler@localhost:~/.giFT/Gnutella$ giftd -d
[20:40:32] giFT: 16657
tyler@localhost:~/.giFT/Gnutella$ ps axu | grep gift
tyler    16657  1.3  0.2  4516 2356 ?        Ss  20:40  0:00 giftd -d
tyler    16660  0.0  0.0  3624  568 pts/10  R+  20:40  0:00 grep gift
tyler@localhost:~/.giFT/Gnutella$ giftd -V
giftd 0.11.6 (Built Fri May 14 07:05:45 CEST 2004)

Copyright (c) 2001-2003 giFT project (
This is free software; see the source for copying conditions.  There is NO

Compile-time support:
        Ogg Vorbis 1.0
        Dynamic library loading (via ltdl)

Compile-time environment paths:

Available plugins:
        Gnutella 0.0.9
tyler@localhost:~/.giFT/Gnutella$ giftd -v
[20:40:44] giftd 0.11.6 (May 14 2004 07:06:39) started
[20:40:44] *** GIFT-ERROR: bind: Address already in use
[20:40:44] *** GIFT-FATAL: Failed to load interface subsystem

There may be another giFT daemon running on this host.  Check to see if the
interface port (1213) is currently in use by another process.

[20:40:44] *** Often times more information can be found in the log file or with the -v command line switch.

I checked, but it seems like nothing is using port 1213 and there is only one daemon running. Anyways when I startup giftUI it won't list any networks and it says "Connection to localhost:0 failed" and prompts me to enter a host and port number. Shouldn't giftUI automatically bring up the OpenFT and Gnutella networks???

Then I went to try Gnutella-GTK, but it won't connect either! It says in the top right that "Gnutella thinks you're firewalled" but I am SO not firewalled! I tried Apollon as well and that was no good either.

So what's wrong? I have all the most recent packages installed, I ran gift-setup correctly, and I've tried playing around with everything I can think of. Why won't these P2P programs just work out of the box (ie after apt-get install)? Thanks for any help/insight you can provide. :study:

hoe 11-01-2004 05:33 AM

Hi: I use Limewire and have used it in XP, Xandros and Mepis with no problems. I just use the basic download free and it always works and is easy to install. I just extract the downloaded file and type: sh LimeWireLinux.bin in the console after becoming su root.


Lakota 11-01-2004 05:35 AM

I could not manage to get the p2p appz you mentioned connected on my box either. What I have had easy success with is Limewire. There is a Linux download on Limewire's website.

McCloud 11-01-2004 05:49 AM

I always use eDonkey. Give it a try, it's a nice program.

You can find eDonkey here.

There actually are Debian packages of the "command line client" and the GUI.

Good luck.

drawhla 11-01-2004 06:52 AM

I use amule (edondeky-emule client), Bittornado (bittorrent), Nicotine (soulseek) and gtk-gnutella
I got them all with apt-get install and they all work perfectly

I never managed to get the gift stuff going (apollong, guiftui, gifttoxic, etc), never got the plugins to work

imroy 11-01-2004 12:14 PM

Firstly, you shouldn't need to start giftd manually. If you want to check what it's doing, look in the log file. I have mine going to ~/.giFT/giftd.log but I can't remember if that's the default. Look in ~/.giFT/giftd.conf to see where it's logging info.

Secondly, how did you check if something wasn't already using that port? I'd use fuser like this:
fuser -n tcp -v 1213

Lastly, are you sure you have giFTui configured properly? Is it looking to connect to localhost on port 1213? The error message says "localhost:0" which looks like it's trying to connect to port 0, not 1213.

gorzuate 11-01-2004 05:48 PM

When I run gtk-gnutella it also thinks I'm firewalled (when I'm not), but I can still connect and download stuff, so that's not the problem. As for what it is....yeah who knows.

R00ts 11-01-2004 08:16 PM


Originally posted by imroy
Lastly, are you sure you have giFTui configured properly? Is it looking to connect to localhost on port 1213? The error message says "localhost:0" which looks like it's trying to connect to port 0, not 1213.
Thanks! That did it! (Now why didn't I think of that? :o). I can see OpenFT and Gnutella on giftui now, but it just sits there and it shows no users. When I open Apollon it says "Connecting..." and its been "connecting" for over 10 minutes now. :rolleyes: So now I think I need to go play around with the plugins

Oh and by the way, thanks for the suggestions of other P2P clients everyone, but I really want to get gift to work. I've heard good things about Limewire, but I am distrusty of any piece of software that "encourages" you to buy a premium version. That usually means a ton of annoying advertisements and such (if not now, then later).

R00ts 11-02-2004 01:11 AM

For those trying to get their gift plugins to work, I just got the OpenFT one working. What you have to do is navigate to ~/.giFT/OpenFT and remove the 'nodes' file. This forces a new, updated nodes list to be downloaded from the network which will allow you to connect. I haven't figured out how to get Gnutella working yet though. If I figure it out I will post again.

initialdrifteg6 11-03-2004 02:13 PM

apt-get install amule

nuff' said

THFdaemon 08-19-2006 03:25 AM

hey nodes
Great tip about the nodes.

All times are GMT -5. The time now is 10:37 PM.