LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Debian (http://www.linuxquestions.org/questions/forumdisplay.php?f=26)
-   -   Getting errors when installing fglrx driver (http://www.linuxquestions.org/questions/showthread.php?t=172911)

Duukkis 04-21-2004 11:41 AM

Getting errors when installing fglrx driver
 
I have followed the advices from this site: http://xoomer.virgilio.it/flavio.sta...installer.html
When I have executed "fakeroot debian/rules binary" in the fglrx directory, which is made by it's installer, I some errors. First it downloads the package succesfully, but then I get this:

dh_testdir
rpm2cpio fglrx-4.3.0-3.7.6.i386.rpm | cpio -i -d --no-preserve-owner
/bin/sh: line 1: rpm2cpio: command not found
cpio: premature end of archive
make: *** [build-stamp] Error 1

I have also tried to install prebuilt packages but it don't work either.

I need help :)

sylvain_gnu 04-21-2004 02:57 PM

Missing tool needed for this installation
 
Hi,

it seems to me that when attempting to perform this command:
rpm2cpio fglrx-4.3.0-3.7.6.i386.rpm | cpio -i -d --no-preserve-owner
the installation script cannot find 'rpm2cpio' which is supposed to do the job!

So you could try as root:
apt-get install rpm2cpio
or first
apt-cache search rpm2cpio
to find the debian package name for 'rpm2cpio' and then
apt-get install whateverthepackagenameis

Good luck.
Sylvain.

sylvain_gnu 04-21-2004 03:04 PM

Can you find out about 'rpm2cpio' ?
 
Well, on my Debian sid, I get this:

# apt-cache search rpm
debaux - Debian Auxiliary Programs
epm - Cross-platform package builder by Easy Software Products
extract - Display meta-data from files of an arbitrary type.
kdeadmin-kfile-plugins - KDE File dialog plugins for deb and rpm files
kpackage - KDE Software package tool
lg-issue19 - Issue 19 of the Linux Gazette.
lg-issue68 - Issue 68 of the Linux Gazette.
librpm-dev - RPM shared library, development kit
librpm4 - RPM shared library
lsb-rpm - Red Hat package manager for LSB package building
rpm - Red Hat package manager
rpm2html - Generate HTML index from directories of RPMs
xfe - lightweight file manager for X11
gmc - Midnight Commander - A powerful file manager. - Gnome version
# apt-cache search rpm2cpio
#

Conclusion: I cannot find a package called 'rpm2cpio' in Sid.
And you can you find it in Sarge?

Maybe it is just a command that will be available if you install one of the following packages:
librpm-dev - RPM shared library, development kit
librpm4 - RPM shared library
lsb-rpm - Red Hat package manager for LSB package building
rpm

1) You could try
apt-get install rpm
then try again the installation that lead you to submit your question.

2) If it doesn't work, try google to find out about this tool 'rpm2cpio' that seems to be needed for your installation.

Good luck.

Sylvain.

Duukkis 04-22-2004 03:31 AM

Thanks very much. I have succesfully installed the fglrx driver from prebuild packages but I will try to download "rpm".

dpinte 05-15-2004 01:18 AM

installin rpm solve the problem
 
Hi,

I add exactly the same problem on my Debian/Sid system.

Installing the rpm package solved the problem.

Didrik

xanas3712 05-15-2004 08:49 PM

I'm having a problem with the driver in 2 areas, but I do have it "working"
1) It won't run both my monitors properly in dual head mode
2) 3d acceleration is faster in windows (I get higher FPS in UT2k4)

But, all I did is use a package conversion tool called alien. I typed
alien radeondriver.rpm and it converted it to deb
Then I used dpkg -i radeondriver.deb
Then I went to the /lib/modules/fglrx/build_mod directory and typed sh make.sh
Then cd ..
Then sh make_install.sh
and it worked for me


All times are GMT -5. The time now is 06:26 AM.