LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-08-2009, 01:08 PM   #1
gardar
LQ Newbie
 
Registered: Apr 2005
Location: Reykjavik, Iceland
Distribution: ArchLinux, Debian, CentOs, RHEL, Ubuntu
Posts: 22

Rep: Reputation: 3
Getting "/bin/sh can't access tty job control turned off" after adding a new HDD


I am setting up a small fileserver at home.
It worked just fine until I added a second HDD to it. Then I keep receiving this message:

Code:
/bin/sh can't access tty job control turned off (initramfs)
When I plug out the hdd, then I'm able to fully boot up.

I have googled this problem but the only thing I found out were posts about this error in ubuntu livecd, tried the solutions given there but they didn't help.

Any ideas what I can do?

Oh and btw, the hdd that's running debian is a sata disk but the one I'm adding is IDE, if that changes anything.
 
Old 02-08-2009, 01:49 PM   #2
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Most boxes boot from ide first, so I'm surprised you saw any boot progress.
Do you have the sata as ide in the bios?
How far does the boot go? At what point do you see the message?
What is the disk layout seen from the livecd? Linux / on sda1? Ide disk as hda1,2,...?
You could use the livecd to set the /boot/grub/device.map to:
(hd0) /dev/hda
(hd1) /dev/sda
if that is what you have.
Then correct /boot/grub/menu.lst hd0,0 et.al. entries and reinstall grub still from the livecd to hda as in:
grub-install --recheck --no-floppy --root-directory=/media/sda1 /dev/hda
Make sure to correct all above entries to what you actually have.
If not sure, post "fdisk -l" with both disks plugged in, device.map and menu.lst.

Last edited by makuyl; 02-08-2009 at 01:52 PM.
 
Old 02-09-2009, 06:03 AM   #3
gardar
LQ Newbie
 
Registered: Apr 2005
Location: Reykjavik, Iceland
Distribution: ArchLinux, Debian, CentOs, RHEL, Ubuntu
Posts: 22

Original Poster
Rep: Reputation: 3
I just reinstalled debian yesterday, with one sata and one ide disk plugged in, installed on the sata disk again.
It worked fine for a few boots but then gave the same message again.

I have 2 sata disks and one ide.

This is my fstab

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sdb1       /               ext3    defaults,errors=remount-ro 0       1
/dev/sdb9       /home           ext3    defaults        0       2
/dev/sdb8       /tmp            ext3    defaults        0       2
/dev/sdb5       /usr            ext3    defaults        0       2
/dev/sdb6       /var            ext3    defaults        0       2
/dev/sdb7       none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/sda1       /media/melman1  ext3    defaults        0       2
/dev/sdc1       /media/melman2  ext3    defaults        0       2
The sata disk that I boot from is /dev/sdb
The ide disk is /dev/sda1 and the other sata is /dev/sdc1

This is from my menu.lst

Code:
title           Debian GNU/Linux, kernel 2.6.18-6-686
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.18-6-686 root=/dev/sdb1 ro
initrd          /boot/initrd.img-2.6.18-6-686
savedefault

title           Debian GNU/Linux, kernel 2.6.18-6-686 (single-user mode)
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.18-6-686 root=/dev/sdb1 ro single
initrd          /boot/initrd.img-2.6.18-6-686
savedefault
I had to change from hd1,0 to 0,0 manually.

This is my device.map
Code:
hd0)   /dev/sda
(hd1)   /dev/sdb
Are all those entries correct?
 
Old 02-09-2009, 10:07 AM   #4
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
If your "root=/dev/sdb1" is correct, then the "root (hd0,0)" should be (hd1,0) in menu.lst:
Code:
title           Debian GNU/Linux, kernel 2.6.18-6-686
root            (hd1,0)
kernel          /boot/vmlinuz-2.6.18-6-686 root=/dev/sdb1 ro
initrd          /boot/initrd.img-2.6.18-6-686
savedefault
(hd0,0) is sda1, and (hd1,0) is sdb1, (hd2,1) would be sdc2 and so on, count begins from 0.
 
Old 08-13-2009, 03:29 PM   #5
gardar
LQ Newbie
 
Registered: Apr 2005
Location: Reykjavik, Iceland
Distribution: ArchLinux, Debian, CentOs, RHEL, Ubuntu
Posts: 22

Original Poster
Rep: Reputation: 3
Surprisingly I had this problem just from time to time, if it happened then I just rebooted and the problem was gone. Seems to have been pretty random.

Until few days ago I added another hdd and now I can't get past this error.

I even had a fresh install of debian with just bare system and nfs+ssh.
It installed fine but then I went and mounted all the disks, they mounted ok and I thought the problem was fixed, but then I rebooted and now I can't get past this error!

Code:
Decompressing Linux... Parsing ELF... done.
Booting the kernel
Loading, please wait...
mount: mounting /dev on /root/dev failed: No Such file or directory
mount: mounting /sys on /root/sys failed: No Such file or directory
mount: mounting /proc on /root/proc failed: No Such file or directory
Target filesystem doesn't have /sbin/init.
No init found. Try passing init= bootarg

Busybox v1.10.2 (Debian 1:1.10.2-2) Built-in shell (ash)
Enter 'help' for a list of built in commands.

/bin/sh: can't access tty; job control turned off
(initramfs)
I have debian on a sata disk. I have 2 IDE disks and 3 sata disks.
Both of the ide's plug straight into the motherboard and one of the satas, the sata that has debian on it also plugs straight into the motherboard and the other satas plug into a pci sata card.


Any ideas what could be causing this?
 
Old 08-14-2009, 05:32 AM   #6
gardar
LQ Newbie
 
Registered: Apr 2005
Location: Reykjavik, Iceland
Distribution: ArchLinux, Debian, CentOs, RHEL, Ubuntu
Posts: 22

Original Poster
Rep: Reputation: 3
Setting UUID's in my fstab and grub config file solved the problem!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/bin/sh: can't access tty; job control turned off retiem Ubuntu 55 07-23-2011 10:15 AM
(/bin/sh: can't access tty; job control turned off) Problem booting encrypted /root trapix22 Debian 0 10-25-2008 08:27 AM
sh: can't access tty; job control turned off. shadowsa SUSE / openSUSE 2 11-21-2005 11:13 AM
can't access tty; job control turned off johnnybezak Linux - General 4 02-21-2004 10:49 PM
sh: can't access tty, job control turned off tgardner Linux - Software 1 06-07-2003 12:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 03:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration