-   Debian (
-   -   Get a black screen when logoff in Debian Etch..same problem with Ctrl+alt+f1 (

rzs 09-04-2007 03:43 AM

Get a black screen when logoff in Debian Etch..same problem with Ctrl+alt+f1

I recently installed Debian Etch as a dual boot on my laptop . I am having an issue with logging off . Also ctrl+alt+f1 does not bring me to the shell . All I get is a black screen in both the cases and i have to manually shutdown my laptop and reboot.
I am however able to shutdown and restart from within gnome.I am new to linux so cant figure out whats wrong. I tried to find out what onboard video card im using from within windows by right clicking on the
desktop then going to :
display properties->settings->advanced->adapter and there it says :
VIA Chrome9 HC IGP.
I have already tried the following troubleshooting steps but it didnt work :

Already tried steps :

1) Tried ctrl+alt+f5 , ctrl+alt+f7 ,ctrl+alt+backspace but get the same black screen and have to manually shutdown and reboot.

2) Added vga=771 at the end of the kernel line in /boot/grub/menu.lst . Also tried vga=773,vga=791

3) Ran the command :

su cat /etc/X11/xorg.conf | grep "Driver"
to get information on driver and the output of the above command is :


Driver    "kbd"
Driver    "mouse"
Driver    "vesa"

What could be going wrong ?
Please help.

Thanks :)

farslayer 09-04-2007 10:35 AM

First thing I would try is to edit xorg.conf and change "vesa" to "via"

by default I believe the via driver is automatically installed in etch..


aptitude search video-via
i A xserver-xorg-video-via          - X.Org X server -- VIA display driver

the actual driver project is here, in case you should need more info on the driver for some reason...

rzs 09-04-2007 01:17 PM

Hello farslayer,

Thanks for the reply . I ran the command

aptitude search video-via
and the output was

i A xserver-xorg-video-via          - X.Org X server -- VIA display driver
I also changed the "vesa" to "via" in xorg.conf. But then when i rebooted my system i got the following error :


Failed to start the X Server (your Graphical User Interface) . It is likely that it is not set up correctly . Would you like to view the X server output to diagnose the problem ?

I viewed the log file Xorg.0.log which is located at /var/log . At the end there was a line that said "No devices detected.Fatal server error:no screens found".
I was then taken to the shell where i changed "via" back to "vesa" in xorg.conf and was able to get to my desktop. But,the problem still persists.

farslayer 09-04-2007 02:40 PM

So, it looks like the drivers included in Etch do not support your Via graphics chip set.. Ubuntu has a nice guide of how to download and install the latest openchrome drivers in Ubuntu. Should be pretty much the same in Debian, just no sudo..

OH found a how-to on the openchrome site for Debian Etch

Rollo69 09-05-2007 08:48 PM

VIA Chrome IGP
I'm not sure if this will or won't help but I searched about the VIA Chrome drivers for video and found this link VIA Arena. Hope this will help you. I'm still in the process of getting my new MSI mobo w/ VIA chipset up and running like I want.

All times are GMT -5. The time now is 05:05 AM.