LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Fuse / Modprobe Help (https://www.linuxquestions.org/questions/debian-26/fuse-modprobe-help-462752/)

Jude Lucien 07-10-2006 06:43 PM

Fuse / Modprobe Help
 
I am trying to mount via fuse a music directory on another box on which I have an account:

mydebian:/home/me# sshfs myname@10.x.x.xx:/music /mnt/music
Password:
modprobe: Can't locate module fuse
fusermount: fuse device not found, try 'modprobe fuse' first
mydebian:/home/me# modprobe fuse
modprobe: Can't locate module fuse

Seeing as I am an apt-get kind of gal, I have no idea about using modprobe. It seems I am missing the fuse module - where would it be? I installed fuse without errors. I have logged out and back in. Can anyone point me in the right direction so I can get this directory mounted? I'm running Sarge with a 2.4.27-2-386 kernel.

Cheers,
Jude

HappyTux 07-10-2006 07:57 PM

Quote:

Originally Posted by Jude Lucien
I am trying to mount via fuse a music directory on another box on which I have an account:

mydebian:/home/me# sshfs myname@10.x.x.xx:/music /mnt/music
Password:
modprobe: Can't locate module fuse
fusermount: fuse device not found, try 'modprobe fuse' first
mydebian:/home/me# modprobe fuse
modprobe: Can't locate module fuse

Seeing as I am an apt-get kind of gal, I have no idea about using modprobe. It seems I am missing the fuse module - where would it be? I installed fuse without errors. I have logged out and back in. Can anyone point me in the right direction so I can get this directory mounted? I'm running Sarge with a 2.4.27-2-386 kernel.

Cheers,
Jude

Check in your kernel config and see if is set with a command similar to this.

Code:

grep -i fuse /boot/config-2.6.17-ck1
# CONFIG_FUSE_FS is not set

Of course changing the -2.??? part to your kernel if it is not present then you either have to install a Debian kernel with it enabled as a module (CONFIG_FUSE_FS=m) or built into (CONFIG_FUSE_FS=y) or build your own kernel with it enabled.

Jude Lucien 07-11-2006 12:42 PM

When I run that command I get no response - does that mean the module does not exist?

I installed all of the fuse packages via apt - surely that should be enough or do I need to recompile my kernel anyway?

Cheers,
Jude

HappyTux 07-11-2006 01:05 PM

Quote:

Originally Posted by Jude Lucien
When I run that command I get no response - does that mean the module does not exist?

I installed all of the fuse packages via apt - surely that should be enough or do I need to recompile my kernel anyway?

Cheers,
Jude

Looks like it is not in that version of the kernel then. I just did a quick search according to this page you should be able to build the module for that kernel. You will probably need to install the kernel-headers package that matches your running kernel.

nx5000 07-11-2006 01:06 PM

Yes FUSE is not active by default.

Recompile the kernel...

edit:
humm no result?
strange :)

WHich command?

Overlooked, you have kernel 2.4
No idea how fuse was supported, seems not in the kernel

Sorry

theNbomr 07-11-2006 01:15 PM

I have built and used the fuse module (assuming you are referring to 'Filesystem in USErspace') with a 2.4 kernel. There are some odd requirements about building the module, though. I seem to recall that it had to be built with the same compiler that built the kernel. I do know that whatever requirement it was that the documentation specified, it really was true, and the symptom was highly unusual. It worked just fine for me as a loadable module, once built correctly.

--- rod.

Jude Lucien 07-11-2006 03:30 PM

theNbomr,

can you tell me where you got the instructions to build and load fuse?

Cheers.

theNbomr 07-11-2006 04:44 PM

I downloaded it from sourceforge.net, and the instructions for building it were in the distribution package. There is also information about it in the package homepage.
--- rod.


All times are GMT -5. The time now is 03:37 AM.