-   Debian (
-   -   Flash player In iceweacel, i can only play youtube videos but i can't in other webs (

dbd10 06-13-2012 06:31 PM

Flash player In iceweacel, i can only play youtube videos but i can't in other webs
Hello everybody,
as the subject says i can only play youtube videos in iceweasel but i can't play videos in other webs.

I installed flashplayer-mozilla of debian-multimedia repository and after i deleted it i tried to install flashplugin-nonfree and in both cases i can only see youtbe videos, then i deleted flashplugin-nonfree and i downloaded the install tar.gz file of adobe's web. For installing the tar.gz first i copied the in home/myuser/.mozilla/plugins and neither i watch videos in youtube, to watch them i create a symbolinc link in /usr/lib/mozilla/plugins and in /usr/lib/iceweasel/plugins and in this way i can watch youtbe's videos but of course i can't watch videos in other webs.

Please, could you help me to watch any video in any web?, What am i doing wrong?


NOTE: i'm spanish so sorry for my english.

craigevil 06-13-2012 06:56 PM

Remove any and all traces and remove any symlinks you manually created.

All that did was mess things up.

Use one of the following:
apt-get install flashplugin-nonfree or
apt-get install flashplayer-mozilla

Also check about:plugins and see what plugin is being used. I am guessing you have Gnash installed. As root try doing:

update-alternatives --set
You should also update your browser to either the version in backports or from the repo.

Is your video card a nvidia card? There are known issues with nvidia cards.

Right click on a flash video and turn off hardware acceleration.

if none of the above work try searching Google or the debian forums at:

Do not manually move, create, delete any files or packages.

dbd10 06-13-2012 07:53 PM

Thank you for your answer.

i have removed all and i have installed flashplayer-mozilla.
In about:plugins i have got that the plugin in use is, when i do:


sudo update-alternatives --set
Is shown:


update-alternatives: --set needs <name> <route>
Also when i write:


sudo dpkg -l | grep gnash
don't show me anything.

The browser is in the last version 13.0, now i can't watch youtube videos. I have got a nvidia video card and i can't do right click because where the video is i see a black square and i can't do nothing.

I have searched in google but i don't find nothing


craigevil 06-13-2012 08:23 PM

Debian User Forums • View topic - flash fails in iceweasel and chromium :

dbd10 06-13-2012 09:40 PM

I was reading the debian forum and i had gotten that it works but suddenly it stops working.

I continue the search.


craigevil 06-13-2012 10:57 PM

Just my opinion, but I believe it is a bug with the nvidia drivers.

If you read the thread, I tried every method of installing and I had no issues with Flash in any browser. There is/was a problem on Ubuntu with the newest version of Flash.

Only other threads I know of are at the SolusOS forum:
SolusOS - View topic - Flash crashes constantly in all browsers... :

SolusOS - View topic - [Fixed]Flashplayer weird colours :

dbd10 06-14-2012 11:25 AM

Finally I solved the problem installing flashplayer 10.2, with gnash i could play youtube videos but i couldn't in other webs, with flashplayer10.2 everything works well.

jim_p 06-15-2012 12:16 AM

I think that the first think one should do when troubleshooting flash is to ensure that he/she is not using some opensource alternative like gnash or swfdec, because, as it seems, the only thing they are capable of is to play youtube videos.

All times are GMT -5. The time now is 12:51 PM.