LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-20-2008, 09:30 AM   #1
Orangutanklaus
Member
 
Registered: May 2006
Posts: 93

Rep: Reputation: 15
Question ffmpegthumbnailer - ./configure fails


Aloha!

I want to add an extra thumbnail feature to mediatomb for my PS3 but it requires ffmpegthumbnailer. Well, I thought I've installed all necessary requirements for ffmpegthumbnailer but when I start the configure-script it stops with the message:

...
checking jpeglib.h usability... yes
checking jpeglib.h presence... yes
checking for jpeglib.h... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for FFMPEG... no
configure: error: +Could not find ffmpeg. Please update PKG_CONFIG_PATH to point at location of ffmpeg pkgconfig files directory.


ffmpeg ist installed so what does this message mean?

I've add the configure.log here.
System: Debian Etch 2.6.26

Thanks in advance
OK
 
Old 09-20-2008, 09:57 AM   #2
johnson_steve
Senior Member
 
Registered: Apr 2005
Location: BrewCity, USA (Milwaukee, WI)
Distribution: Xubuntu 9.10, Gentoo 2.6.27 (AMD64), Darwin 9.0.0 (arm)
Posts: 1,152

Rep: Reputation: 46
Quote:
Originally Posted by Orangutanklaus View Post
ffmpeg ist installed so what does this message mean?
OK
That ffmpeg isn't installed.

your going to need it. install ffmpeg first then try again.
 
Old 09-20-2008, 11:17 AM   #3
Orangutanklaus
Member
 
Registered: May 2006
Posts: 93

Original Poster
Rep: Reputation: 15
It looks like ffmpeg, it's listed as ffmpeg and it works like ffmpeg. What could it be? Sorry, but when I wrote it's installed, then I don't expect an answer like yours.

No harm meant!
OK
 
Old 09-20-2008, 11:28 AM   #4
johnson_steve
Senior Member
 
Registered: Apr 2005
Location: BrewCity, USA (Milwaukee, WI)
Distribution: Xubuntu 9.10, Gentoo 2.6.27 (AMD64), Darwin 9.0.0 (arm)
Posts: 1,152

Rep: Reputation: 46
ffmpeg is installed?
perhaps configure just can't find it. post the output of 'which ffmpeg'
 
Old 11-17-2008, 03:58 PM   #5
eniot
LQ Newbie
 
Registered: Nov 2008
Posts: 1

Rep: Reputation: 0
Exclamation

Hi,

I have the same error and my ffmpeg is already installed !!

Someonelse have solution ???
 
Old 11-18-2008, 11:38 AM   #6
Orangutanklaus
Member
 
Registered: May 2006
Posts: 93

Original Poster
Rep: Reputation: 15
Hi eniot.

I'm answering here because (WTF) I can't find the private message menu to reply to you. (rofl)

No, I didn't resolve this problem yet.

Regards
OK
 
Old 11-18-2008, 12:19 PM   #7
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
You have to install the development ffmpeg files (headers and libraries). In Debian these are splitted in 4 different packages: libavutil-dev, libavcodec-dev, libswscale-dev and libavformat-dev. You can see these requirements also in the config.log:
Code:
configure:16027: $? = 1
No package 'libavutil' found
No package 'libavformat' found
No package 'libavcodec' found
No package 'libswscale' found
configure:16054: result: no
configure:16056: error:  +Could not find ffmpeg. Please update
PKG_CONFIG_PATH to point at location of ffmpeg pkgconfig files directory.
 
Old 11-18-2008, 04:35 PM   #8
Orangutanklaus
Member
 
Registered: May 2006
Posts: 93

Original Poster
Rep: Reputation: 15
Question

Thanks for your help. I've added the missing packages but now it seems that ffmpegthumbnailer requires older versions of these packages than installed. (???)

PHP Code:
configure:16001checking for FFMPEG
configure
:16008$PKG_CONFIG --exists --print-errors "libavutil libavformat libavcodec libswscale"
Package 'libswscale' requires 'libavutil = 49.4.0' but version of libavutil is 49.10.0
configure
:16011: $? = 1
configure
:16024$PKG_CONFIG --exists --print-errors "libavutil libavformat libavcodec libswscale"
Package 'libswscale' requires 'libavutil = 49.4.0' but version of libavutil is 49.10.0
configure
:16027: $? = 1
Package 
'libswscale' requires 'libavutil = 49.4.0' but version of libavutil is 49.10.0
configure
:16054resultno
configure
:16056error:  +Could not find ffmpegPlease update PKG_CONFIG_PATH to point at location of ffmpeg pkgconfig files directory
Regards
OK
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xgl -configure fails shn_ Linux - Desktop 2 01-16-2007 09:06 AM
OpenOffice Configure Fails jroggow Linux - Desktop 2 11-07-2006 08:49 AM
./configure fails with: libz... configure: error: not found. erpe Linux - Software 17 10-11-2006 05:56 PM
./configure for openLDAP fails..... rayj00 Linux - Software 2 10-01-2006 04:11 PM
ardour wont configure: configure: error: C preprocessor "/lib/cpp" fails sanity check disciple061 Linux - Software 4 01-22-2005 12:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration