-   Debian (
-   -   Fails to boot - rcS /dev/tty1: No such file or directory (

Spearhawk 03-28-2007 10:53 AM

Fails to boot - rcS /dev/tty1: No such file or directory
Me and a friend are trying to install debian on a flash disk which will then be used on a pc104 where it appears as a normal hard drive (since the flash reader is connected on the ide buss). We're using debootstrap to install the os to a dir on our main computer and then chroots into it to install kernel and such and finally we copies it to the flashcard and writes boot loader (grub). In order to make it easier to reproduce we have written scripts to handle it all:, in scripts. - installs the os in a subdir
make_striped_OS_flash - copies the os to the flash disk, it's also supposed to strip the os to bare minimum of what we need but we haven't got that far yet.

We managed to get it start booting on the pc104 but after a while we get:
/etc/init.d/rcS: line 199: /dev/tty1: No such file or directory


INIT: Entering runlevel: 2
INIT: Id "1" respawning too fast: disabled for 5 minutes
INIT: Id "2" respawning too fast: disabled for 5 minutes

We tried modifying /etc/inittab in various ways:

We tried using
1:2345:respawn:/sbin/getty -L 38400 tty1
or (after installing mingetty)
1:2345:respawn:/sbin/mingetty 38400 tty1
instead of
1:2345:respawn:/sbin/getty 38400 tty1

We tried to comment out all of those rows, tried leaving just the first, etc.
We tried changing the run level to 1 and then it seems to boot fine, we get stuck on "Press enter to do maintenance" since we don't have any input options on the pc104 (someone managed to lose the input dongle). But even if it booted fine it wouldn't be an option, we need run level 2 (for obvious reasons).

Anyone that has any suggestions on what might be wrong?

Thanks in advance
Leon Ljunggren

Spearhawk 03-29-2007 09:05 AM

We managed to get it booting. :)
What we had to do was first create the nodes while chrooted into the os on our main computer using mknod tty1 c 4 1 (etc) and then use 1:2345:respawn:/sbin/getty -L 38400 tty1 (etc) in inittab.

All times are GMT -5. The time now is 10:25 AM.