-   Debian (
-   -   Failed systemd install ruined my boot, trying to restore sysvinit (

the dsc 11-20-2012 01:54 AM

Failed systemd install ruined my boot, trying to restore sysvinit
Just as I'm about to call it the day and go to sleep I wonder if trying to replace KDM for slim is part of the problem. But that's probably unlikely.

As I installed systemd, replacing sysv, as it's supposed to, the PC wasn't able to reboot by "shutdown -r now" - I guess it has something to do with the uninstalling of sysv. I tried "halt" but contrarily to my expectations, apparently it just makes the PC literally halt rather than shut down. I've then shut down by holding the power button (just pressing it once wasn't triggering a proper shutdown either). After that I've not been able to boot on my Debian Wheezy install properly, it always end up not running the init scripts properly with the message:

"/etc/init.d/[whatever] can't open /lib/lsb/init-functions"

"whatever" being things like "mountall", "urandom", "procps", dozens of things, actually these are the bulk of the boot messages, more things not working than working. I think that the only thing that gets done is mounting the drives but maybe not even that.

I've tried chrooting into it through an live AntiX CD, trying to reinstall sysv, switch for upstart, systemd again, and then sysv again, none of these attemps worked, the boot is always unfinished on that "control D or password for maintenance" point.

In this last attempt for some reason apt/dpkg eventually got locked and I can't use it anymore (aptitude says something along the lines of a file on /var/aptitude/lock not existing or something, and then it only "dry runs").

I've googled a little bit for such terms but I haven't find any situation that's similar enough so far. Part of the reason why I tried it to begin with, I've found a couple of people saying that they installed systemd on Debian with no problem, so I thought it couldn't get into much trouble, at most something that would be easily reversible. What a fool I am.

So, anyone thinks there's something relatively simple I could be missing, before I go on and reinstall the whole OS?


unSpawn 11-20-2012 08:10 AM


Originally Posted by the dsc (Post 4833042)
(..)I wonder if trying to replace KDM for slim is part of the problem.

A DM comes in way later in the boot process as far as I know.


Originally Posted by the dsc (Post 4833042)
(..) the PC wasn't able to reboot by "shutdown -r now"

Systemd works with .target files so unless 'shutdown -r' already was linked to that's not going to work. I wonder why you installed it anyway (and chose a brute force approach to "fixing" things instead of understanding what's going on) because working through the Known Issues and Workarounds and reported bugs shows some reasons why Wheezy doesn't come with Systemd as default init. Before re-installing your OS contemplate dropping the brute force approach and see for troubleshooting lock file problems and and explnanation of what to do.

the dsc 11-20-2012 11:00 PM

Thanks, UnSpawn, but it I ran out of ideas for possible solutions and decided to reinstall the OS, which has collateral benefits anyway.

I just installed out of curiosity, I had tried it once sometime ago, without such harsh consequences, and as I've stumbled on the subject recently when googling for "slow grub", I decided to give it a try again (depite of being unrelated to grub itself), perhaps things had changed since then as I've found a few people talking about how it worked for them. But I should have trusted my "spider sense" tingling rather than being too optimistic.

I never thought of installing/reinstalling packages as a "brute force" way to fix things (if that's what you mean), I thought it would be actually safer than trying to understand but fail to do so and complicate things with nonstandard modifications. But the safest way to go anyway is simply to not try to change what's actually working pretty well when you're not 100% sure you know how to fix it if anything does not run as expected. Lesson learnt. =/

Should I mark this thread as "solved" even though it's somewhat misleading for someone who might find it when searching for related issues? And do you know if it was temporarily deleted and restored by my request, or was it some sort of glitch that it disappeared for a while (even though I could find it on the forum search engine)?

All times are GMT -5. The time now is 11:56 AM.