LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-24-2007, 07:00 PM   #1
arobinson74
Member
 
Registered: Nov 2002
Location: Lone Tree, CO
Distribution: Xubuntu Gutsy
Posts: 174

Rep: Reputation: 30
Exim4 + Spamassassin + clamav not working


I have tried just about everything I can think of, but I can't get exim4 on debian etch to work with spamassassin and clamav.

I have tried the following resources:
http://koivi.com/exim4-config/
http://www.debian-administration.org/articles/141
http://www.exim.org/eximwiki/Exiscan...88ff2ef91387e1

I have found a similar thread here with no replies:
http://www.linuxquestions.org/questi...d.php?t=270566

I have made sure that I am running exim4-daemon-heavy.
I am running in exim4 split configuration.

I tried with mailscanner and sa-exim, but even those didn't help (sa-exim partially, but not fully)

What I have done:
I executed a dpkg-reconfigure exim4-config.conf and setup my localdomains and relay domains and the other settings.

Then I have installed clamav (with clamav-base, clamav-daemon, clamav-freshclam and clamav-testfiles) and spamassassin.

I then enabled spamassassin in /etc/default/spamassassin
I also enabled clamd in /etc/default/clamav
I added clamav user to the "Debian-exim" group
I set the av_scanner in 02_exim4-config_options to "av_scanner = clamd:/var/run/clamav/clamd.ctl"
I double checked that "/var/run/clamav/clamd.ctl" exists
I uncommented the spamd_address in 02_exim4-config_options
I uncommented the lines in "acl/40_exim4-config_check_data" so that the have:
Code:
  deny
    malware = *
    message = This message was detected as possible malware ($malware_name).

  warn
    spam = Debian-exim:true
    message = X-Spam_score: $spam_score\n\
              X-Spam_score_int: $spam_score_int\n\
              X-Spam_bar: $spam_bar\n\
              X-Spam_report: $spam_report
    spam = nobody:true
I added:
Code:
  warn
    message = Subject: *SPAM* $h_Subject:
    spam = nobody
Then I updated the configuration as root "update-exim4.conf". I looked over "/var/lib/exim4/config.autogenerated" and ensured that my settings looked right from what I knew.

Then I tried to send email to myself (root->arobinson):
Code:
mutt -a clam.exe -s "test clam" arobinson
Which clam.exe has a test virus in it.

Always arobinson got the email fine and no hint that spamassassin or clamav had run. Nowhere in the logs for either did it show that they had been called.

When I installed sa-exim, and enabled it I did get a spam score in the mail headers, but it skipped clam scanning then too. It never did reject the email, even when I tried to add the "demime = exe:com:vbs:batif:scr" type of functionality to block EXE files altogether.

I am tearing my hair out. Anyone know what is going on? Could it be that I am sending local mail and that is causing spam & clam to be skipped? (BTW - I am sending local email because this server is not on the net yet and therefore cannot receive external emails).

Any help is appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sendmail+clamav+mimedefang+spamassassin ssilayaraja Linux - Security 1 01-05-2007 06:39 AM
slackware: sendmail, clamAV, MIMEDefang, spamassassin aubrey-calm2 Linux - Newbie 4 03-09-2006 11:44 PM
Mailscanner With Spamassassin + Clamav On The Same Server treedstang Linux - Enterprise 3 02-09-2006 10:53 PM
Exim4 / Clamav & Debian williew Linux - Software 0 12-26-2004 04:11 PM
Exim4/ sa-exim/Spamassassin - Flags as Spam but Still Accepts jonwatson Linux - Software 4 11-29-2004 06:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration