LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-24-2009, 05:37 PM   #1
grzeslaw
Member
 
Registered: Nov 2008
Posts: 95

Rep: Reputation: 24
exim4 +clamav not working


Hello

I've just installed the exim4 package, with the tls/ssl support on my fresh 64bit install of debian lenny. I used split config file, but not this which was generated, but: /usr/share/doc/exim4-base/examples/example.conf.gz

I installed the following packages:
Code:
ii  clamav                              0.94.dfsg.2-1          anti-virus utility for Unix - command-line i
ii  clamav-base                         0.94.dfsg.2-1          anti-virus utility for Unix - base package
ii  clamav-daemon                       0.94.dfsg.2-1          anti-virus utility for Unix - scanner daemon
ii  clamav-data                         20090123.125900.8897   clamav data files
ii  clamav-testfiles                    0.94.dfsg.2-1          anti-virus utility for Unix - test files
ii  exim4-base                          4.69-9                 support files for all Exim MTA (v4) packages
ii  exim4-config                        4.69-9                 configuration for the Exim MTA (v4)
ii  exim4-daemon-heavy                  4.69-9                 Exim MTA (v4) daemon with extended features,
ii  libclamav5                          0.94.dfsg.2-1          anti-virus utility for Unix - library
My exim with tls support works nice without any problems. But in next step I try to relate exim4 to use the clamav to scan messages.

I uncomment the following options in the config file:
Code:
av_scanner = clamd:/var/run/clamav/clamd.ctl
acl_check_data:
   deny    malware    = *
           message    = This message contains a virus ($malware_name).
  accept
And potentially it should work, but in exim/mail.log there is no info about the clamav scanning.




All deamons listen at ports:
Code:
tcp        0      0 0.0.0.0:587             0.0.0.0:*               LISTEN      3334/exim4      
tcp        0      0 127.0.0.1:783           0.0.0.0:*               LISTEN      2595/spamd.pid

The clamd works fine when I scan any directory, and after restarts of system/services i get the following logs for clamd:
Code:
Wed Feb 25 00:02:22 2009 -> +++ Started at Wed Feb 25 00:02:22 2009
Wed Feb 25 00:02:22 2009 -> clamd daemon 0.94.2 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
Wed Feb 25 00:02:22 2009 -> Log file size limit disabled.
Wed Feb 25 00:02:22 2009 -> Reading databases from /var/lib/clamav
Wed Feb 25 00:02:22 2009 -> Not loading PUA signatures.
Wed Feb 25 00:02:22 2009 -> Loaded 513855 signatures.
Wed Feb 25 00:02:22 2009 -> LOCAL: Unix socket file /var/run/clamav/clamd.ctl
Wed Feb 25 00:02:22 2009 -> LOCAL: Setting connection queue length to 15
Wed Feb 25 00:02:22 2009 -> Listening daemon: PID: 3194
Wed Feb 25 00:02:22 2009 -> Limits: Global size limit set to 104857600 bytes.
Wed Feb 25 00:02:22 2009 -> Limits: File size limit set to 26214400 bytes.
Wed Feb 25 00:02:22 2009 -> Limits: Recursion level limit set to 16.
Wed Feb 25 00:02:22 2009 -> Limits: Files limit set to 10000.
Wed Feb 25 00:02:22 2009 -> Archive support enabled.
Wed Feb 25 00:02:22 2009 -> Algorithmic detection enabled.
Wed Feb 25 00:02:22 2009 -> Portable Executable support enabled.
Wed Feb 25 00:02:22 2009 -> ELF support enabled.
Wed Feb 25 00:02:22 2009 -> Mail files support enabled.
Wed Feb 25 00:02:22 2009 -> OLE2 support enabled.
Wed Feb 25 00:02:22 2009 -> PDF support enabled.
Wed Feb 25 00:02:22 2009 -> HTML support enabled.
Wed Feb 25 00:02:22 2009 -> Self checking every 3600 seconds.
What can be wrong, where can I find the right documentation how to relate exim4 with clamav deamon?

Thanks for any suggestions!

Regards
 
Old 02-25-2009, 09:47 AM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Take a look at
http://edin.no-ip.com/content/exim4-...tch-mini-howto
 
Old 02-26-2009, 02:34 AM   #3
grzeslaw
Member
 
Registered: Nov 2008
Posts: 95

Original Poster
Rep: Reputation: 24
Yeahh, I read this link before posting message, and do all of it.

I utterly don't know what can it be. My logs didn't mark any clamav scanning messages, the email headers too. I think that mam exim , don't now how to scan the message.

What kind of marks I should saw in my logs? Please if anyone have the similar configuration (exim with one split config and SA), please paste it and write how SA marks the scanned messages. Thanks.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Exim4 + Spamassassin + clamav not working arobinson74 Debian 0 02-24-2007 07:00 PM
exim4 help mithereal Linux - General 3 08-29-2005 03:49 PM
ClamAV VirusEvent not working... timmywo Linux - Security 2 05-09-2005 01:06 PM
Exim4 / Clamav & Debian williew Linux - Software 0 12-26-2004 04:11 PM
exim4 exim4, setup debian tongueroo Linux - Networking 1 11-09-2004 04:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration