-   Debian (
-   -   EXIM blocking domains (

n3r0 09-19-2004 05:07 PM

EXIM blocking domains
i am trying to block email from certain domains (spammers) i didnt want to set up spam assasin becuase i dont think installing more software is the answer. i could do it in sendmail before but debian made sendmail a bitch to configure so im using the EXIM.

i found a faq that said to add the following to /etc/exim/exim.conf


deny  message =3D Spadaj spamerze... Get off spamers
    senders =3D ${if exists{/etc/exim/spam-reject} \

and then put a domain name in that file but it didnt seem to work (as in the mail just disapeared and didnt bounce back or anything)
i also tried sending myself mail from my hotmail account with hotmail blocked but no dice on that either.

am i doing this properly? is there another way to? there was a blocking file in sendmail but i cant find the darn thing in exim. i restarted exim after every change, is there another thing i ahve to be restarting? it works with procmail i think but i cant find the init script to restart that.



ToniT 09-19-2004 09:46 PM

Well, using procmail do drop some mail is quite easy. You don't have to touch any of the configuraton in exim. Just drop .procmailrc to your home directory and it is in use.

Anyways, I would put something like:

deny  message = Spadaj spamerze... Get off spamers
          senders = ${lookup{$host_name}lsearch{/etc/exim/spam-reject}{$value}fail}

acl_smtp_rcpt = drop_bad_guys

to the exim.conf to get it to drop connoctions from some hosts.

n3r0 09-20-2004 12:59 AM

thanks man i'll try this for a while see if it drops some connections.
also i cant do anything like per user as i want it a general server thing as no one likes getting spam :) even the bad users.

n3r0 09-22-2004 08:23 PM

damn actually i just realized that that filter blocked all my incomming mail. hmm. well im going to try setting up spam assassin. ill see how that goes as exim has a module to integrate them aparently.

All times are GMT -5. The time now is 02:33 AM.