LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-15-2005, 10:24 PM   #1
bazder
LQ Newbie
 
Registered: Jun 2005
Posts: 3

Rep: Reputation: 0
Etch: no CD sound


I installed Debian testing yesterday and like it fine except
I can't hear audio CDs although I can play the .wav files if
I copy them to the hard drive. When an audio CD is in the
drive KsCD will correctly identify the artist/song/etc. from CDDB
and look like its playing but no sound comes out.

I tried to enable sound using kmix and the KDE volume
control but to no avail. I have a DVD-ROM and a DVD-RW drive
on the second IDE controller. My /etc/fstab says...

Code:
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hdb1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hdb3       /home           ext3    defaults        0       2
/dev/hdb2       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
/dev/hdd        /media/cdrom1   udf,iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
ls -l /dev/cdrom* says...

Code:
lrwxrwxrwx  1 root root 3 2005-06-15 17:11 /dev/cdrom -> hdc
lrwxrwxrwx  1 root root 3 2005-06-15 17:11 /dev/cdrom1 -> hdd
my user account is a member of the audio, users, and cdrom group.

How can I get the CD audio to work???

with thanks,

Baz
 
Old 06-16-2005, 01:12 AM   #2
beezlebozo
LQ Newbie
 
Registered: May 2005
Posts: 15

Rep: Reputation: 0
Is your sound card on board, or an actual stand alone card? (there's probably a more technical term than that, but you get the point)

I think a lot of stand alone cards need a seperate cable going from the sound card to the cd/dvd drive for audio. (or at least, the ones I've seen do.)

Also, does it play when you're logged in as root? If so, it might be a permissions issue somewhere.

Not sure if any of that is helpful, but it's a start I suppose.
 
Old 06-16-2005, 01:14 AM   #3
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
Try playing them in XMMS by right clicking, choosing preferences, then click on CD audio plugin then options. Then from there check digital audio extraction.

then when you want to listen right click, and choose play location and type in /mnt/cdrom

see if that works.
 
Old 06-17-2005, 04:03 PM   #4
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Rep: Reputation: 30
Hi bazder. I'm only using sarge, but still on the testing repo, and getting Etch upgrades. Try having a look at Alsamixer (type alsamixer in the CLI) I'm using an Audigy2 soundblaster card and there are 2 sliders for CD. In my case one is marked CD, the other is further along and marked Audigy C. If you're using KDE there should be no problem. With Gnome there is a problem with CDROM drives, in that you need to have an analogue connection to your sound card to play CD's. Nigel. aka farpoint.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sarge or etch? anti.corp Debian 16 12-17-2005 05:57 AM
Status on etch? hyllplan Debian 9 10-30-2005 09:21 AM
nForce2 sound on Debian Etch ie_Rev Linux - Hardware 1 09-30-2005 06:18 PM
Getting Etch BradDaBug Debian 1 07-05-2005 11:25 AM
About Etch maginotjr Debian 6 06-07-2005 02:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration