LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-08-2006, 10:02 AM   #1
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Rep: Reputation: 30
Etch 3.2 Manual Partitioning option... Where is it??


I am trying to install Etch 3.2, but when I get to the point where it says automatic partitioning, it won't let me do it manualy. Instead, it says that all data will be wiped clean.... Does anybody here know how to do a manual partition? Like any other distro.... I find that this is really weird, it's one of the most basic operation.

Thanks!
 
Old 04-08-2006, 01:43 PM   #2
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Well, as far I know, there's no option of manually edit the partition table using the Etch install CD

If you want to install Etch, you can do it using the Sarge install CD and when you get promt from where you want to install, if your using http or ftp to reach the packages, you can Manually edit your sources.list and put Etch repositories


Reegards


Bye
 
Old 04-08-2006, 02:31 PM   #3
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
So there is really no option?????

Thats really stupid... I just dont get it. Its like saying a car doesnt have wheel..... It doesnt make sense
 
Old 04-08-2006, 04:39 PM   #4
Michael_aust
Member
 
Registered: Aug 2005
Location: Lancashire (United Kingdom)
Distribution: Debian Etch, on 686 machine.
Posts: 509

Rep: Reputation: 31
yes there is an option. Thts how I did my install. You may be selecting to set up partitions that consume more then your free room on the driver or something or choosing to format the existing partitions I dont know.. Theres an option the restricts you from formatting that partition.

Yeh well I did my partitions as 512 swap 15 gm root and filled the rest of the harddrive as my home directoy. I used the manually edit partition table to do this.
 
Old 04-08-2006, 05:12 PM   #5
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
Well thanks but I don't understand what you're telling me.
 
Old 04-08-2006, 05:49 PM   #6
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Unless, you're trying to save some old partitions for there data or something, the manual partition editing process should be pretty apparent.

I've installed Etch from the Net installer a half dozen times and used it every one of them.
 
Old 04-08-2006, 07:20 PM   #7
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
No its as simple as: There is no choice of partitioning there. It is Wipe HD, or cancel. Thats really doesnt make sense, does it?
 
Old 04-09-2006, 06:39 AM   #8
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
First, make sure that you've got the official installation media: http://www.debian.org/devel/debian-installer/

If you've got a fast network connection, you should choose the netinst CD image. (Notice that there are also daily builds of the installer available. Try first the Etch beta 2 image and use a daily build only if Etch beta 2 doesn't work.)

When you get to the "[!!] Partition disks" screen http://shots.osdir.com/slideshows/sl...se=395&slide=8 , the "Manually edit partition table" option should be shown at the bottom of the option list.

Instead of starting the installer by simply pressing the Enter key, you can also choose to start it by typing "expert" (without quotes) and then hitting the Enter key. This should give you more options during the installation.

It's also possible to download the netinst version of the Sarge installer (Debian 3.1r1) http://www.debian.org/releases/sarge/debian-installer/ and to boot it by typing "expert26" (and hitting Enter). This will start the Sarge installer with the 2.6 kernel and it will also give you the option to install Etch (Debian testing) via network.
 
Old 04-09-2006, 09:33 AM   #9
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
Thanks pal. Now I know that you DID understand me. The screenshot you posted is the same thing I am USED to see. But in this case, I do not have any options at all. Only clear the whole disk.

But never mind, I gave up. I just won't bother with debian releases anymore. Too bad it seemed like a nice distro.

Thanks all!
 
Old 04-09-2006, 11:58 AM   #10
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
But what's the problem, in the case that there's no option to get a manually partitioning, you can install sarge and then use a dist-upgrade to reach the Etch, or even, just modify the sources.list adding Etch repositories during installation (using Sarge CD install) is not so hard and you will get more stability using this method than a dist-upgrade ;-)


Reegards


Bye
 
Old 04-09-2006, 04:44 PM   #11
lonecrow
Member
 
Registered: May 2005
Location: Canada
Distribution: PCLinuxOS 2007
Posts: 274

Original Poster
Rep: Reputation: 30
No internet connection available during setup !
 
Old 04-13-2006, 03:51 PM   #12
drbootsie
LQ Newbie
 
Registered: Mar 2005
Location: Pocahontas County, West Virginia
Distribution: Debian
Posts: 5

Rep: Reputation: 0
I'm having a similar problem. The Etch beta2 installer tries to auto-partition, then fails. There's no option to manually configure partitions. Guess that's why they call it "beta." I've been trying the net-install stable iso, followed by upgrading with the Etch iso's. So far, I'm not having good luck there either.

Fortunately, I have a non-essential computer to experiment with, so there are no panic attacks, just puzzlement, as I try one possible solution after another.
 
Old 04-13-2006, 04:27 PM   #13
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Manual partitioning absolutely is there. Since two people have now claimed this problem, maybe it's not intuitive enough. When you get to the partitioning section of the install, you probably do want to format either the entire drive, or all the partions that Linux will be using. As I recall it, I deleted one partition at a time until all that was left was free space, then I set up my desired partitions. Just highlight the 'free space', hit enter and it'll start asking you questions. If you don't want to answer question, let it format the free space in one of two optional manners.

The only other possibly confusing thing I can think of is that when you've arrowed down to the bottom of the visible screen, there's still more farther down. Keep hitting the down arrow.
 
Old 04-13-2006, 07:31 PM   #14
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Uhm.....well, as far I recall, there was no way to select a partition to install, I remember exactly how it looks the partition screen, I installed my debian sarge many times and the common is to see several options, in the bottom you see the option to edit your partition table, in Etch when I tried to install it, well, that option wasn't included

Maybe was a problem with the CD that I downloaded, but I can be sure that the only question show for the partitioner was if I wanted let the partitioner use the disk as he want it, the best of all, is that I response "no" and then gave me an error, simple saying "Error during the partitioning of disk....."


With the testing branch, he's not the only one that saw this error, like I said, maybe was the CD that I get, but really this could happen


Reegards



Bye
 
Old 04-13-2006, 07:37 PM   #15
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Quote:
I installed my debian sarge many times and the common is to see several options, in the bottom you see the option to edit your partition table, in Etch...
I installed Etch from an installer cd I downloaded just this week, and partitioned it manually. It was the AMD64 version, but it seems unlikely that that part of the installation would be different.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How disable PCMCIA at install? Or manual partitioning on Etch lonecrow Linux - Newbie 10 04-09-2006 10:47 AM
rpm have --nodeps option with dpkg is such an option available deepclutch Debian 2 03-26-2006 10:49 PM
Getting Etch BradDaBug Debian 1 07-05-2005 12:25 PM
About Etch maginotjr Debian 6 06-07-2005 03:04 PM
Manual Partitioning during Mandrake 9.2 Installation BACTRATE Mandriva 13 02-09-2004 06:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 03:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration