LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Error message: "Unable to start the settings manager 'mate-settings-daemon'..." (https://www.linuxquestions.org/questions/debian-26/error-message-unable-to-start-the-settings-manager-mate-settings-daemon-4175648489/)

linustalman 02-17-2019 08:06 AM

Error message: "Unable to start the settings manager 'mate-settings-daemon'..."
 
2 Attachment(s)
Hi.

I'm on Debian 9 Stable. I use the MATE desktop with backports. Yesterday an update messed up my system. When I did a reboot - I was at a CLI prompt and startx would not work. So I installed Xorg (wifi worked ok). I logged in and reinstalled MATE packages bit by bit. Now almost everything is fine again.

When I try to change the theme - I get this error message [1st image attached]. Also some hotkeys don't work (like Ctrl+Alt+Delete to launch MATE System Monitor - although MSM launched ok if I select it in the menu). Quarter tiling is gone. MATE search and MATE screenshot are gone.

Also, I have sounds on like a camera click when I take a screenshot, etc. -- even though in the 2nd image attached - it's disabled.

I'm current on MATE 1.20.4.

Side by side tiling works ok. My current theme is like something from Windows 95. The only part of my theme that's ok is the window border.

How do I launch mate-settings-daemon? Here's the output:
Code:

(mate-settings-daemon:27139): GLib-GIO-ERROR **: Settings schema 'org.mate.interface' does not contain a key named 'can-change-accels'
Trace/breakpoint trap


HappyTux 02-17-2019 10:01 AM

The first hit in a google search on the error seems to suggest you missed installing the mate-desktop package.


https://github.com/mate-desktop/mate...mon/issues/193

linustalman 02-17-2019 10:06 AM

Quote:

Originally Posted by HappyTux (Post 5963222)
The first hit in a google search on the error seems to suggest you missed installing the mate-desktop package.


https://github.com/mate-desktop/mate...mon/issues/193

Hi HT. I have mate-desktop-environment installed.

Code:

apt search mate-desktop-environment
Code:

Sorting... Done
Full Text Search... Done
mate-desktop-environment/stable,stable,now 1.16.0+1 all [installed]
  MATE Desktop Environment (metapackage)

mate-desktop-environment-core/stable,stable,now 1.16.0+1 all [installed,automatic]
  MATE Desktop Environment (essential components, metapackage)

mate-desktop-environment-extra/stable,stable 1.16.0+1 all
  MATE Desktop Environment (extra components, dummy package)

mate-desktop-environment-extras/stable,stable 1.16.0+1 all
  MATE Desktop Environment (extra components, metapackage)


linustalman 02-17-2019 12:38 PM

I reinstalled the backport of pluma, mate-panel and later of mate-desktop-environment via:
Code:

sudo apt -t stretch-backports install mate-desktop-environment
All works fine now even after a reboot. :-)


All times are GMT -5. The time now is 03:30 AM.