LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-18-2005, 05:46 PM   #1
c_olin3404
Member
 
Registered: Jan 2004
Posts: 131

Rep: Reputation: 15
Error compiling fglrx module


I'm following this HOWTO to install my ATI driver for Debian. I'm using a custom built 2.6.12.5 kernel.

On compiling the fglrx module I get this output:

Code:
bluebox:/usr/src/modules/fglrx# ./make.sh
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /usr/src/linux-2.6.12.5 SUBDIRS=/usr/src/modules/fglrx modules
make[1]: Entering directory `/usr/src/linux-2.6.12.5'
  CC [M]  /usr/src/modules/fglrx/agp3.o
  CC [M]  /usr/src/modules/fglrx/nvidia-agp.o
  CC [M]  /usr/src/modules/fglrx/agpgart_be.o
/usr/src/modules/fglrx/agpgart_be.c: In function `agp_find_supported_device':
/usr/src/modules/fglrx/agpgart_be.c:7136: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7156: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7161: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7187: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7207: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7227: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7232: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c: In function `__fgl_agp_init':
/usr/src/modules/fglrx/agpgart_be.c:7613: warning: `pm_register' is deprecated (declared at include/linux/pm.h:106)
/usr/src/modules/fglrx/agpgart_be.c: In function `__fgl_agp_cleanup':
/usr/src/modules/fglrx/agpgart_be.c:7623: warning: `pm_unregister_all' is deprecated (declared at include/linux/pm.h:116)
make[2]: *** [/usr/src/modules/fglrx/agpgart_be.o] Error 1
make[1]: *** [_module_/usr/src/modules/fglrx] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.12.5'
make: *** [kmod_build] Error 2
build failed with return value 2
Any ideas?

Thanks
 
Old 08-18-2005, 07:55 PM   #2
koobert637
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian Etch (mostly :D)
Posts: 16

Rep: Reputation: 0
The ATI drivers as of now do not support kernel versions over 2.6.12. In order to build them, you need a patch. The one recommended here is http://rambo.its.tudelft.nl/~ewald/f...4.13-fc4.patch I have yet to upgrade to the 2.6.12 kernel series, but will soon. Also, if you want to install these drivers the debian way, I suggest looking here

Of course, apply the patch by patch -p1 < fglrx_6_8_0-8.14.13-fc4.patch in the /usr/src/modules/fglrx directory.

//EDIT:
Well I just upgraded The patch will complain it can't find the makefile to patch, thats okay as long as you are not using gcc-4.0 (which unfortuately most people are due to debian's upgrade, I still don't think its stable enough to use yet) If you are, add these lines to your makefile after the first line in the file:
Code:
ifeq ($(GCC_VER_MAJ),4)
GCC_VER_MAJ     = 3
endif
And you should be as good as gold!

Last edited by koobert637; 08-18-2005 at 08:20 PM.
 
Old 08-19-2005, 05:00 PM   #3
c_olin3404
Member
 
Registered: Jan 2004
Posts: 131

Original Poster
Rep: Reputation: 15
Thanks! That worked very smoothly!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error compiling ati module with 2.6.11-rc4 usethesource Linux - Hardware 1 02-13-2005 05:40 PM
fglrx compiling custom module problem (firegl_public.c) Slate01 Linux - Hardware 0 11-25-2004 02:25 PM
fglrx module not found but X runs using module biger problem though HELP! fireicer Linux - Newbie 4 07-30-2004 04:44 PM
Compiling 2.4.23 : Module error spam Modify Linux - Newbie 0 12-15-2003 05:52 PM
Error compiling Module in Linux kernel iannou Linux - Software 1 06-27-2003 07:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration