LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-17-2007, 08:49 PM   #1
deepclutch
Member
 
Registered: Nov 2004
Location: Kerala, India
Distribution: Devuan Beowulf
Posts: 770
Blog Entries: 1

Rep: Reputation: 34
Smile Epiphany-2.18 crashes with flash player 9


Uses Debian Sid and a week before upgraded to Epiphany-2.18.now when i play a flash and then try changing to some URL,the browser hangs.I already submitted a bug report at GNOME bugzilla and they said they cant do much as it is a proprietory flash-plugin problem.below is the output of :
Code:
prakash@jaguar:~$ /usr/bin/epiphany.debian --sync

(epiphany.debian:3566): libgnomevfs-WARNING **: Failed to create service browser: Bad state


(epiphany.debian:3566): libgnomevfs-WARNING **: Failed to create service browser: Bad state


(epiphany.debian:3566): libgnomevfs-WARNING **: Failed to create service browser: Bad state


** (epiphany.debian:3566): WARNING **: No word lists can be found for the language "en".
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)

***MEMORY-WARNING***: [3581]: GSlice: g_thread_init() must be called before all other GLib functions; memory corruption due to late invocation of g_thread_init() has been detected; this program is likely to crash, leak or unexpectedly abort soon...

sys:1: GtkWarning: gtk_window_group_remove_window: assertion `GTK_IS_WINDOW_GROUP (window_group)' failed
earlier if i enable pango there is a message as below.so i disabled pango rendering.
Code:
NOTE: Enabling gecko pango renderer; this may cause performance degradation.
You can set /apps/epiphany/web/enable_pango to "false" to disable it.
So how can i prevent flash lock-up's.
I already invokes epiphany as "aoss epiphany" after a dpkg-divert to epiphany.debian containing "aoss" alsa-oss.this is the same issue which iceweasel too have when ESD server is used allover the GNOME Desktop.
So What is it related to?why failed to create service browser?is it related to HAL and dbus?
Thank You
 
Old 06-17-2007, 09:04 PM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Are you using the latest flash that was released just a few days ago?
 
Old 06-18-2007, 11:25 PM   #3
deepclutch
Member
 
Registered: Nov 2004
Location: Kerala, India
Distribution: Devuan Beowulf
Posts: 770

Original Poster
Blog Entries: 1

Rep: Reputation: 34
Yes I do.now crash and hangs are lesser.
now thinking of trying GNASH(GPL swf player) after a loong time
 
Old 06-18-2007, 11:44 PM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
I use Gnash on my 64-bit system and I'm very pleased with it. There is a new version waiting in the "new" queue which I got from here. If you don't like getting packages from Sid, you'll have to compile it yourself. This new version has lots of improvements including working for YouTube videos.
 
Old 06-19-2007, 01:35 PM   #5
deepclutch
Member
 
Registered: Nov 2004
Location: Kerala, India
Distribution: Devuan Beowulf
Posts: 770

Original Poster
Blog Entries: 1

Rep: Reputation: 34
yes,thank you.I am running long time Debian Sid apt-pinned with testing,experimental in a low priority.gnash too is available.


btwn there is some support for flash and other plugins for 64-bit users coming(came!):
nspluginwrapper
Quote:
nspluginwrapper is an Open Source compatibility plugin for Netscape 4 (NPAPI) plugins. That is, it enables you to use plugins on platforms they were not built for. For example, you can use the Adobe Flash plugin on Linux/x86_64, NetBSD and FreeBSD platforms.
http://gwenole.beauchesne.info/proje...pluginwrapper/
http://home.comcast.net/~next/nsplug...l-0-1.1.tar.gz
reg,

Last edited by deepclutch; 06-19-2007 at 01:38 PM.
 
  


Reply

Tags
epiphany, flash9, nspluginwrapper


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash Player 9 crashes in Opera and Konqueror wauwha Linux - Software 4 05-19-2008 09:13 AM
Installing Adobe Flash Player on Konqueror, Epiphany and Other Browsers rm_-rf_windows Linux - Software 9 09-07-2007 05:26 PM
Epiphany browser crashes when viewing history General Linux - Software 1 03-15-2007 11:47 AM
opera 9 crashes with flash player 9 beta sometimes tfm1 Linux - Software 2 10-25-2006 05:25 AM
Firefox and Epiphany crashes in FC5 dabang Fedora 4 04-04-2006 11:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration