LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-25-2011, 08:58 PM   #1
fhleung
Member
 
Registered: Aug 2004
Distribution: Lubuntu Live OS
Posts: 432

Rep: Reputation: 30
Enable the apache2 module --- a2enmod


The default Server root of the apache2.conf is "etc/apache2". But the actual "It works!" file is in /var/www/apache2-default

I edit the apache2.conf file the Server root line then restart the scrip at /etc/init.d/apache2
But the webpage still point to "It works!"

Anyone have idea how to change the Document root?

Last edited by fhleung; 03-13-2011 at 11:12 PM.
 
Old 02-26-2011, 03:33 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,441

Rep: Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739
Hi,

In Fedora and the other Redhat based distros, all modules are already loaded through LoadModule directives in /etc/httpd/conf/httpd.conf during the apache installation.

Regards
 
Old 03-13-2011, 11:00 PM   #3
fhleung
Member
 
Registered: Aug 2004
Distribution: Lubuntu Live OS
Posts: 432

Original Poster
Rep: Reputation: 30
The default Server root of the apache2.conf is "etc/apache2". But the actual "It works!" file is in /var/www/apache2-default

I edit the apache2.conf file the Server root line then restart the scrip at /etc/init.d/apache2
But the webpage still point to "It works!"

Anyone have idea how to change the Document root?
 
Old 03-14-2011, 03:10 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,441

Rep: Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739Reputation: 1739
Hi,

May I ask why did you change completely your 1st post? There you mentioned that you use Fedora's apache package.
If you use apache in a debian based distro (I assume this because you say that config is under etc/apache2), then you should edit /etc/apache2/sites-enabled/000-default

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apache2 module? razzera Debian 5 12-18-2010 07:27 AM
howto enable/link ssh with apache2 rh-penguin Linux - Server 1 12-30-2007 08:56 AM
configured apache2 without --enable-so vivek_nz76 Fedora 1 01-08-2006 02:24 PM
Mandrake & Apache2/php4.2.3 how to enable GD extensions sablecurls Mandriva 1 07-09-2004 02:35 PM
How to enable php in Apache2 under RHlinux 8? Luc Linux - Newbie 3 12-14-2002 07:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration