LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-27-2015, 03:23 PM   #1
cli-86
LQ Newbie
 
Registered: Mar 2015
Location: uk
Distribution: lmde 2
Posts: 26

Rep: Reputation: Disabled
enable root login debian wheezy 7.8.0


ONLY USE ROOT ACCOUNT IF ITS A MUST TRY AND USE REGULAR ACCOUNT AS MUCH AS POSSIBLE (YOU COULD BREAK YOUR INSTALL USING ROOT ACCOUNT IF YOU DO SOMETHING WRONG) FOLLOW THIS GUIDE EXACTLY!

ok, first open a terminal and type su then your root password that you created when installing your debian 7 wheezy os.

type: apt-get install leafpad (this will install leafpad text editor which is what we are going to use next) once installed stay in root terminal.

type leafpad /etc/gdm3/daemon.conf under security type this (AllowRoot=true) no brackets so it should look like this:

[security]
AllowRoot=true
(once it looks like this go to file then save then you can exit the window)


type leafpad /etc/pam.d/gdm3 and press enter you will get a window open that contains this text:

#PAM-1.0
auth requisite pam_nologin.so
auth required pam_env.so readenv=1
auth required pam_env.so readenv=1 envfile=/etc/default/locale
#auth required pam_succeed_if.so user != root quiet_success
@include common-auth
auth optional pam_gnome_keyring.so
@include common-account
session required pam_limits.so
@include common-session
session optional pam_gnome_keyring.so auto_start
@include common-password

comment out this line: #auth required pam_succeed_if.so user != root quiet_success

go to file hit save then exit window

now you can exit the terminal window aswell

now you can either logout or restart computer (restart would maybe be better just to make sure)

at login screen make sure (system default is selected this will be gd3 which you edited earlier)

just type username: root
then type your root password that you created during install. hopefully this helps someone

Last edited by cli-86; 03-27-2015 at 06:03 PM. Reason: how i enabled root login
 
Old 03-27-2015, 04:02 PM   #2
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
Quote:
Originally Posted by cli-86 View Post
Solved
It would be polite to share your solution with the rest of the community.

FWIW:
Code:
sudo passwd root
 
Old 03-27-2015, 04:39 PM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4860Reputation: 4860Reputation: 4860Reputation: 4860Reputation: 4860Reputation: 4860Reputation: 4860Reputation: 4860Reputation: 4860Reputation: 4860Reputation: 4860
Quote:
Originally Posted by Head_on_a_Stick View Post
It would be polite to share your solution with the rest of the community.

FWIW:
Code:
sudo passwd root
Debian does by default not have a disabled root account, I guess that the OP's problem was that the GDM display manager for by default does not allow root logins to the GUI.

@cli-86: deleting your posts when your problems are solved is not appreciated on this forum. If you instead share your solution others with the same problems or question can benefit from it.

Last edited by TobiSGD; 03-27-2015 at 04:41 PM.
 
1 members found this post helpful.
Old 03-27-2015, 04:59 PM   #4
cli-86
LQ Newbie
 
Registered: Mar 2015
Location: uk
Distribution: lmde 2
Posts: 26

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
Debian does by default not have a disabled root account, I guess that the OP's problem was that the GDM display manager for by default does not allow root logins to the GUI.

@cli-86: deleting your posts when your problems are solved is not appreciated on this forum. If you instead share your solution others with the same problems or question can benefit from it.
really sorry i found a webpage that i used with the solution, is it against forum rules to post the link?
 
Old 03-27-2015, 05:13 PM   #5
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,628

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
No it is not. Just telling people what you did would be fine also.

To mark a thread solved you go to the top of the page click on Forum tools and choose the option to mark it solved.
 
Old 03-27-2015, 05:51 PM   #6
cli-86
LQ Newbie
 
Registered: Mar 2015
Location: uk
Distribution: lmde 2
Posts: 26

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by widget View Post
No it is not. Just telling people what you did would be fine also.

To mark a thread solved you go to the top of the page click on Forum tools and choose the option to mark it solved.
ok edited first post with a tutorial if thats ok?
 
Old 03-27-2015, 05:52 PM   #7
cli-86
LQ Newbie
 
Registered: Mar 2015
Location: uk
Distribution: lmde 2
Posts: 26

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
It would be polite to share your solution with the rest of the community.

FWIW:
Code:
sudo passwd root
edited first post with tutorial really sorry for my ignorance with not sharing i will know in the future to share this info
 
Old 03-27-2015, 05:54 PM   #8
cli-86
LQ Newbie
 
Registered: Mar 2015
Location: uk
Distribution: lmde 2
Posts: 26

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
Debian does by default not have a disabled root account, I guess that the OP's problem was that the GDM display manager for by default does not allow root logins to the GUI.

@cli-86: deleting your posts when your problems are solved is not appreciated on this forum. If you instead share your solution others with the same problems or question can benefit from it.
tutorial in first post sorry for not sharing
 
Old 03-27-2015, 05:57 PM   #9
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,638

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Also, logging in to an x session as root is a spectacularly bad idea.
 
Old 03-27-2015, 06:00 PM   #10
cli-86
LQ Newbie
 
Registered: Mar 2015
Location: uk
Distribution: lmde 2
Posts: 26

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by descendant_command View Post
Also, logging in to an x session as root is a spectacularly bad idea.
im new to this i only done it so i could change themes because i didnt have elevated priveledges to do it i will add that to the tutorial
 
Old 03-27-2015, 08:39 PM   #11
cli-86
LQ Newbie
 
Registered: Mar 2015
Location: uk
Distribution: lmde 2
Posts: 26

Original Poster
Rep: Reputation: Disabled
can this be moved to tutorial section?
 
Old 03-28-2015, 05:53 PM   #12
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,638

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
You don't need elevated priveleges to change themes.
Just put them in ~/.themes

You can su to root in a terminal.
You can run selected gui apps as root with gksu and such.

You do NOT want to log in as root and have your clock and weather app and BROWSER and ... ALL RUNNING AS ROOT.

Edit: ... and, no, this should not be in any tutorial section.

Last edited by descendant_command; 03-28-2015 at 05:54 PM.
 
Old 03-29-2015, 03:37 AM   #13
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,393
Blog Entries: 55

Rep: Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565
Quote:
Originally Posted by descendant_command View Post
Edit: ... and, no, this should not be in any tutorial section.
You have the right to voice your opinion but you do not have the right to answer that question authoritatively.
Next time please mark that subtle difference for others prefixing such utterings with an "in my opinion".
 
Old 03-29-2015, 03:50 AM   #14
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,393
Blog Entries: 55

Rep: Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565
Quote:
Originally Posted by cli-86 View Post
can this be moved to tutorial section?
It could be but I veto it. Here's why:


Quote:
Originally Posted by cli-86 View Post
type: apt-get install leafpad
Installing a Desktop Environment editor and all of its dependencies is completely unnecessary: just use any command line visual editor the machine comes with: pico, nano, vi, ed, Hell even Emacs...


Quote:
Originally Posted by cli-86 View Post
now you can either logout or restart computer (restart would maybe be better just to make sure)
Rebooting a Linux machine to make settings stick is almost never necessary: here logging out (or restarting the Xorg server) will do because that will allow one to have PAM re-read its stack on login.


...but most of all, as descendant_command already noted, because it's completely unnecessary to change themes that way. Realize that separation of privileges architecturally is one of the foundations that contributes to the safety of using Linux. Like other subsystems Desktop Environments use sane defaults and user-specific customizations. It would be beneficial for you to read your distributions user and admin documentation.


// I'll mark this thread "solved" for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Adjusting login screen resolution in Debian Wheezy/Gnome 3. theAdmiral Debian 2 05-27-2014 10:25 AM
[SOLVED] HOWTO: Debian 7 (Wheezy) LXDE Auto Numlock, both BEFORE and AFTER login luvr Debian 3 04-08-2014 10:00 PM
How to run a program as root on startup in debian wheezy? skilo47 Linux - Software 2 01-10-2014 12:20 PM
[SOLVED] Cannot log in, or use, as root in new clean Debian Wheezy installs. k3lt01 Debian 11 06-20-2013 08:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration