LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   enable root login debian wheezy 7.8.0 (https://www.linuxquestions.org/questions/debian-26/enable-root-login-debian-wheezy-7-8-0-a-4175538034/)

cli-86 03-27-2015 03:23 PM

enable root login debian wheezy 7.8.0
 
ONLY USE ROOT ACCOUNT IF ITS A MUST TRY AND USE REGULAR ACCOUNT AS MUCH AS POSSIBLE (YOU COULD BREAK YOUR INSTALL USING ROOT ACCOUNT IF YOU DO SOMETHING WRONG) FOLLOW THIS GUIDE EXACTLY!

ok, first open a terminal and type su then your root password that you created when installing your debian 7 wheezy os.

type: apt-get install leafpad (this will install leafpad text editor which is what we are going to use next) once installed stay in root terminal.

type leafpad /etc/gdm3/daemon.conf under security type this (AllowRoot=true) no brackets so it should look like this:

[security]
AllowRoot=true
(once it looks like this go to file then save then you can exit the window)


type leafpad /etc/pam.d/gdm3 and press enter you will get a window open that contains this text:

#PAM-1.0
auth requisite pam_nologin.so
auth required pam_env.so readenv=1
auth required pam_env.so readenv=1 envfile=/etc/default/locale
#auth required pam_succeed_if.so user != root quiet_success
@include common-auth
auth optional pam_gnome_keyring.so
@include common-account
session required pam_limits.so
@include common-session
session optional pam_gnome_keyring.so auto_start
@include common-password

comment out this line: #auth required pam_succeed_if.so user != root quiet_success

go to file hit save then exit window

now you can exit the terminal window aswell

now you can either logout or restart computer (restart would maybe be better just to make sure)

at login screen make sure (system default is selected this will be gd3 which you edited earlier)

just type username: root
then type your root password that you created during install. :) hopefully this helps someone

Head_on_a_Stick 03-27-2015 04:02 PM

Quote:

Originally Posted by cli-86 (Post 5338579)
Solved

It would be polite to share your solution with the rest of the community.

FWIW:
Code:

sudo passwd root

TobiSGD 03-27-2015 04:39 PM

Quote:

Originally Posted by Head_on_a_Stick (Post 5338605)
It would be polite to share your solution with the rest of the community.

FWIW:
Code:

sudo passwd root

Debian does by default not have a disabled root account, I guess that the OP's problem was that the GDM display manager for by default does not allow root logins to the GUI.

@cli-86: deleting your posts when your problems are solved is not appreciated on this forum. If you instead share your solution others with the same problems or question can benefit from it.

cli-86 03-27-2015 04:59 PM

Quote:

Originally Posted by TobiSGD (Post 5338632)
Debian does by default not have a disabled root account, I guess that the OP's problem was that the GDM display manager for by default does not allow root logins to the GUI.

@cli-86: deleting your posts when your problems are solved is not appreciated on this forum. If you instead share your solution others with the same problems or question can benefit from it.

really sorry :( i found a webpage that i used with the solution, is it against forum rules to post the link?

widget 03-27-2015 05:13 PM

No it is not. Just telling people what you did would be fine also.

To mark a thread solved you go to the top of the page click on Forum tools and choose the option to mark it solved.

cli-86 03-27-2015 05:51 PM

Quote:

Originally Posted by widget (Post 5338647)
No it is not. Just telling people what you did would be fine also.

To mark a thread solved you go to the top of the page click on Forum tools and choose the option to mark it solved.

ok edited first post with a tutorial if thats ok?

cli-86 03-27-2015 05:52 PM

Quote:

Originally Posted by Head_on_a_Stick (Post 5338605)
It would be polite to share your solution with the rest of the community.

FWIW:
Code:

sudo passwd root

edited first post with tutorial :) really sorry for my ignorance with not sharing i will know in the future to share this info

cli-86 03-27-2015 05:54 PM

Quote:

Originally Posted by TobiSGD (Post 5338632)
Debian does by default not have a disabled root account, I guess that the OP's problem was that the GDM display manager for by default does not allow root logins to the GUI.

@cli-86: deleting your posts when your problems are solved is not appreciated on this forum. If you instead share your solution others with the same problems or question can benefit from it.

tutorial in first post sorry for not sharing :(

descendant_command 03-27-2015 05:57 PM

Also, logging in to an x session as root is a spectacularly bad idea.

cli-86 03-27-2015 06:00 PM

Quote:

Originally Posted by descendant_command (Post 5338673)
Also, logging in to an x session as root is a spectacularly bad idea.

im new to this i only done it so i could change themes because i didnt have elevated priveledges to do it i will add that to the tutorial

cli-86 03-27-2015 08:39 PM

can this be moved to tutorial section?

descendant_command 03-28-2015 05:53 PM

You don't need elevated priveleges to change themes.
Just put them in ~/.themes

You can su to root in a terminal.
You can run selected gui apps as root with gksu and such.

You do NOT want to log in as root and have your clock and weather app and BROWSER and ... ALL RUNNING AS ROOT.

Edit: ... and, no, this should not be in any tutorial section.

unSpawn 03-29-2015 03:37 AM

Quote:

Originally Posted by descendant_command (Post 5339129)
Edit: ... and, no, this should not be in any tutorial section.

You have the right to voice your opinion but you do not have the right to answer that question authoritatively.
Next time please mark that subtle difference for others prefixing such utterings with an "in my opinion".

unSpawn 03-29-2015 03:50 AM

Quote:

Originally Posted by cli-86 (Post 5338726)
can this be moved to tutorial section?

It could be but I veto it. Here's why:


Quote:

Originally Posted by cli-86 (Post 5338579)
type: apt-get install leafpad

Installing a Desktop Environment editor and all of its dependencies is completely unnecessary: just use any command line visual editor the machine comes with: pico, nano, vi, ed, Hell even Emacs...


Quote:

Originally Posted by cli-86 (Post 5338579)
now you can either logout or restart computer (restart would maybe be better just to make sure)

Rebooting a Linux machine to make settings stick is almost never necessary: here logging out (or restarting the Xorg server) will do because that will allow one to have PAM re-read its stack on login.


...but most of all, as descendant_command already noted, because it's completely unnecessary to change themes that way. Realize that separation of privileges architecturally is one of the foundations that contributes to the safety of using Linux. Like other subsystems Desktop Environments use sane defaults and user-specific customizations. It would be beneficial for you to read your distributions user and admin documentation.


// I'll mark this thread "solved" for you.


All times are GMT -5. The time now is 08:04 AM.