LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-01-2007, 07:42 AM   #16
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 60

Quote:
Originally Posted by Aleora View Post
No difference. Should I maybe make a new file to replace it with?
That may help, but on the other hand whatever caused the ghost extra space to appear is the real problem. I worry that redoing the file would only recreate the problem. Still, it may be worth a try. First backup the current list, by doing "cp /etc/apt/sources.list /etc/apt/sources.list.bak". Then you can try removing the sources list and write an entirely new one. Try using a different editor maybe (vi/vim should be fine, but something is clearly going wrong with it).
 
Old 11-24-2007, 01:41 PM   #17
Aleora
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Rep: Reputation: 0
I finally got it working. I made a new file and that cleared things up. Thanks for your help
 
Old 04-17-2008, 02:07 PM   #18
felipe1982
LQ Newbie
 
Registered: Dec 2007
Posts: 23

Rep: Reputation: 0
Quote:
Originally Posted by leonscape View Post
Add the following line to either /etc/apt/apt.conf or /etc/apt/apt.conf.d/70debconf

Code:
APT::Cache-Limit "8388608";
This is so annoying! Why do we have to do this manually? Shouldn't it just use up as much space as necessary, no matter if we have 3 repos or 30? That's just user hostile, not user friendly.

Anyways, I trimmed down my sources, and it is working better no. No more contrib and non-free (for the short term)
 
Old 04-17-2008, 03:55 PM   #19
gamewolf
Member
 
Registered: Jun 2007
Distribution: Debian Sid, Slackware 13.37
Posts: 204

Rep: Reputation: 16
I had the same error. I just got rid of the testing sites and it worked fine.
 
Old 12-26-2008, 06:28 PM   #20
Lillioan Martinez
LQ Newbie
 
Registered: Dec 2005
Location: Round Rock, Texas, USA
Distribution: Debian
Posts: 10

Rep: Reputation: 0
MMap

I think this didn't work:
[~]# etc/apt/apt.conf.d
-su: etc/apt/apt.conf.d: No such file or directory
[~]# etc/apt/apt.conf.d/70debconf
-su: etc/apt/apt.conf.d/70debconf: No such file or directory
[~]# etc/apt/apt.conf
-su: etc/apt/apt.conf: No such file or directory
[~]#
 
Old 12-26-2008, 06:30 PM   #21
Lillioan Martinez
LQ Newbie
 
Registered: Dec 2005
Location: Round Rock, Texas, USA
Distribution: Debian
Posts: 10

Rep: Reputation: 0
MMap

how do you make a new file?

Lillian Simmons
Still Free! in Round Rock, Texas, USA
http://xld.com
 
Old 12-26-2008, 06:38 PM   #22
Lillioan Martinez
LQ Newbie
 
Registered: Dec 2005
Location: Round Rock, Texas, USA
Distribution: Debian
Posts: 10

Rep: Reputation: 0
MMap

how do you make a directory?
this is what I got:


[~]# make dir apt.conf
make: *** No rule to make target `dir'. Stop.
[~]#

Lillian Simmons
Still Free! in Round Rock, Texas, USA
http://xld.com
 
Old 12-26-2008, 08:01 PM   #23
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Please don't triple-post. Please don't necro old topics.

Please go to your local bookstore, pick up a "Linux for dummies" book or similar title, and read it cover to cover.
 
Old 03-04-2009, 09:02 PM   #24
linuxstyles
LQ Newbie
 
Registered: Mar 2009
Posts: 1

Rep: Reputation: 0
Worked for me, thanks..

// Pre-configure all packages with debconf before they are installed.
// If you don't like it, comment it out.
DPkg::Pre-Install-Pkgs {"/usr/sbin/dpkg-preconfigure --apt || true";};
APT::Cache-Limit "16777216";
 
Old 04-09-2011, 12:57 AM   #25
ghaon
LQ Newbie
 
Registered: Apr 2011
Posts: 1

Rep: Reputation: 0
Comment out some of your sources.list file

Hey all, I had this problem as well, it didn't seem to help to add an apt.conf file.

So I just went into the source.list file and commented out most of the newer sources I had been adding (without totally knowing what I was doing so there were so errors)

just type:

sudo nano /etc/apt/sources.list

press down and add ## in the front of anything that you've added that isn't essential to update

Ctrl + X
and then Y for Yes to save
Enter

That seemed to clear it up. Now apt, synaptic and the system updater are working again.
 
Old 05-27-2013, 03:56 AM   #26
ptericles
LQ Newbie
 
Registered: Jan 2012
Posts: 2

Rep: Reputation: Disabled
segmentation faultsts... 87%

APT::Cache-Limit "16777216";
in /etc/apt/apt.conf.d/70debconf
only got me to 87%, but
APT::Cache-Limit "25165824";
worked (8388608*3). I supposed even
APT::Cache-Limit "18958255";
might have worked, but whatever.

Last edited by ptericles; 05-27-2013 at 04:00 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dynamic MMap ran out of room +APT bassclarinet Debian 3 12-26-2008 07:46 PM
Dynamic MMap out of room dekket Debian 6 12-25-2006 12:23 AM
smbclient "Error returning browse list: NT_STATUS_OK" b0nes Linux - Networking 2 02-18-2005 07:13 AM
Can't "stat source package list" irvken Debian 3 01-31-2005 01:52 PM
apt-get -> testing, errors processing package lists, Dynamic MMap??? gaffel Debian 5 07-16-2004 01:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration