LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   "Dynamic MMap ran out of room" error when adding new apt source list (https://www.linuxquestions.org/questions/debian-26/dynamic-mmap-ran-out-of-room-error-when-adding-new-apt-source-list-233417/)

hasanito 09-21-2004 12:35 PM

"Dynamic MMap ran out of room" error when adding new apt source list
 
G'day

I've just installed Debian 3.0
I try to install xfce4 as the desktop manager but my "wajig install xfce" installed xfce3... so I added following apt source list to my source list:

# Unstable
deb ftp.de.debian.org/debian unstable main contrib non-free
deb ftp.de.debian.org/debian-non-US unstable/non-US main contrib non-free

# Testing
deb ftp.de.debian.org/pub/debian testing main contrib non-free
deb ftp.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free

*add http after deb :-)*
but this time I get following error when I do a wajig update:

- - - - - - - - - -
Reading Package Lists... Error!
E: Dynamic MMap ran out of room
E: Error occured while processing orange (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp.de.debian.org_debian_dists_unstable_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.

update available list script returned error exit status 1.
Press <enter> to continue.
- - - - - - - - - -

any help?

cheers

ps:
Alternative to that, how can I install Gnome2+? everytime I try wajig install gnome or gnome core, it can't find it?

cheers

leonscape 09-21-2004 12:39 PM

Add the following line to either /etc/apt/apt.conf or /etc/apt/apt.conf.d/70debconf

Code:

APT::Cache-Limit "8388608";

Abject 09-08-2007 01:22 PM

Thanks, that will probably work for many folks. Didn't for me, but
Code:

APT::Cache-Limit "16777216";
(... twice the size), did the trick.

- Ab

makuyl 09-08-2007 02:20 PM

I'll raise that to: APT::Cache-Limit 50000000;

Seriously, you can set it to how much you like but keep in mind not to let it fill /var or worse /.
"apt-get clean" or "aptitude clean" now and then would clean up the /var/cache/apt/archives so you can manage with a lower limit.

EDIT: Might want to wade through some of the user's manuals here: http://www.debian.org/doc/index.en.html

MooseMagnet 10-13-2007 12:50 PM

Increases Cache
 
Howdy:
I had the same problem. I increased the cache size, and it did allow me to run sudo apt-get upgrade. But now my sound card is dead. I've had this problem before many times. I'm running Ubuntu Feisty Fawn on a Dell Laptop. Any way to permanently solve this problem without re-installing XP? Thanks.

AlucardZero 10-13-2007 01:06 PM

Quote:

Originally Posted by MooseMagnet (Post 2923046)
Howdy:
I had the same problem. I increased the cache size, and it did allow me to run sudo apt-get upgrade. But now my sound card is dead. I've had this problem before many times. I'm running Ubuntu Feisty Fawn on a Dell Laptop. Any way to permanently solve this problem without re-installing XP? Thanks.

yes, but your problem is completely unrelated and you need to create your own thread.

Aleora 10-30-2007 08:50 PM

I am having this same problem, and editing the /etc/apt/apt.conf.d file 70debconf is having no effect. I also ran apt-get clean. The whole error message is:
Reading package lists... Error!
E: Dynamic MMap ran out of room
E: Error occurred while processing xmcd (NewFileVer1)
E: Problem with MergeList /var/lib/apt/lists/ftp.debian.org_debian_dists_testing_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.

which looks a lot like the error message in the original post. Does anyone know what's wrong?

AlucardZero 10-30-2007 10:36 PM

up the APT::Cache-Limit more and try again

Aleora 10-31-2007 07:19 AM

I've taken it up to 20 times what makuyl suggested in jest, and nothing changes.

Telemachos 10-31-2007 12:56 PM

Quote:

Originally Posted by Aleora (Post 2943361)
I've taken it up to 20 times what makuyl suggested in jest, and nothing changes.

Can you post what's in your /etc/apt/sources.list file, please?

Aleora 10-31-2007 01:47 PM

In /etc/apt/sources.list I have this:

#
# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

deb http://ftp.us.debian.org/debian/ etch main
deb-src http://ftp.us.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib
deb ftp://ftp.debian.org/debian unstable main contrib non-free
deb ftp://ftp.debian.org/debian testing main contrib non-free

#Added to get codecs
deb http://mirror.home-dn.net/debian-multimedia stable main
deb-src http://mirror.home-dn.net/debian-multimedia stable main

As a side-note, I am very new to linux (as you have probably guessed) and my boyfriend has most often been the one to make changes. He added some of these- I think everything after the first two...

Telemachos 10-31-2007 02:00 PM

Ok, well the sources list is a bit of a mess. You have all three branches of Debian enabled (etch/stable, testing and unstable). No matter what else, you probably don't want that. Maybe try to trim it down a bit to this (the # in front of a line makes apt ignore the line):

Quote:

#
# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

#deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

deb http://ftp.us.debian.org/debian/ etch main
deb-src http://ftp.us.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib
#deb ftp://ftp.debian.org/debian unstable main contrib non-free
#deb ftp://ftp.debian.org/debian testing main contrib non-free

#Added to get codecs
#deb http://mirror.home-dn.net/debian-multimedia stable main
#deb-src http://mirror.home-dn.net/debian-multimedia stable main
Still, you should be able to update your sources list if you have made the cache that large. Try again to do "apt-get clean && apt-get update" after trimming down the sources list. My only other guess is that maybe you have /var in a partition that it filled up? I took out the multimedia repos for the moment, just to see if you can get apt working again.

Aleora 10-31-2007 02:25 PM

So, I went and changed the file as directed. Now it doesn't like the sources.list file, though. It says:
E: Type '' is not known on line 1 in source list /etc/apt/sources.list

When cat sources.list, there is a leading space. When I open it in vi, there isn't, so I can't remove it. *sigh*

Telemachos 10-31-2007 03:24 PM

The whole first line is not needed, so you could open in vim, move up to the first line (you may start there, you may not) and then use "dd" to delete that one line.

Aleora 10-31-2007 08:49 PM

No difference. Should I maybe make a new file to replace it with?


All times are GMT -5. The time now is 12:58 PM.