LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-06-2004, 04:31 AM   #1
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 547

Rep: Reputation: 30
Unhappy During 2.6.6 kernel compile, make-dpkg not found?


I know that we don't need yet another kernel compilation thread, but this didn't fit into any of the others. I am using the following guide to compile the 2.6.6 kernel for my Debian sarge system which is currently running the 2.4.25 kernel. I already did make menuconfig and everything is set to go according to this guide: http://www.desktop-linux.net/debkernel.htm. But when I go to make the source here is what I get:

Code:
localhost:/usr/src/linux# make-kpkg buildpackage -rev Custom.1 kernel_image
bash: make-kpkg: command not found
I don't know what to do from here. I tried using apt-cache search to see if I was missing something but I couldn't find anything. Please help me, I'm really anxious/excited to get my newly configured kernel up and running Thanks in advance!
 
Old 07-06-2004, 04:44 AM   #2
vimico
Member
 
Registered: Jan 2004
Distribution: Debian, Ubuntu
Posts: 118

Rep: Reputation: 15
you're right. it seems they forgot to install the most important part - the kernel-package.

The following apt-get should install everything else you need (if it is not already there).

Code:
apt-get install libncurses5-dev make gcc bin86 libc6-dev kernel-package
 
Old 07-06-2004, 04:52 AM   #3
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 547

Original Poster
Rep: Reputation: 30
Yup I was missing kernel-package. Thanks a lot sir/madam, now everything is great!
 
Old 07-06-2004, 07:55 AM   #4
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 547

Original Poster
Rep: Reputation: 30
I spoke too soon.....

So I installed the kernel successfully after it compiled, but things aren't great. I get the following messages during boot-up:

Code:
VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root= " boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)
Ok.....so I hope all I need to do to fix this is to append a correct root= boot option! The question is, where? I followed that guide completely, but it didn't say anything about making/installing the modules. Should I have done this, or were the modules already made/compiled into my .deb custom kernel? Thanks, and don't hate the
 
Old 07-06-2004, 02:38 PM   #5
comp12345
Member
 
Registered: Feb 2004
Posts: 467

Rep: Reputation: 30
The most common problem is either you did not compile built-in support for your IDE chipset(under Device Drivers->ATA/ATAPI/MFM/RLL) or you compiled it as a module. Check and make sure you have it built-in.
 
Old 07-07-2004, 12:56 AM   #6
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 547

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by comp12345
The most common problem is either you did not compile built-in support for your IDE chipset(under Device Drivers->ATA/ATAPI/MFM/RLL) or you compiled it as a module. Check and make sure you have it built-in.
I checked and it was a module, so I re-compiled but still the same problem. I asked my friend and he said he had the same problem, but after he changed his bootloader from grub to lilo it worked fine. So I'm going to try that and see if it works. Thanks anyway though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel compile fails with make-kpkg, not with make cspos Debian 37 11-09-2005 10:11 AM
No module raid0 found during kernel compile mcalizo Linux - Software 2 12-08-2004 01:09 AM
kernel compile - make errors hnad Slackware 5 09-18-2004 07:54 AM
make-dpkg: command not found kadalz Linux - Newbie 5 10-02-2003 06:15 AM
Kernel Compile: Image Cannot Be Found katana Linux - General 1 11-20-2002 02:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration