LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-07-2016, 02:00 AM   #1
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,745

Rep: Reputation: 107Reputation: 107
drmSetMaster failed: Permission denied


Hya

System
Debian stretch amd64,
graphic driver is i915

What happened
After dist-upgrade, X fails to kick in.
Last upgrade was on Aug 9.

Error message (Xorg.0.log) is
Code:
modeset(0): drmSetMaster failed: Permission denied
then Server terminates with several other messages.

Troubleshooting process
X kicks in with root. (This indicates that packages are good. Permission issue is next one to check)
/etc/group says that user belongs to video group. (looks good. not edited at all!)

No other logs (dmesg, syslog, messages) are helpful.
I checked several other comps for permission of /usr/lib/x86_64../dri/i915_dri.so
Both owner and group are root. (not helpful)

Web search does not give me anything better information.

Question
What else should I check?

Thank you in advance.

Last edited by kaz2100; 09-07-2016 at 04:02 PM. Reason: typo drn -> drm
 
Old 09-07-2016, 07:32 PM   #2
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 7,068

Rep: Reputation: Disabled
Code:
~ $ ls -l /dev/dri/card0 
crw-rw---- 1 root video 226, 0 Sep  7 18:57 /dev/dri/card0
 
Old 09-07-2016, 07:57 PM   #3
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,745

Original Poster
Rep: Reputation: 107Reputation: 107
Self reply.


This thread gave me a solution. xorg.conf file does the job.

For some unknown reason, I was confident that checking permission or privilege would be correct.

Not quite solved, but my penguin got back again.

cheers
 
Old 09-07-2016, 08:15 PM   #4
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,745

Original Poster
Rep: Reputation: 107Reputation: 107
Hya

Emerson, Thank you for your reply..

Now (x is working with xorg.conf), it is root video.

I am confused. Why did x not kick in?

Following I did, since my post #1.

remove xorg-xserver-input-kbd (for historical reason, it existed. -> did not work.
reinstall xorg packages. -> did not work.
dist-upgrade -> did not work.

tried with xorg.conf -> WORKED!

postconfig related?

I will investigate and update.


+++ added.
Without xorg.conf, it is root video.

Last edited by kaz2100; 09-07-2016 at 08:23 PM. Reason: wrong info corrected, additional info
 
Old 09-08-2016, 02:38 AM   #5
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,745

Original Poster
Rep: Reputation: 107Reputation: 107
Self reply

I compared several logs, but not much progress.

Comparing Xorg.0.log (root and user):
I thought
Code:
(II) FBDEV: driver for framebuffer: fbdev
(II) VESA: driver for VESA chipsets: vesa
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
The last line in magenta looked like the one to blame. It shows up in only user log.

However, it shows in log with config file also. So, my assumption is probably wrong.

Comparing logs with or without config file,
Code:
WithOut xorg.conf
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
        compiled for 1.18.4, module version = 1.0.0
        ABI class: X.Org Server Extension, version 9.0
(==) AIGLX enabled
(==) Matched modesetting as autoconfigured driver 0
(==) Matched fbdev as autoconfigured driver 1
(==) Matched vesa as autoconfigured driver 2
(==) Assigned the driver to the xf86ConfigLayout


With xorg.conf
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
        compiled for 1.18.4, module version = 1.0.0
        ABI class: X.Org Server Extension, version 9.0
(==) AIGLX enabled
(II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
        compiled for 1.18.3, module version = 2.99.917
        Module class: X.Org Video Driver
They start to be different at blocks in red.

And not much difference before, which is
Code:
(**) |-->Screen "Default Screen Section" (0)
(**) | |-->Monitor "<default monitor>"
I will update.

cheers
 
Old 09-13-2016, 11:58 PM   #6
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,745

Original Poster
Rep: Reputation: 107Reputation: 107
Self reply.

Not much progress, but

Another node, upgraded same day, graphic driver is i915 also, has no trouble with X.

When X is started through ssh-connected terminal, (ssh -Y to dead node, with root permission)
desktop shows up on non ssh-connected LCD. (checked without conf file. I guess it would die with error)

cheers
 
Old 03-24-2017, 10:15 PM   #7
qdbp
LQ Newbie
 
Registered: Mar 2017
Posts: 1

Rep: Reputation: Disabled
Check the contents of /sys/kernel/debug/dri/0/clients and make sure no application has grabbed master. I ran into this issue and it turns out I was running redshift in -m drm mode before trying to startx, which blocked X.
 
Old 04-25-2017, 08:06 PM   #8
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,745

Original Poster
Rep: Reputation: 107Reputation: 107
Hya

Quote:
Originally Posted by qdbp View Post
Check the contents of /sys/kernel/debug/dri/0/clients and make sure no application has grabbed master. I ran into this issue and it turns out I was running redshift in -m drm mode before trying to startx, which blocked X.
Thanks for your comment. However, for some reason my penguin does not have "clients" under /sys/...

BTW, my penguin still has xorg.conf (have not tried without it since then)
 
Old 12-09-2018, 07:43 AM   #9
maxeuer
LQ Newbie
 
Registered: Jun 2004
Posts: 17

Rep: Reputation: 0
Xorg.log: drmSetMaster,etc. "Permission denied"

(Re)install libpam-systemd [Debian9 as of 2018]
I accidentally removed this package.
Symptoms were: no 2nd Graph. screen possible
Errors in Xorg.n.log:
systemd-logind: failed to get session: PID 1573 does not belong to any known session
xfree86: adding drm device /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
 
  


Reply

Tags
dri, error, permission, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
setversion 1.4 failed: Permission denied RandomTroll Linux - Software 3 01-10-2015 06:09 AM
udevd - rmdir(/dev/.udev/failed) failed: Permission denied pbhj Slackware 20 03-21-2008 10:46 AM
Failed to send mail : Write failed : Permission denied shawnbishop Linux - Software 1 03-27-2006 01:50 PM
php failed: Permission denied (13) in rino.caldelli Linux - Software 2 03-18-2006 11:25 AM
Wine Installation failed, permission denied enegron Linux - Newbie 4 10-15-2003 03:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration