LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Driver for nVidia 6800 GT on debian 10.2 "Buster" (https://www.linuxquestions.org/questions/debian-26/driver-for-nvidia-6800-gt-on-debian-10-2-buster-4175669623/)

lukeer 02-14-2020 06:59 PM

Driver for nVidia 6800 GT on debian 10.2 "Buster"
 
Hi there,

this Linux box needed an upgrade. Debian 10.2 installed fine but didn't get the graphics driver right automatically.

We have here an nVidia 6800 GT.

With nouveau, the colours are weird, psychadelic, wrong. Where there should be a smooth gradient, we get clearly visible stripes of a lot less colours than 24 bit should be able to produce. Orange turns light blue, white stays white. There's a lot of gray on this site (which should be some blue, IIRC), which makes reading the black text impossible without highlighting it.

from /var/log/Xorg.0.log:
Code:

(II) [drm] nouveau interface version: 1.3.1
[    19.931] (II) Loading sub module "dri2"
[    19.931] (II) LoadModule: "dri2"
[    19.931] (II) Module "dri2" already built-in
[    19.931] (--) NOUVEAU(0): Chipset: "NVIDIA NV40"
[    19.931] (==) NOUVEAU(0): Depth 24, (--) framebuffer bpp 32 # <<< here?
[    19.931] (==) NOUVEAU(0): RGB weight 888
[    19.931] (==) NOUVEAU(0): Default visual is TrueColor

Can there be a problem in the marked line? Or is that completely normal to have a framebuffer with different colour depth from ... whatever?

Starting with the kernel option nomodeset, we get correct colours, but the resolution cannot get over 1024x768, which is undesirable on a FullHD screen.
Creating new modelines with cvt works but they cannot be added through xrandr because there are no output names, just "+default".

The nVidia proprietary driver doesn't seem like an option atm. Buster provides nvidia-legacy back to 340, but the 6800 GT is last supported by 304. I tried adding stretch to /etc/apt/sources.lst, but nvidia-legacy-304xx won't install due to dependencies which apt says are impossible to install.

Is there some configuration for nouveau, which can mitigate the colour problem?

mrmazda 02-14-2020 09:28 PM

What made it "need" an updgrade? Was everything working well no longer? Upgrade from what? How was it upgraded? If upgrade rather than fresh installation, do any remnants of any NVidia driver remain in /etc/X11/xorg.con* or /lib/? They well can prevent proper FOSS DDX operation.

Try purging xserver-xorg-video-nouveau. The much newer modesetting (upstream) default DDX should then automatically be used. It works for me using NVidia GPUs both newer and older than yours.

Nomodeset is a troubleshooting tool, intended only for temporary use.

The marked line is no issue. Lines with (EE) should be the only ones of a serious nature. (WW) warnings usually are non-serious. EE lines reporting "Failed to load module" can be ignored as long as any appropriate module loads and stays loaded.

lukeer 02-15-2020 02:58 AM

It was a MythBuntu 12.04 based on (you guessed that) Ubutnut 12.04 and therefore long out of security update time.
MythBuntu doesn't exist any longer, so I did a fresh install.

I'll try that modesetting thin I've never heard about until now. Thanks.

ondoho 02-15-2020 06:40 AM

^ so it's SOLVED through reinstall?

lukeer 02-15-2020 02:38 PM

Not yet.
When trying to purge the nouveau driver, this is what apt tells me:
Code:

root@hostname:/home/user# apt-get purge xserver-xorg-video-nouveau
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.     
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt: (installed automatically and not needed any longer)
  acl coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5
  coinor-libcoinutils3v5 coinor-libosi1v5 crda cups-client cups-pk-helper
  dns-root-data dnsmasq-base espeak-ng-data exfalso fonts-dejavu
  fonts-font-awesome fonts-lato fonts-linuxlibertine fonts-noto-core
  fonts-noto-ui-core fonts-roboto-slab fonts-sil-gentium
  fonts-sil-gentium-basic gimp-data gir1.2-atk-1.0 gir1.2-atspi-2.0
  gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gst-plugins-base-1.0
  gir1.2-gstreamer-1.0 gir1.2-gtk-3.0 gir1.2-gtksource-3.0
  gir1.2-javascriptcoregtk-4.0 gir1.2-keybinder-3.0 gir1.2-notify-0.7
  gir1.2-packagekitglib-1.0 gir1.2-pango-1.0 gir1.2-polkit-1.0 gir1.2-secret-1
  gir1.2-soup-2.4 gir1.2-webkit2-4.0 gir1.2-wnck-3.0 gnome-keyring
  gnome-keyring-pkcs11 hyphen-en-us iw libamd2 libao-common libao4
  libappstream4 libatk-adaptor libaudio2 libayatana-appindicator3-1
  libayatana-ido3-0.4-0 libayatana-indicator3-7 libbabl-0.1-0 libblas3
  libbluetooth3 libbrlapi0.6 libbsh-java libcamd2 libccolamd2 libcdr-0.1-1
  libcholmod3 libcolamd2 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdotconf0
  libespeak-ng1 libexiv2-14 libfreehand-0.1-1 libgd3 libgegl-0.4-0
  libgegl-common libgexiv2-2 libgfortran5 libgimp2.0 libglib2.0-bin
  libgphoto2-6 libgphoto2-l10n libgphoto2-port12 libieee1284-3 libjim0.77
  libjs-jquery libjs-modernizr libjs-sphinxdoc libjs-underscore liblapack3
  liblouis-data liblouis17 libmariadb3 libmbim-glib4 libmbim-proxy libmetis5
  libmm-glib0 libmspub-0.1-1 libndp0 libnl-3-200 libnl-genl-3-200
  libnl-route-3-200 libnm0 libnma0 libpackagekit-glib2-18 libpagemaker-0.0-0
  libpam-gnome-keyring libpangoxft-1.0-0 libpcaudio0 libqmi-glib5 libqmi-proxy
  libquadmath0 libqxp-0.0-0 libraw19 libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-calc libreoffice-draw
  libreoffice-gtk2 libreoffice-help-en-us libreoffice-impress
  libreoffice-librelogo libreoffice-nlpsolver libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-wiki-publisher libsane libsane-common libsnmp-base libsnmp30
  libsonic0 libspeechd2 libstemmer0d libsuitesparseconfig5 libteamdctl0
  libu2f-udev libumfpack5 libvisio-0.1-1 libyaml-0-2 libzmf-0.0-0 lp-solve
  mariadb-common mobile-broadband-provider-info modemmanager mysql-common
  mythes-en-us network-manager network-manager-gnome orca p11-kit
  p11-kit-modules packagekit packagekit-tools python3-brlapi python3-cairo
  python3-cups python3-cupshelpers python3-dbus python3-feedparser
  python3-gi-cairo python3-gst-1.0 python3-louis python3-musicbrainzngs
  python3-mutagen python3-pyatspi python3-pyinotify python3-smbc
  python3-speechd python3-xdg quodlibet sane-utils sound-icons
  speech-dispatcher speech-dispatcher-audio-plugins
  speech-dispatcher-espeak-ng sphinx-rtd-theme-common system-config-printer
  system-config-printer-common system-config-printer-udev update-inetd
  usb-modeswitch usb-modeswitch-data wireless-regdb wpasupplicant xbrlapi
  xsane xsane-common
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  task-desktop* task-xfce-desktop* xserver-xorg-video-all*
  xserver-xorg-video-nouveau*
0 aktualisiert, 0 neu installiert, 4 zu entfernen und 0 nicht aktualisiert.
Nach dieser Operation werden 552 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]

Just a wild guess: All those to-be-removed packets don't relate to purging nouveau at all. That's another problem. Isn't it?

But those last four packets are troubling me. Will X still work after "task-xfce-desktop" has been removed?

A few hours ago, I have been here, done that already. The NIC stopped working and I don't know what else. So I re-installed debian 10 from my CD just now. Have a completely ootb system now.

mrmazda 02-15-2020 05:01 PM

Quote:

Originally Posted by lukeer (Post 6090453)
Code:

...
task-desktop* task-xfce-desktop* xserver-xorg-video-all*
...

Will X still work after "task-xfce-desktop" has been removed?

Yes. Those 3 are meta-packages. They cause other packages to be installed. Removing them doesn't cause other packages to be removed. OTOH, autoremove would probably remove some packages you wouldn't want removed.

lukeer 02-16-2020 08:10 AM

Hi again!

I tried purging the package xserver-xorg-video-nouveau (which includes the 3 other packages mentioned above) and rebooted after that.

But that didn't work out as expected. Colours are still distorted.

There still seems a nouveau to be running somewhere in the system:
Code:

user@host:~$ lsmod | grep nouveau
nouveau              2179072  3
mxm_wmi                16384  1 nouveau
wmi                    28672  2 mxm_wmi,nouveau
video                  45056  1 nouveau
i2c_algo_bit          16384  2 bttv,nouveau
ttm                  131072  1 nouveau
drm_kms_helper        208896  1 nouveau
drm                  495616  7 sil164,drm_kms_helper,ttm,nouveau
button                16384  1 nouveau

What else to do so nouveau won't load?

ondoho 02-16-2020 12:18 PM

You can blacklist nouveau.
Do you have an appropriate video driver to take over, or do you just want to use the fallback driver?

lukeer 02-16-2020 01:00 PM

I'm trying to follow mrmazda's advice to use the "modesetting (upstream) default DDX".

mrmazda 02-16-2020 01:13 PM

Blacklisting the nouveau kernel driver will defeat both DDX, nouveau (xserver-xorg-video-nouveau) and modesetting (upstream default, provided by server package). Without any installed proprietary driver, the blacklisting forces use of either the fbdev or vesa driver, both of which are very slow, and limited in available modes, usually to only a small selection of low resolution 4:3 aspect modes.

Strange colors behavior is typical of hardware failure, either a cable connector, cable, or the RAM or one or more capacitors on the gfxcard. Possibly removing and reinserting the 6800GT in its slot could help. That the colors problem goes away when nomodeset forces use of a generic fallback driver suggests to me the problem is more likely failing/failed gfxcard RAM, or an overheat failure from a failed fan.

A 6800GT comes from an era when capacitor longevity was a common problem. My much newer 8600GT was such a victim, but I was able to replace its bad caps, so it's still in service using the modesetting DDX. Badcaps.net describes the caps problem with example images, and possible replacement solutions.

lukeer 02-16-2020 06:46 PM

We can rule out the hardware problem because booting either MythBuntu 10.04 or SystemRescueCD (don't know what version atm) from CD results in perfectly fine image, both resolution and colours.

mrmazda 02-16-2020 06:54 PM

Quote:

Originally Posted by lukeer (Post 6090908)
We can rule out the hardware problem because booting either MythBuntu 10.04 or SystemRescueCD (don't know what version atm) from CD results in perfectly fine image, both resolution and colours.

You know for a fact that both 10.04 installed or from CD/DVD and SystemRescueCD from CD now will run in your display's native mode rather than 1024x768? That hadn't been made clear to me.

ondoho 02-17-2020 03:38 AM

I recommend trying the proper legacy proprietary driver for this.
How to find the proper one.

lukeer 02-17-2020 09:56 AM

Quote:

Originally Posted by mrmazda (Post 6090909)
10.04 [..] from CD [..] and SystemRescueCD from CD now will run [..]? That hadn't been made clear to me.

Sorry for that. I tried both just yesterday.

Quote:

Originally Posted by self (Post 6090148)
Buster [=Debian 10] provides nvidia-legacy back to 340, but the 6800 GT is last supported by 304. I tried adding stretch [=Debian 9, latest version to support 304] to /etc/apt/sources.lst, but nvidia-legacy-304xx won't install due to dependencies which apt says are impossible to install.

I need the nvidia-legacy-304xx driver.

mrmazda 02-17-2020 01:10 PM

Do you have space available to install Stretch? That should enable installation of legacy 304 so that at least you could find out if it's any better, and should be supported until more than two years at least from now.


All times are GMT -5. The time now is 11:04 AM.