LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-08-2018, 08:29 PM   #1
KS4
LQ Newbie
 
Registered: Jan 2018
Posts: 5

Rep: Reputation: Disabled
Cool Double Click Not Working In Debian/Kali, Logitech mouse


Hello,

I'm KS, here is my issue, I cannot double click with my logitech wireless mouse or the built in touch pad. I've followed some stuff below with no result.


how-to-enable-double-click

linux-laptop-and-netbook-25/touchpad-double-click-doesnt-work-

In order to open things, resize windows, etc I have to right click and select "Open"

MACHINE=Gateway NE56R41u

OS=Linux KG 4.14.0-kali1-amd64 #1 SMP Debian 4.14.2-1kali1 (2017-12-04) x86_64 GNU/Linux


OUTPUT=below

#lsusb
Bus 002 Device 003: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04f2:b374 Chicony Electronics Co., Ltd
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
# dmesg | grep Logitech
[ 2.616206] usb 2-1.2: Manufacturer: Logitech
[ 2.625466] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/0003:046D:C52F.0001/input/input3
[ 2.625539] hid-generic 0003:046D:C52F.0001: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:1d.0-1.2/input0
[ 2.625729] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.1/0003:046D:C52F.0002/input/input4
[ 2.684488] hid-generic 0003:046D:C52F.0002: input,hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:1d.0-1.2/input1
root@KG:~# egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices
N: Name="ETPS/2 Elantech Touchpad"
# dmesg | grep Elan
[ 2.844530] psmouse serio1: elantech: Elan sample query result 04, 0b, 00
[ 2.976395] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input2
# dmesg | grep mouse
[ 1.492548] mousedev: PS/2 mouse device common for all mice
[ 2.797233] psmouse serio1: elantech: assuming hardware version 3 (with firmware version 0x450f01)
[ 2.820402] psmouse serio1: elantech: Synaptics capabilities query result 0x68, 0x15, 0x0a.
[ 2.844530] psmouse serio1: elantech: Elan sample query result 04, 0b, 00

ANYTHING YOU CAN OFFER IS GREATLY APPRECIATED
THANK YOU

-K
 
Old 01-09-2018, 04:18 AM   #2
Hostech_Support
Member
 
Registered: Oct 2017
Location: India
Posts: 41

Rep: Reputation: Disabled
hello KS4,
Please enable double click option in System Settings > Mouse and TouchPad OR if that doesn't work, it must be device driver issue, If still the problem persists then check device drivers are not installed properly.

Last edited by Hostech_Support; 01-10-2018 at 03:17 AM.
 
Old 01-09-2018, 05:24 PM   #3
KS4
LQ Newbie
 
Registered: Jan 2018
Posts: 5

Original Poster
Rep: Reputation: Disabled
There is no double click option and my dmesg says my drivers are fine
 
Old 01-09-2018, 08:25 PM   #4
flshope
Member
 
Registered: Jul 2009
Location: Tennessee (United States)
Distribution: Debian 10.8, Ubuntu 20.04.2 and 16.04.7, Android 10
Posts: 230
Blog Entries: 43

Rep: Reputation: 78
I am running Debian 9.3 and I don't know what might be different in Kali. In Debian, I open Files (sometimes called Nautilus), click on a Files icon in the upper left of the Files window, click on Preferences, then Behavior. There I can choose either single or double click to open items. I doubt that this affects applications other than Files.

I am using a Logitech wired mouse.
 
Old 01-10-2018, 03:08 AM   #5
KS4
LQ Newbie
 
Registered: Jan 2018
Posts: 5

Original Poster
Rep: Reputation: Disabled
WORKAROUND

Quote:
Originally Posted by flshope View Post
I am running Debian 9.3 and I don't know what might be different in Kali. In Debian, I open Files (sometimes called Nautilus), click on a Files icon in the upper left of the Files window, click on Preferences, then Behavior. There I can choose either single or double click to open items. I doubt that this affects applications other than Files.

I am using a Logitech wired mouse.
Yeah that doesn't solve the whole issue but its a work around if you can adapt to not double clicking. When I goto mouse and touch pad settings there a spot for test settings... in that test you can only get single clicks.... only other computers with same os the double click test passes

Additionally its not just the wireless or wired mouse or even the touch pad... all psmouse devices fail double click

Thanks

-K
 
Old 05-20-2018, 11:31 PM   #6
akshat1984
LQ Newbie
 
Registered: May 2018
Location: India
Posts: 1

Rep: Reputation: Disabled
Double clicking is a hardware issue and can only be solved by replacing the mouse micro switch.
 
Old 05-25-2018, 07:03 AM   #7
KS4
LQ Newbie
 
Registered: Jan 2018
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by akshat1984 View Post
Double clicking is a hardware issue and can only be solved by replacing the mouse micro switch.
Dude go back and read I just explained I have used the same external mouse with no problems on a different kali machine. THIS IS DEFINITELY NOT PHYSICAL HARDWARE ISSUES YOU. DON'T WASTE PEOPLE'S TIME CAUSE YOU CAN'T READ.

Last edited by KS4; 05-25-2018 at 07:28 AM.
 
Old 05-25-2018, 07:25 AM   #8
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,194

Rep: Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040
KS4: correct your language. Thread is reported.

jlinkels
 
2 members found this post helpful.
Old 05-25-2018, 04:23 PM   #9
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Ubuntu, Debian, Slackware
Posts: 2,151
Blog Entries: 6

Rep: Reputation: 2433Reputation: 2433Reputation: 2433Reputation: 2433Reputation: 2433Reputation: 2433Reputation: 2433Reputation: 2433Reputation: 2433Reputation: 2433Reputation: 2433
There is one very simple way to solve your issue, OP, uninstall Kali. It's for professionals only.
 
1 members found this post helpful.
Old 05-26-2018, 10:12 AM   #10
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 13,424

Rep: Reputation: 3986Reputation: 3986Reputation: 3986Reputation: 3986Reputation: 3986Reputation: 3986Reputation: 3986Reputation: 3986Reputation: 3986Reputation: 3986Reputation: 3986
@KS4, welcome to LQ. We aim to be friendly and welcome to all. Shouting and the language you used before the edit isn't acceptable. Please refrain from this behavior moving forward.

--jeremy
 
Old 05-29-2018, 05:36 PM   #11
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
There's a setting for double click speed. Try adjusting that. I just can't imagine everything else working but double click on the touchpad and on an external mouse. So, check that out. Also try double clicking at different speeds.
 
Old 06-01-2018, 06:31 AM   #12
KS4
LQ Newbie
 
Registered: Jan 2018
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by AwesomeMachine View Post
There's a setting for double click speed. Try adjusting that. I just can't imagine everything else working but double click on the touchpad and on an external mouse. So, check that out. Also try double clicking at different speeds.
Believe it or not there is no slider for double click speed in my installation even after recent updates etc..... I've tried double clicking at different speeds slow, fast, super fast, insanely fast, etc... Nothing nada and nope... Any other ideas and btw thank you for fully understanding my question this has been puzzling me for months.
 
Old 06-01-2018, 06:58 AM   #13
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 16,255

Rep: Reputation: 5455Reputation: 5455Reputation: 5455Reputation: 5455Reputation: 5455Reputation: 5455Reputation: 5455Reputation: 5455Reputation: 5455Reputation: 5455Reputation: 5455
in that case I would rather say it is a GUI configuration issue, that event is simply not bound to anywhere.
 
Old 06-04-2018, 09:24 AM   #14
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
This seems to be a gnome feature. In gnome-tweak-tool you can set it back to normal.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Single-Click-Drag Interpreted as Double Click artvarck Linux - Desktop 1 03-11-2014 07:47 AM
Single mouse click acts as a double click TheIndependentAquarius Linux - Hardware 9 08-31-2010 01:50 AM
mapping Logitech mouse thumb button to double-click buldir Linux - Hardware 3 12-04-2004 09:11 PM
Logitech First Mouse+ PS2 double click jang Linux - General 2 12-11-2002 01:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration