LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   DNS IPv6 Queries Fail (https://www.linuxquestions.org/questions/debian-26/dns-ipv6-queries-fail-278205/)

kawauso-kun 01-15-2005 05:12 PM

DNS IPv6 Queries Fail
 
I just got DSL and hooked everything up, and it all works fine in Windows. However, I'm having a DNS resolution problem in Linux...

When I try to resolve with Mozilla or Gaim or similar programs, they try three times with IPv6-style queries, i.e., AAAA queries. These (seem) to be dropped by the DSL modem, which is acting as the DNS server, though I'm sure it's only translating. Then the program (they all act the same way) gives up and uses a normal A query and it works perfectly. I've blacklisted and aliased the ipv6 module to off as per instructions I found online, but lsmod still tells me it's loaded. This happens in kernel 2.6.7 and 2.6.9 (I've heard it's supposed to be fixed in 2.6.9). I'd prefer 2.6.7 as that's where my nvidia X11 driver works. Any more suggestions to either remove IPv6 or reduce the timeout to something tiny?

Incidentally, both DiG and nslookup work the first time -- Ethereal tells me they try the A query first.

Thanks in advance,
Phillip

kawauso-kun 01-15-2005 05:31 PM

Fixed
 
Fixed this -- since the Netopia modem Earthlink (my ISP) sent drops AAAA queries, I just went the the modem status page, checked to see what DNS servers it was using, and set that to be the default assigned from the router.


All times are GMT -5. The time now is 12:10 PM.