Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 06-16-2004, 10:16 PM   #1
Registered: May 2003
Location: lake michigan
Distribution: Debian, Mint, Slackware
Posts: 457

Rep: Reputation: 35
dma at boot, which rc.* to use

Just have a quick question about wanting to enable DMA on my new debian install.
I previously ran slackware and added the line
hdparm blahblah /dev/hda to the rc.d/rc.local and it worked great.
Just curous about how to do the same in Debian, where to add the line and/or what I have to do.

Thanks in advance
Old 06-16-2004, 10:56 PM   #2
LQ Newbie
Registered: Dec 2003
Location: texas
Distribution: RH9 looking at Deb
Posts: 19

Rep: Reputation: 0

My system (sarge 2.4.26-1-k7 #1) defaults to dma=1 for /dev/hda/
Checkout the /etc/hdparm.conf file.
Old 06-16-2004, 11:04 PM   #3
Registered: May 2003
Location: lake michigan
Distribution: Debian, Mint, Slackware
Posts: 457

Original Poster
Rep: Reputation: 35
oh great! thanks for the reply. Im still getting used to system v LOL
Old 06-16-2004, 11:47 PM   #4
Dead Parrot
Senior Member
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Also check out that you actually have the hdparm package installed. /etc/hdparm.conf makes no difference if you haven't got the actual hdparm package installed.

AFAIK, Sarge ships with DMA enabled and you don't need hdparm to change that.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
hda1 /boot dma problem chadi Linux - General 2 12-21-2004 10:42 AM
boot problems dma errors rakesh_em Slackware 2 10-05-2004 01:48 PM
dma problems with the 2.6.6 at boot time rabbit171 Linux - Newbie 1 07-30-2004 11:40 AM
hde:DMA disabled at boot up. HELP!!!! carboncopy Slackware 4 07-16-2004 09:14 AM
How to enable DMA at boot-up time reyemarr Debian 11 11-21-2003 01:38 PM > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:01 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration