LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-09-2007, 01:17 AM   #1
adityavpratap
Member
 
Registered: Dec 2004
Location: Hyderabad, India
Distribution: Slackware 13, Ubuntu 12.04
Posts: 438

Rep: Reputation: 32
Disk might not be spun down properly. Update shutdown utility


Hi!
I am getting the following error message while shutdown since I upgraded to kernel 2.6.22 on my Debian etch install -
Quote:
DISK MIGHT NOT BE SPUN DOWN PROPERLY. UPDATE SHUTDOWN UTILITY
For more info, visit http://linux-ata.org/shutdown.html
Can anyone suggest a way out? I visited that site but debian specific instructions are not available.
 
Old 09-09-2007, 07:20 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Edit /etc/init.d/halt, find the hddown="-h" and
change it to hddown="".
 
Old 09-14-2007, 07:53 AM   #3
adityavpratap
Member
 
Registered: Dec 2004
Location: Hyderabad, India
Distribution: Slackware 13, Ubuntu 12.04
Posts: 438

Original Poster
Rep: Reputation: 32
Ok, that works! Thanks a lot friend!
 
Old 10-12-2007, 01:08 PM   #4
Kirmonkey
Member
 
Registered: Jan 2004
Location: UK
Distribution: Debian
Posts: 194

Rep: Reputation: 30
How do you know that! (in amazed tone)
 
Old 10-12-2007, 02:03 PM   #5
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
I had the same problem and Googled it.
 
Old 10-12-2007, 07:17 PM   #6
justaguynpc
LQ Newbie
 
Registered: Jun 2005
Location: Muskoka, Ontario, Canada
Distribution: Debian Testing
Posts: 14

Rep: Reputation: 1
I had been meaning to get around to that issue, thanx for reminding me

Cheers
 
Old 10-16-2007, 01:34 PM   #7
esaym
Member
 
Registered: Nov 2006
Distribution: Lots of Debian
Posts: 165

Rep: Reputation: 32
Quote:
Originally Posted by AlucardZero View Post
Edit /etc/init.d/halt, find the hddown="-h" and
change it to hddown="".

I have 2 hddown entries:
Code:
	# Don't shut down drives if we're using RAID.
	hddown="-h"
	if grep -qs '^md.*active' /proc/mdstat
	then
		hddown=""
	fi

Should I just change the top one then?
 
Old 10-16-2007, 03:54 PM   #8
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
yes, that is correct.
 
Old 10-17-2007, 05:26 AM   #9
reverse
Member
 
Registered: Apr 2007
Distribution: Gentoo
Posts: 337

Rep: Reputation: 30
Quote:
Originally Posted by justaguynpc View Post
I had been meaning to get around to that issue, thanx for reminding me

Cheers
Double thanks.
 
Old 10-17-2007, 10:24 AM   #10
esaym
Member
 
Registered: Nov 2006
Distribution: Lots of Debian
Posts: 165

Rep: Reputation: 32
Quote:
Originally Posted by AlucardZero View Post
yes, that is correct.
Yea that's what I did. I think it fixed the problem. Something flashes on the screen in place of the previous error when the computer is halting. It displays a split second before the computer shuts off so I can't read it. I don't think it is an error though.
 
Old 11-07-2007, 06:43 AM   #11
Coyote34
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Rep: Reputation: 0
Same problem

Hi!

Have the same problem and I have fixed using the explanation above. But I newbie at linux and I would like to know if I have to reinstall my linux again? Did that problem damage my computer?

Thanks,

COYOTE34
 
Old 11-07-2007, 06:58 AM   #12
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 60
You should not have to reinstall. Even if the problem goes on without being fixed, it would most likely only damage your hardware after hundreds of bad shutdowns. Also, if your particular hardware really minded, then you would most likely know. What I mean is that people who reported significant problems with this could hear a loud thunk as the hard-drive spun down, then up, then down again a little too quickly. If you are really concerned and you don't especially need a 2.6.22 kernel, then you could downgrade your kernel to 2.6.21 or 2.6.18 (which didn't have this problem).
 
Old 11-13-2007, 12:36 PM   #13
ultr
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Rep: Reputation: 0
Question

Hello,

Can you tell me more about the problem with shutdown? I'm getting the warning before power-off, but I cannot hear _any_ parking sound. However on other forums I have found reports, that the bug causes the drive to do parking twice very quickly.

Quote:
Originally Posted by AlucardZero View Post
Edit /etc/init.d/halt, find the hddown="-h" and
change it to hddown="".
What does this line do? I would just like to know what am I doing I googled a bit, and couldn't find a clear answer.

I am using Debian testing (Lenny). Should I update my `shutdown`?

To sum up, I just want to know if anything may happen to my drive. It's a new 250GB disk, and I have quite important data on it.



Regards,

Piotr Dąbrowski

Last edited by ultr; 11-13-2007 at 04:48 PM.
 
Old 11-13-2007, 07:11 PM   #14
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 60
As I said above, if you are very nervous, then the easiest complete fix is to downgrade your kernel (say to 2.6.18-5 from Etch). I'm not an expert on the issue, but here's my rough understanding: the kernel (as of 2.6.22) issues a shutdown sequence and the operating system also initiates a shutdown sequence (as it always used to). The two overlapping sequences get f&*$%ed up (that's the technical term), and the system can (1) get told (by one side) to spindown, (2) get a command (from the other side) that causes it to spin up again and then (3) get a final command to shut down entirely (and quickly?!?). The result is a hard change in direction that can cause a noticeable clunk on some drives. You do that enough times and your drive is f&*$%ed. However, a few people on a kernel irc channel said that "enough times" means in the hundreds.

For me, it's not worth the worry, so I left the kernel on both my boxes at 2.6.21 (the last version before the trouble started for me).

Removing the "-h" from that file manually would seem to remove the Debian system calling for "halt" - that's certainly what the -h flag does in, eg, "shutdown -h now". Perhaps that fixes the conflicting messages and the problem. Again, I don't know enough to trust it, so I stuck with an earlier kernel.

Last edited by Telemachos; 11-13-2007 at 07:17 PM.
 
Old 11-14-2007, 01:58 AM   #15
Schalken
LQ Newbie
 
Registered: Mar 2006
Distribution: Debian/Ubuntu
Posts: 26

Rep: Reputation: 15
I am also having this problem on my Debian Testing (Lenny) installation. I have made the change to /etc/init.d/halt and am about to see if it works.

I hope the Debain guys can figure out how to fix this in the current default install of Lenny.

Edit: The edit to /etc/init.d/halt seems to have done the trick

Last edited by Schalken; 11-14-2007 at 06:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can not shutdown the computer properly michael! Linux - Hardware 2 09-25-2006 12:18 AM
Properly shutdown Haiyadragon Linux - Hardware 1 06-08-2006 10:22 AM
cannot shutdown properly space_beyond Linux - Security 7 07-15-2005 12:17 PM
redhat linux update databse's type and utility like windows update services kamii47 Linux - General 1 04-18-2005 05:50 AM
Can't shutdown properly hus Linux - Newbie 5 01-01-2004 04:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration