LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 05-04-2011, 07:35 AM   #1
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Rep: Reputation: 50
disable any kind of automounting in Gnome


hi

I have squeeze with gnome (gdm3) desktop.
Howto disable any kind of device automounting in gnome?

Last edited by cccc; 05-04-2011 at 07:46 AM.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 05-04-2011, 08:02 AM   #2
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello,

Maybe this link will help: http://www.cyberciti.biz/faq/disable...-automounting/. As always Google provides.

Kind regards,

Eric
 
Old 05-04-2011, 08:31 AM   #3
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by EricTRA View Post
Hello,

Maybe this link will help: http://www.cyberciti.biz/faq/disable...-automounting/. As always Google provides.

Kind regards,

Eric
I've tried and it doesn't work.
BTW this is for Fedora and not for Debian.
 
Old 05-04-2011, 08:42 AM   #4
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

I've noticed it's for Fedora but that doesn't matter much in this case since it refers to Gnome. What error do you get? Does the value in the xml file get changed correctly? Most likely you'd have to logout and login again for the changes to take effect.

Kind regards,

Eric
 
Old 05-04-2011, 08:47 AM   #5
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by EricTRA View Post
Hi,

I've noticed it's for Fedora but that doesn't matter much in this case since it refers to Gnome. What error do you get? Does the value in the xml file get changed correctly? Most likely you'd have to logout and login again for the changes to take effect.

Kind regards,

Eric
No errors, the value was changed correctly, after restart the computer it doesn't work.
 
Old 05-04-2011, 08:49 AM   #6
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
I've solved this problem!

Configuring Automounting

To enable or disable automount open a terminal and type gconf-editor followed by the [Enter] key.

Browse to /apps/nautilus/preferences/media_automount.

The media_automount key controls whether to automatically mount media. If set to true, then Nautilus will automatically mount media such as user-visible hard disks and removable media on start-up and media insertion.

There is another key /apps/nautilus/preferences/media_automount_open. This controls whether to automatically open a folder for automounted media. This key can also be set in the Nautilus (file manager) window. From the Edit menu in Nautilus select Preferences and then select the Media tab.

If set to true, then Nautilus will automatically open a folder when media is automounted. This only applies to media where no known x-content/* type was detected; for media where a known x-content type is detected, the user configurable action will be taken instead. This can be configured as shown below.

greetings
cccc

Last edited by cccc; 05-04-2011 at 08:51 AM.
 
2 members found this post helpful.
Old 05-04-2011, 08:52 AM   #7
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Great, thanks for sharing the solution to your problem.

Kind regards,

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable any kind of stanby-mode under Gnome cccc Debian 7 04-25-2011 05:57 PM
Disable Automounting paldebojyoti Linux - Distributions 6 08-18-2009 09:34 AM
disable automounting Skaperen Ubuntu 3 07-17-2009 06:01 AM
How to disable automounting in SLAX? Albo74 Linux - Newbie 1 03-21-2009 05:41 PM
Disable any kind of network trasfer athv_gr Linux - Networking 1 09-18-2008 05:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration